[ANN] Groovy-Eclipse 2.1 compiler support and Kepler builds now available

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[ANN] Groovy-Eclipse 2.1 compiler support and Kepler builds now available

Andrew Eisenberg
Today is your lucky day! Two announcements for the price of one.

Groovy-Eclipse now supports the Groovy 2.1 compiler as an optional
add-on (Eclipse 3.8, 4.2, and 4.3 builds only). You can install from
the snapshot update site.  The new @DelegatesTo annotation is
supported as well.

Also, we now have Eclipse 4.3 (Kepler) support for Groovy-Eclipse.
These are snapshot builds only and installing Groovy-Eclipse 4.3 will
downgrade your JDT to use the 3.8 JDT (i.e, the JDT for the Juno
release).  This is less scary than it sounds since there are few
changes between the 3.8 and 3.9 JDT versions.

Eclipse 4.2 and 4.3 update sites (with Groovy 2.1 support):
        http://dist.springsource.org/snapshot/GRECLIPSE/e4.2/
        http://dist.springsource.org/snapshot/GRECLIPSE/e4.2/

In order to keep our build process simpler and shorter, we will no
longer be shipping regular snapshots (or new releases of)
Groovy-Eclipse for Eclipse 3.7 (Indigo). If there are requests for
specific builds then we can create them.

See here for more information on how to install:
http://docs.codehaus.org/display/GROOVY/Eclipse+Plugin Feedback is
welcome.

thanks all,
Andrew

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email