[ANN] Groovy-Eclipse 2.6.1 Released

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[ANN] Groovy-Eclipse 2.6.1 Released

Andrew Eisenberg-2
Hi all,

The Groovy-Eclipse team is proud to announce the 2.6.1 release.  We
have fixed over 100 issues including support for better content
assist, navigation, and type inferencing.  In addition, we are
continuing to implement new quick fixes.  You can find the wonderful
details in the new and noteworthy:

http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+2.6.1+New+and+Noteworthy

If you want to start using this version, the bits are available from
the release update site.
For Eclipse 3.7:
http://dist.springsource.org/release/GRECLIPSE/e3.7/
For Eclipse 3.6:
http://dist.springsource.org/release/GRECLIPSE/e3.6/

Additionally, we now have support for Eclipse 4.2M5.  This is still a
beta build and so is not officially part of this release.  The update
site is here:
http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e4.2/

Please send your comments to this mailing list and raise issues here:
http://jira.codehaus.org/browse/GRECLIPSE

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: [ANN] Groovy-Eclipse 2.6.1 Released

Matthias Hryniszak
Hi,

I've just installed the 2.6.1 via STS 2.9.0 M2. I have the following problem while importing groovy-eclipse compiled projects:

CoreException: Could not get the value for parameter compilerId for plugin execution default-compile: PluginResolutionException: Plugin org.apache.maven.plugins:maven-compiler-plugin:2.3.2 or one of its dependencies could not be resolved: Failed to collect dependencies for org.apache.maven.plugins:maven-compiler-plugin:jar:2.3.2 (): ArtifactDescriptorException: Failed to read artifact descriptor for org.codehaus.groovy:groovy-eclipse-batch:jar:1.7.10-02: ArtifactResolutionException: Failure to transfer org.codehaus.groovy:groovy-eclipse-batch:pom:1.7.10-02 from http://repo1.maven.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact org.codehaus.groovy:groovy-eclipse-batch:pom:1.7.10-02 from/to central (http://repo1.maven.org/maven2): The operation was cancelled.

Could you take a look at the enclosed pom.xml and tell me what am I doing wrong?

Matthias

2012/3/5 Andrew Eisenberg <[hidden email]>
Hi all,

The Groovy-Eclipse team is proud to announce the 2.6.1 release.  We
have fixed over 100 issues including support for better content
assist, navigation, and type inferencing.  In addition, we are
continuing to implement new quick fixes.  You can find the wonderful
details in the new and noteworthy:

http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+2.6.1+New+and+Noteworthy

If you want to start using this version, the bits are available from
the release update site.
For Eclipse 3.7:
http://dist.springsource.org/release/GRECLIPSE/e3.7/
For Eclipse 3.6:
http://dist.springsource.org/release/GRECLIPSE/e3.6/

Additionally, we now have support for Eclipse 4.2M5.  This is still a
beta build and so is not officially part of this release.  The update
site is here:
http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e4.2/

Please send your comments to this mailing list and raise issues here:
http://jira.codehaus.org/browse/GRECLIPSE

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email





---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email

pom.xml (3K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [ANN] Groovy-Eclipse 2.6.1 Released

Andrew Eisenberg
Hmmm...there's nothing obviously problematic in your pom.  I'm not
sure why maven is trying to download groovy-eclipse-batch 1.7.10-02
when you are explicitly using version 1.8.6--01.  A few questions,
though.

1. Was this working before you upgraded?
2. Is this working when you run mvn on the command line?

Also, a drastic measure would be to delete your ~/.m2/repository
directory and recreate your cache, but you can try a simpler thing to
delete just ~/.m2/repository/org/codehaus/groovy/groovy-eclipse-batch
and see if that helps.

On Mon, Mar 5, 2012 at 5:53 AM, Matthias Hryniszak <[hidden email]> wrote:

> Hi,
>
> I've just installed the 2.6.1 via STS 2.9.0 M2. I have the following problem
> while importing groovy-eclipse compiled projects:
>
> CoreException: Could not get the value for parameter compilerId for plugin
> execution default-compile: PluginResolutionException: Plugin
> org.apache.maven.plugins:maven-compiler-plugin:2.3.2 or one of its
> dependencies could not be resolved: Failed to collect dependencies for
> org.apache.maven.plugins:maven-compiler-plugin:jar:2.3.2 ():
> ArtifactDescriptorException: Failed to read artifact descriptor for
> org.codehaus.groovy:groovy-eclipse-batch:jar:1.7.10-02:
> ArtifactResolutionException: Failure to transfer
> org.codehaus.groovy:groovy-eclipse-batch:pom:1.7.10-02 from
> http://repo1.maven.org/maven2 was cached in the local repository, resolution
> will not be reattempted until the update interval of central has elapsed or
> updates are forced. Original error: Could not transfer artifact
> org.codehaus.groovy:groovy-eclipse-batch:pom:1.7.10-02 from/to central
> (http://repo1.maven.org/maven2): The operation was cancelled.
>
> Could you take a look at the enclosed pom.xml and tell me what am I doing
> wrong?
>
> Matthias
>
> 2012/3/5 Andrew Eisenberg <[hidden email]>
>>
>> Hi all,
>>
>> The Groovy-Eclipse team is proud to announce the 2.6.1 release.  We
>> have fixed over 100 issues including support for better content
>> assist, navigation, and type inferencing.  In addition, we are
>> continuing to implement new quick fixes.  You can find the wonderful
>> details in the new and noteworthy:
>>
>>
>> http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+2.6.1+New+and+Noteworthy
>>
>> If you want to start using this version, the bits are available from
>> the release update site.
>> For Eclipse 3.7:
>> http://dist.springsource.org/release/GRECLIPSE/e3.7/
>> For Eclipse 3.6:
>> http://dist.springsource.org/release/GRECLIPSE/e3.6/
>>
>> Additionally, we now have support for Eclipse 4.2M5.  This is still a
>> beta build and so is not officially part of this release.  The update
>> site is here:
>> http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e4.2/
>>
>> Please send your comments to this mailing list and raise issues here:
>> http://jira.codehaus.org/browse/GRECLIPSE
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: [ANN] Groovy-Eclipse 2.6.1 Released

Matthias Hryniszak
Well... It was kind of suspicious from the start since it did work on my other machine without problems. I was just curious what could have caused the difference between the two which is now obvious: my local repository was broken for reasons I still cannot understand...)

Anyways, clearing the folder you suggested did the trick.

Thanks!

Matthias

2012/3/5 Andrew Eisenberg <[hidden email]>
Hmmm...there's nothing obviously problematic in your pom.  I'm not
sure why maven is trying to download groovy-eclipse-batch 1.7.10-02
when you are explicitly using version 1.8.6--01.  A few questions,
though.

1. Was this working before you upgraded?
2. Is this working when you run mvn on the command line?

Also, a drastic measure would be to delete your ~/.m2/repository
directory and recreate your cache, but you can try a simpler thing to
delete just ~/.m2/repository/org/codehaus/groovy/groovy-eclipse-batch
and see if that helps.

On Mon, Mar 5, 2012 at 5:53 AM, Matthias Hryniszak <[hidden email]> wrote:
> Hi,
>
> I've just installed the 2.6.1 via STS 2.9.0 M2. I have the following problem
> while importing groovy-eclipse compiled projects:
>
> CoreException: Could not get the value for parameter compilerId for plugin
> execution default-compile: PluginResolutionException: Plugin
> org.apache.maven.plugins:maven-compiler-plugin:2.3.2 or one of its
> dependencies could not be resolved: Failed to collect dependencies for
> org.apache.maven.plugins:maven-compiler-plugin:jar:2.3.2 ():
> ArtifactDescriptorException: Failed to read artifact descriptor for
> org.codehaus.groovy:groovy-eclipse-batch:jar:1.7.10-02:
> ArtifactResolutionException: Failure to transfer
> org.codehaus.groovy:groovy-eclipse-batch:pom:1.7.10-02 from
> http://repo1.maven.org/maven2 was cached in the local repository, resolution
> will not be reattempted until the update interval of central has elapsed or
> updates are forced. Original error: Could not transfer artifact
> org.codehaus.groovy:groovy-eclipse-batch:pom:1.7.10-02 from/to central
> (http://repo1.maven.org/maven2): The operation was cancelled.
>
> Could you take a look at the enclosed pom.xml and tell me what am I doing
> wrong?
>
> Matthias
>
> 2012/3/5 Andrew Eisenberg <[hidden email]>
>>
>> Hi all,
>>
>> The Groovy-Eclipse team is proud to announce the 2.6.1 release.  We
>> have fixed over 100 issues including support for better content
>> assist, navigation, and type inferencing.  In addition, we are
>> continuing to implement new quick fixes.  You can find the wonderful
>> details in the new and noteworthy:
>>
>>
>> http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+2.6.1+New+and+Noteworthy
>>
>> If you want to start using this version, the bits are available from
>> the release update site.
>> For Eclipse 3.7:
>> http://dist.springsource.org/release/GRECLIPSE/e3.7/
>> For Eclipse 3.6:
>> http://dist.springsource.org/release/GRECLIPSE/e3.6/
>>
>> Additionally, we now have support for Eclipse 4.2M5.  This is still a
>> beta build and so is not officially part of this release.  The update
>> site is here:
>> http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e4.2/
>>
>> Please send your comments to this mailing list and raise issues here:
>> http://jira.codehaus.org/browse/GRECLIPSE
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: [ANN] Groovy-Eclipse 2.6.1 Released

Andrew Eisenberg
Had you just updated to STS 2.9.0M2 from 2.8.0 or earlier?  There's a
known problem that updating to the newer version of m2eclipse
(introduced in STS 2.8.1) may corrupt your m2 repository.

On Tue, Mar 6, 2012 at 12:53 AM, Matthias Hryniszak <[hidden email]> wrote:

> Well... It was kind of suspicious from the start since it did work on my
> other machine without problems. I was just curious what could have caused
> the difference between the two which is now obvious: my local repository was
> broken for reasons I still cannot understand...)
>
> Anyways, clearing the folder you suggested did the trick.
>
> Thanks!
>
> Matthias
>
>
> 2012/3/5 Andrew Eisenberg <[hidden email]>
>>
>> Hmmm...there's nothing obviously problematic in your pom.  I'm not
>> sure why maven is trying to download groovy-eclipse-batch 1.7.10-02
>> when you are explicitly using version 1.8.6--01.  A few questions,
>> though.
>>
>> 1. Was this working before you upgraded?
>> 2. Is this working when you run mvn on the command line?
>>
>> Also, a drastic measure would be to delete your ~/.m2/repository
>> directory and recreate your cache, but you can try a simpler thing to
>> delete just ~/.m2/repository/org/codehaus/groovy/groovy-eclipse-batch
>> and see if that helps.
>>
>> On Mon, Mar 5, 2012 at 5:53 AM, Matthias Hryniszak <[hidden email]>
>> wrote:
>> > Hi,
>> >
>> > I've just installed the 2.6.1 via STS 2.9.0 M2. I have the following
>> > problem
>> > while importing groovy-eclipse compiled projects:
>> >
>> > CoreException: Could not get the value for parameter compilerId for
>> > plugin
>> > execution default-compile: PluginResolutionException: Plugin
>> > org.apache.maven.plugins:maven-compiler-plugin:2.3.2 or one of its
>> > dependencies could not be resolved: Failed to collect dependencies for
>> > org.apache.maven.plugins:maven-compiler-plugin:jar:2.3.2 ():
>> > ArtifactDescriptorException: Failed to read artifact descriptor for
>> > org.codehaus.groovy:groovy-eclipse-batch:jar:1.7.10-02:
>> > ArtifactResolutionException: Failure to transfer
>> > org.codehaus.groovy:groovy-eclipse-batch:pom:1.7.10-02 from
>> > http://repo1.maven.org/maven2 was cached in the local repository,
>> > resolution
>> > will not be reattempted until the update interval of central has elapsed
>> > or
>> > updates are forced. Original error: Could not transfer artifact
>> > org.codehaus.groovy:groovy-eclipse-batch:pom:1.7.10-02 from/to central
>> > (http://repo1.maven.org/maven2): The operation was cancelled.
>> >
>> > Could you take a look at the enclosed pom.xml and tell me what am I
>> > doing
>> > wrong?
>> >
>> > Matthias
>> >
>> > 2012/3/5 Andrew Eisenberg <[hidden email]>
>> >>
>> >> Hi all,
>> >>
>> >> The Groovy-Eclipse team is proud to announce the 2.6.1 release.  We
>> >> have fixed over 100 issues including support for better content
>> >> assist, navigation, and type inferencing.  In addition, we are
>> >> continuing to implement new quick fixes.  You can find the wonderful
>> >> details in the new and noteworthy:
>> >>
>> >>
>> >>
>> >> http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+2.6.1+New+and+Noteworthy
>> >>
>> >> If you want to start using this version, the bits are available from
>> >> the release update site.
>> >> For Eclipse 3.7:
>> >> http://dist.springsource.org/release/GRECLIPSE/e3.7/
>> >> For Eclipse 3.6:
>> >> http://dist.springsource.org/release/GRECLIPSE/e3.6/
>> >>
>> >> Additionally, we now have support for Eclipse 4.2M5.  This is still a
>> >> beta build and so is not officially part of this release.  The update
>> >> site is here:
>> >> http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e4.2/
>> >>
>> >> Please send your comments to this mailing list and raise issues here:
>> >> http://jira.codehaus.org/browse/GRECLIPSE
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe from this list, please visit:
>> >>
>> >>    http://xircles.codehaus.org/manage_email
>> >>
>> >>
>> >
>> >
>> >
>> > ---------------------------------------------------------------------
>> > To unsubscribe from this list, please visit:
>> >
>> >    http://xircles.codehaus.org/manage_email
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

RE: [ANN] Groovy-Eclipse 2.6.1 Released

Talkov, Roger
In reply to this post by Andrew Eisenberg-2
Hi Andrew,

I noticed that 1.8 is now the default compiler.
We have an eclipse based development tool that we build Groovy-Eclipse into, along with a bunch of our own plugins.
Our runtime environment is still using groovy 1.7.10.
Is it possible to configure Groovy-Eclipse so it will be built into eclipse with 1.7 as the default

Thanks,

Roger Talkov

-----Original Message-----
From: Andrew Eisenberg [mailto:[hidden email]]
Sent: Sunday, March 04, 2012 8:35 PM
To: user; [hidden email]
Subject: [groovy-eclipse-plugin-user] [ANN] Groovy-Eclipse 2.6.1 Released

Hi all,

The Groovy-Eclipse team is proud to announce the 2.6.1 release.  We
have fixed over 100 issues including support for better content
assist, navigation, and type inferencing.  In addition, we are
continuing to implement new quick fixes.  You can find the wonderful
details in the new and noteworthy:

http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+2.6.1+New+and+Noteworthy

If you want to start using this version, the bits are available from
the release update site.
For Eclipse 3.7:
http://dist.springsource.org/release/GRECLIPSE/e3.7/
For Eclipse 3.6:
http://dist.springsource.org/release/GRECLIPSE/e3.6/

Additionally, we now have support for Eclipse 4.2M5.  This is still a
beta build and so is not officially part of this release.  The update
site is here:
http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e4.2/

Please send your comments to this mailing list and raise issues here:
http://jira.codehaus.org/browse/GRECLIPSE

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



This email (including any attachments) may contain information which is privileged, confidential, or protected. If you are not the intended recipient, note that any disclosure, copying, distribution, or use of the contents of this message and attached files is prohibited. If you have received this email in error, please notify the sender and delete this email and any attached files.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: [ANN] Groovy-Eclipse 2.6.1 Released

Andrew Eisenberg
How are you distributing your runtime environment?

If you have your own eclipse.ini, you can add the lines:

-groovy.compiler.level
17

See here:
http://docs.codehaus.org/display/GROOVY/Compiler+Switching+within+Groovy-Eclipse

There are lots of other possibilities, and the best one will depend on
how you are shipping your dev tools and how you are consuming
Groovy-Eclipse.

On Thu, Mar 8, 2012 at 11:12 AM, Talkov, Roger <[hidden email]> wrote:

> Hi Andrew,
>
> I noticed that 1.8 is now the default compiler.
> We have an eclipse based development tool that we build Groovy-Eclipse into, along with a bunch of our own plugins.
> Our runtime environment is still using groovy 1.7.10.
> Is it possible to configure Groovy-Eclipse so it will be built into eclipse with 1.7 as the default
>
> Thanks,
>
> Roger Talkov
>
> -----Original Message-----
> From: Andrew Eisenberg [mailto:[hidden email]]
> Sent: Sunday, March 04, 2012 8:35 PM
> To: user; [hidden email]
> Subject: [groovy-eclipse-plugin-user] [ANN] Groovy-Eclipse 2.6.1 Released
>
> Hi all,
>
> The Groovy-Eclipse team is proud to announce the 2.6.1 release.  We
> have fixed over 100 issues including support for better content
> assist, navigation, and type inferencing.  In addition, we are
> continuing to implement new quick fixes.  You can find the wonderful
> details in the new and noteworthy:
>
> http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+2.6.1+New+and+Noteworthy
>
> If you want to start using this version, the bits are available from
> the release update site.
> For Eclipse 3.7:
> http://dist.springsource.org/release/GRECLIPSE/e3.7/
> For Eclipse 3.6:
> http://dist.springsource.org/release/GRECLIPSE/e3.6/
>
> Additionally, we now have support for Eclipse 4.2M5.  This is still a
> beta build and so is not officially part of this release.  The update
> site is here:
> http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e4.2/
>
> Please send your comments to this mailing list and raise issues here:
> http://jira.codehaus.org/browse/GRECLIPSE
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>
> This email (including any attachments) may contain information which is privileged, confidential, or protected. If you are not the intended recipient, note that any disclosure, copying, distribution, or use of the contents of this message and attached files is prohibited. If you have received this email in error, please notify the sender and delete this email and any attached files.
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email