Can't use a different version of Groovy than the default 1.8

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't use a different version of Groovy than the default 1.8

Siddhartha Kasivajhula
Hi there,
I am using the groovy eclipse compiler plugin to build my Maven/Groovy project:

https://github.com/countvajhula/pilot

As it stands, it builds successfully. But, I actually need the project to be built using Groovy 1.7.7 (or some other 1.7.x version of Groovy). I tried to change the maven compiler plugin dependency to an earlier version of Groovy as indicated on the website (http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+compiler+plugin+for+Maven), i.e.:

I changed this:

<dependency>
    <groupId>org.codehaus.groovy</groupId>
    <artifactId>groovy-eclipse-batch</artifactId>
    <version>1.8.0-03</version>
</dependency>

..to this:

<dependency>
    <groupId>org.codehaus.groovy</groupId>
    <artifactId>groovy-eclipse-batch</artifactId>
    <version>1.7.10-02</version>
</dependency>

... but this gives me the following error when I run 'mvn clean install':

---- begin error message ---

Internal compiler error: java.lang.NoSuchMethodError: org.codehaus.groovy.classgen.AsmClassGenerator.access$0(Lorg/codehaus/groovy/classgen/AsmClassGenerator;)Lorg/objectweb/asm/MethodVisitor; at org.codehaus.groovy.classgen.AsmClassGenerator$MyMethodAdapter.<init>(AsmClassGenerator.java:4460)
----------
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 9.649s
[INFO] Finished at: Thu Sep 08 17:28:32 PDT 2011
[INFO] Final Memory: 9M/81M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile (default-compile) on project pilot: Execution default-compile of goal org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile failed: An API incompatibility was encountered while executing org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile: java.lang.NoSuchMethodError: org.codehaus.groovy.classgen.AsmClassGenerator.access$0(Lorg/codehaus/groovy/classgen/AsmClassGenerator;)Lorg/objectweb/asm/MethodVisitor;
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>org.apache.maven.plugins:maven-compiler-plugin:2.3.2
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
[ERROR] urls[0] = file:/Users/siddhartha/.m2/repository/org/apache/maven/plugins/maven-compiler-plugin/2.3.2/maven-compiler-plugin-2.3.2.jar
[ERROR] urls[1] = file:/Users/siddhartha/.m2/repository/org/codehaus/groovy/groovy-eclipse-compiler/2.5.1-M3/groovy-eclipse-compiler-2.5.1-M3.jar
[ERROR] urls[2] = file:/Users/siddhartha/.m2/repository/org/apache/xbean/xbean-reflect/3.4/xbean-reflect-3.4.jar
[ERROR] urls[3] = file:/Users/siddhartha/.m2/repository/log4j/log4j/1.2.12/log4j-1.2.12.jar
[ERROR] urls[4] = file:/Users/siddhartha/.m2/repository/commons-logging/commons-logging-api/1.1/commons-logging-api-1.1.jar
[ERROR] urls[5] = file:/Users/siddhartha/.m2/repository/com/google/collections/google-collections/1.0/google-collections-1.0.jar
[ERROR] urls[6] = file:/Users/siddhartha/.m2/repository/junit/junit/3.8.2/junit-3.8.2.jar
[ERROR] urls[7] = file:/Users/siddhartha/.m2/repository/org/codehaus/groovy/groovy-eclipse-batch/1.7.10-02/groovy-eclipse-batch-1.7.10-02.jar
[ERROR] urls[8] = file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-utils/2.0.5/plexus-utils-2.0.5.jar
[ERROR] urls[9] = file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-compiler-api/1.8.1/plexus-compiler-api-1.8.1.jar
[ERROR] urls[10] = file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-compiler-manager/1.8.1/plexus-compiler-manager-1.8.1.jar
[ERROR] urls[11] = file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-compiler-javac/1.8.1/plexus-compiler-javac-1.8.1.jar
[ERROR] Number of foreign imports: 1
[ERROR] import: Entry[import  from realm ClassRealm[maven.api, parent: null]]
[ERROR] 
[ERROR] -----------------------------------------------------
[ERROR] -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:

--- end error message ---


Is there something else I need to do in addition to specifying a different version as a dependency for this to work? Or any ideas on what's wrong? Here is the POM I'm using:

https://github.com/countvajhula/pilot/blob/master/pom.xml

Thanks for any help!
-Sid

Reply | Threaded
Open this post in threaded view
|

Re: Can't use a different version of Groovy than the default 1.8

Andrew Eisenberg
Hi Sid,

The pom.xml that you link to does show 1.8.0 being used in the
compiler.  I'm guessing that you have changed it locally to 1.7.10
without committing it.  Also, I see that you are using 2.5.1-m3 of
groovy-eclipse compiler.  It's better to be using 2.5.1.

That being said, I checked out your project, made those changes and I
see the NoSuchMethodError.  I'll dig a little deeper and see what the
problem is.

--a

On Thu, Sep 8, 2011 at 5:51 PM, Siddhartha Kasivajhula
<[hidden email]> wrote:

> Hi there,
> I am using the groovy eclipse compiler plugin to build my Maven/Groovy
> project:
>
> https://github.com/countvajhula/pilot
>
> As it stands, it builds successfully. But, I actually need the project to be
> built using Groovy 1.7.7 (or some other 1.7.x version of Groovy). I tried to
> change the maven compiler plugin dependency to an earlier version of Groovy
> as indicated on the
> website (http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+compiler+plugin+for+Maven),
> i.e.:
> I changed this:
> <dependency>
>     <groupId>org.codehaus.groovy</groupId>
>     <artifactId>groovy-eclipse-batch</artifactId>
>     <version>1.8.0-03</version>
> </dependency>
> ..to this:
> <dependency>
>     <groupId>org.codehaus.groovy</groupId>
>     <artifactId>groovy-eclipse-batch</artifactId>
>     <version>1.7.10-02</version>
> </dependency>
> ... but this gives me the following error when I run 'mvn clean install':
> ---- begin error message ---
> Internal compiler error: java.lang.NoSuchMethodError:
> org.codehaus.groovy.classgen.AsmClassGenerator.access$0(Lorg/codehaus/groovy/classgen/AsmClassGenerator;)Lorg/objectweb/asm/MethodVisitor;
> at
> org.codehaus.groovy.classgen.AsmClassGenerator$MyMethodAdapter.<init>(AsmClassGenerator.java:4460)
> ----------
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 9.649s
> [INFO] Finished at: Thu Sep 08 17:28:32 PDT 2011
> [INFO] Final Memory: 9M/81M
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile
> (default-compile) on project pilot: Execution default-compile of goal
> org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile failed: An API
> incompatibility was encountered while executing
> org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile:
> java.lang.NoSuchMethodError:
> org.codehaus.groovy.classgen.AsmClassGenerator.access$0(Lorg/codehaus/groovy/classgen/AsmClassGenerator;)Lorg/objectweb/asm/MethodVisitor;
> [ERROR] -----------------------------------------------------
> [ERROR] realm =
>  plugin>org.apache.maven.plugins:maven-compiler-plugin:2.3.2
> [ERROR] strategy =
> org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
> [ERROR] urls[0] =
> file:/Users/siddhartha/.m2/repository/org/apache/maven/plugins/maven-compiler-plugin/2.3.2/maven-compiler-plugin-2.3.2.jar
> [ERROR] urls[1] =
> file:/Users/siddhartha/.m2/repository/org/codehaus/groovy/groovy-eclipse-compiler/2.5.1-M3/groovy-eclipse-compiler-2.5.1-M3.jar
> [ERROR] urls[2] =
> file:/Users/siddhartha/.m2/repository/org/apache/xbean/xbean-reflect/3.4/xbean-reflect-3.4.jar
> [ERROR] urls[3] =
> file:/Users/siddhartha/.m2/repository/log4j/log4j/1.2.12/log4j-1.2.12.jar
> [ERROR] urls[4] =
> file:/Users/siddhartha/.m2/repository/commons-logging/commons-logging-api/1.1/commons-logging-api-1.1.jar
> [ERROR] urls[5] =
> file:/Users/siddhartha/.m2/repository/com/google/collections/google-collections/1.0/google-collections-1.0.jar
> [ERROR] urls[6] =
> file:/Users/siddhartha/.m2/repository/junit/junit/3.8.2/junit-3.8.2.jar
> [ERROR] urls[7] =
> file:/Users/siddhartha/.m2/repository/org/codehaus/groovy/groovy-eclipse-batch/1.7.10-02/groovy-eclipse-batch-1.7.10-02.jar
> [ERROR] urls[8] =
> file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-utils/2.0.5/plexus-utils-2.0.5.jar
> [ERROR] urls[9] =
> file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-compiler-api/1.8.1/plexus-compiler-api-1.8.1.jar
> [ERROR] urls[10] =
> file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-compiler-manager/1.8.1/plexus-compiler-manager-1.8.1.jar
> [ERROR] urls[11] =
> file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-compiler-javac/1.8.1/plexus-compiler-javac-1.8.1.jar
> [ERROR] Number of foreign imports: 1
> [ERROR] import: Entry[import  from realm ClassRealm[maven.api, parent:
> null]]
> [ERROR]
> [ERROR] -----------------------------------------------------
> [ERROR] -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e
> switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, please
> read the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/PluginContainerException
> --- end error message ---
>
> Is there something else I need to do in addition to specifying a different
> version as a dependency for this to work? Or any ideas on what's wrong? Here
> is the POM I'm using:
>
> https://github.com/countvajhula/pilot/blob/master/pom.xml
>
> Thanks for any help!
> -Sid
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Can't use a different version of Groovy than the default 1.8

Andrew Eisenberg
Well, I couldn't figure out why 1.7.10-02 wasn't working, so I
re-built the artifact and uploaded 1.7.10-03.  I installed locally,
and it works for me.  I uploaded to http://repository.codehaus.org,
which is synced to maven central.

I'm not sure if you can access artifacts from
http://repository.codehaus.org directly, but it should be synced with
maven central by tomorrow.  Someone more familiar with the codehaus
maven repos may be able to chime in and know how to access the
artifact from codehaus (and not waiting for the sync).

I hope this helps.  Please let me know.

On Thu, Sep 8, 2011 at 8:20 PM, Andrew Eisenberg <[hidden email]> wrote:

> Hi Sid,
>
> The pom.xml that you link to does show 1.8.0 being used in the
> compiler.  I'm guessing that you have changed it locally to 1.7.10
> without committing it.  Also, I see that you are using 2.5.1-m3 of
> groovy-eclipse compiler.  It's better to be using 2.5.1.
>
> That being said, I checked out your project, made those changes and I
> see the NoSuchMethodError.  I'll dig a little deeper and see what the
> problem is.
>
> --a
>
> On Thu, Sep 8, 2011 at 5:51 PM, Siddhartha Kasivajhula
> <[hidden email]> wrote:
>> Hi there,
>> I am using the groovy eclipse compiler plugin to build my Maven/Groovy
>> project:
>>
>> https://github.com/countvajhula/pilot
>>
>> As it stands, it builds successfully. But, I actually need the project to be
>> built using Groovy 1.7.7 (or some other 1.7.x version of Groovy). I tried to
>> change the maven compiler plugin dependency to an earlier version of Groovy
>> as indicated on the
>> website (http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+compiler+plugin+for+Maven),
>> i.e.:
>> I changed this:
>> <dependency>
>>     <groupId>org.codehaus.groovy</groupId>
>>     <artifactId>groovy-eclipse-batch</artifactId>
>>     <version>1.8.0-03</version>
>> </dependency>
>> ..to this:
>> <dependency>
>>     <groupId>org.codehaus.groovy</groupId>
>>     <artifactId>groovy-eclipse-batch</artifactId>
>>     <version>1.7.10-02</version>
>> </dependency>
>> ... but this gives me the following error when I run 'mvn clean install':
>> ---- begin error message ---
>> Internal compiler error: java.lang.NoSuchMethodError:
>> org.codehaus.groovy.classgen.AsmClassGenerator.access$0(Lorg/codehaus/groovy/classgen/AsmClassGenerator;)Lorg/objectweb/asm/MethodVisitor;
>> at
>> org.codehaus.groovy.classgen.AsmClassGenerator$MyMethodAdapter.<init>(AsmClassGenerator.java:4460)
>> ----------
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] BUILD FAILURE
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Total time: 9.649s
>> [INFO] Finished at: Thu Sep 08 17:28:32 PDT 2011
>> [INFO] Final Memory: 9M/81M
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] Failed to execute goal
>> org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile
>> (default-compile) on project pilot: Execution default-compile of goal
>> org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile failed: An API
>> incompatibility was encountered while executing
>> org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile:
>> java.lang.NoSuchMethodError:
>> org.codehaus.groovy.classgen.AsmClassGenerator.access$0(Lorg/codehaus/groovy/classgen/AsmClassGenerator;)Lorg/objectweb/asm/MethodVisitor;
>> [ERROR] -----------------------------------------------------
>> [ERROR] realm =
>>  plugin>org.apache.maven.plugins:maven-compiler-plugin:2.3.2
>> [ERROR] strategy =
>> org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
>> [ERROR] urls[0] =
>> file:/Users/siddhartha/.m2/repository/org/apache/maven/plugins/maven-compiler-plugin/2.3.2/maven-compiler-plugin-2.3.2.jar
>> [ERROR] urls[1] =
>> file:/Users/siddhartha/.m2/repository/org/codehaus/groovy/groovy-eclipse-compiler/2.5.1-M3/groovy-eclipse-compiler-2.5.1-M3.jar
>> [ERROR] urls[2] =
>> file:/Users/siddhartha/.m2/repository/org/apache/xbean/xbean-reflect/3.4/xbean-reflect-3.4.jar
>> [ERROR] urls[3] =
>> file:/Users/siddhartha/.m2/repository/log4j/log4j/1.2.12/log4j-1.2.12.jar
>> [ERROR] urls[4] =
>> file:/Users/siddhartha/.m2/repository/commons-logging/commons-logging-api/1.1/commons-logging-api-1.1.jar
>> [ERROR] urls[5] =
>> file:/Users/siddhartha/.m2/repository/com/google/collections/google-collections/1.0/google-collections-1.0.jar
>> [ERROR] urls[6] =
>> file:/Users/siddhartha/.m2/repository/junit/junit/3.8.2/junit-3.8.2.jar
>> [ERROR] urls[7] =
>> file:/Users/siddhartha/.m2/repository/org/codehaus/groovy/groovy-eclipse-batch/1.7.10-02/groovy-eclipse-batch-1.7.10-02.jar
>> [ERROR] urls[8] =
>> file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-utils/2.0.5/plexus-utils-2.0.5.jar
>> [ERROR] urls[9] =
>> file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-compiler-api/1.8.1/plexus-compiler-api-1.8.1.jar
>> [ERROR] urls[10] =
>> file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-compiler-manager/1.8.1/plexus-compiler-manager-1.8.1.jar
>> [ERROR] urls[11] =
>> file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-compiler-javac/1.8.1/plexus-compiler-javac-1.8.1.jar
>> [ERROR] Number of foreign imports: 1
>> [ERROR] import: Entry[import  from realm ClassRealm[maven.api, parent:
>> null]]
>> [ERROR]
>> [ERROR] -----------------------------------------------------
>> [ERROR] -> [Help 1]
>> [ERROR]
>> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e
>> switch.
>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>> [ERROR]
>> [ERROR] For more information about the errors and possible solutions, please
>> read the following articles:
>> [ERROR] [Help 1]
>> http://cwiki.apache.org/confluence/display/MAVEN/PluginContainerException
>> --- end error message ---
>>
>> Is there something else I need to do in addition to specifying a different
>> version as a dependency for this to work? Or any ideas on what's wrong? Here
>> is the POM I'm using:
>>
>> https://github.com/countvajhula/pilot/blob/master/pom.xml
>>
>> Thanks for any help!
>> -Sid
>>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Can't use a different version of Groovy than the default 1.8

Siddhartha Kasivajhula
Hi Andrew,
I just tried to build using '1.7.10-03' and it built successfully :). I also changed it from 2.5.1-M3 to 2.5.1 as you suggested.

Thanks a ton for looking into this!
-Sid


On Thu, Sep 8, 2011 at 9:01 PM, Andrew Eisenberg <[hidden email]> wrote:
Well, I couldn't figure out why 1.7.10-02 wasn't working, so I
re-built the artifact and uploaded 1.7.10-03.  I installed locally,
and it works for me.  I uploaded to http://repository.codehaus.org,
which is synced to maven central.

I'm not sure if you can access artifacts from
http://repository.codehaus.org directly, but it should be synced with
maven central by tomorrow.  Someone more familiar with the codehaus
maven repos may be able to chime in and know how to access the
artifact from codehaus (and not waiting for the sync).

I hope this helps.  Please let me know.

On Thu, Sep 8, 2011 at 8:20 PM, Andrew Eisenberg <[hidden email]> wrote:
> Hi Sid,
>
> The pom.xml that you link to does show 1.8.0 being used in the
> compiler.  I'm guessing that you have changed it locally to 1.7.10
> without committing it.  Also, I see that you are using 2.5.1-m3 of
> groovy-eclipse compiler.  It's better to be using 2.5.1.
>
> That being said, I checked out your project, made those changes and I
> see the NoSuchMethodError.  I'll dig a little deeper and see what the
> problem is.
>
> --a
>
> On Thu, Sep 8, 2011 at 5:51 PM, Siddhartha Kasivajhula
> <[hidden email]> wrote:
>> Hi there,
>> I am using the groovy eclipse compiler plugin to build my Maven/Groovy
>> project:
>>
>> https://github.com/countvajhula/pilot
>>
>> As it stands, it builds successfully. But, I actually need the project to be
>> built using Groovy 1.7.7 (or some other 1.7.x version of Groovy). I tried to
>> change the maven compiler plugin dependency to an earlier version of Groovy
>> as indicated on the
>> website (http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+compiler+plugin+for+Maven),
>> i.e.:
>> I changed this:
>> <dependency>
>>     <groupId>org.codehaus.groovy</groupId>
>>     <artifactId>groovy-eclipse-batch</artifactId>
>>     <version>1.8.0-03</version>
>> </dependency>
>> ..to this:
>> <dependency>
>>     <groupId>org.codehaus.groovy</groupId>
>>     <artifactId>groovy-eclipse-batch</artifactId>
>>     <version>1.7.10-02</version>
>> </dependency>
>> ... but this gives me the following error when I run 'mvn clean install':
>> ---- begin error message ---
>> Internal compiler error: java.lang.NoSuchMethodError:
>> org.codehaus.groovy.classgen.AsmClassGenerator.access$0(Lorg/codehaus/groovy/classgen/AsmClassGenerator;)Lorg/objectweb/asm/MethodVisitor;
>> at
>> org.codehaus.groovy.classgen.AsmClassGenerator$MyMethodAdapter.<init>(AsmClassGenerator.java:4460)
>> ----------
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] BUILD FAILURE
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Total time: 9.649s
>> [INFO] Finished at: Thu Sep 08 17:28:32 PDT 2011
>> [INFO] Final Memory: 9M/81M
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] Failed to execute goal
>> org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile
>> (default-compile) on project pilot: Execution default-compile of goal
>> org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile failed: An API
>> incompatibility was encountered while executing
>> org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile:
>> java.lang.NoSuchMethodError:
>> org.codehaus.groovy.classgen.AsmClassGenerator.access$0(Lorg/codehaus/groovy/classgen/AsmClassGenerator;)Lorg/objectweb/asm/MethodVisitor;
>> [ERROR] -----------------------------------------------------
>> [ERROR] realm =
>>  plugin>org.apache.maven.plugins:maven-compiler-plugin:2.3.2
>> [ERROR] strategy =
>> org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
>> [ERROR] urls[0] =
>> file:/Users/siddhartha/.m2/repository/org/apache/maven/plugins/maven-compiler-plugin/2.3.2/maven-compiler-plugin-2.3.2.jar
>> [ERROR] urls[1] =
>> file:/Users/siddhartha/.m2/repository/org/codehaus/groovy/groovy-eclipse-compiler/2.5.1-M3/groovy-eclipse-compiler-2.5.1-M3.jar
>> [ERROR] urls[2] =
>> file:/Users/siddhartha/.m2/repository/org/apache/xbean/xbean-reflect/3.4/xbean-reflect-3.4.jar
>> [ERROR] urls[3] =
>> file:/Users/siddhartha/.m2/repository/log4j/log4j/1.2.12/log4j-1.2.12.jar
>> [ERROR] urls[4] =
>> file:/Users/siddhartha/.m2/repository/commons-logging/commons-logging-api/1.1/commons-logging-api-1.1.jar
>> [ERROR] urls[5] =
>> file:/Users/siddhartha/.m2/repository/com/google/collections/google-collections/1.0/google-collections-1.0.jar
>> [ERROR] urls[6] =
>> file:/Users/siddhartha/.m2/repository/junit/junit/3.8.2/junit-3.8.2.jar
>> [ERROR] urls[7] =
>> file:/Users/siddhartha/.m2/repository/org/codehaus/groovy/groovy-eclipse-batch/1.7.10-02/groovy-eclipse-batch-1.7.10-02.jar
>> [ERROR] urls[8] =
>> file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-utils/2.0.5/plexus-utils-2.0.5.jar
>> [ERROR] urls[9] =
>> file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-compiler-api/1.8.1/plexus-compiler-api-1.8.1.jar
>> [ERROR] urls[10] =
>> file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-compiler-manager/1.8.1/plexus-compiler-manager-1.8.1.jar
>> [ERROR] urls[11] =
>> file:/Users/siddhartha/.m2/repository/org/codehaus/plexus/plexus-compiler-javac/1.8.1/plexus-compiler-javac-1.8.1.jar
>> [ERROR] Number of foreign imports: 1
>> [ERROR] import: Entry[import  from realm ClassRealm[maven.api, parent:
>> null]]
>> [ERROR]
>> [ERROR] -----------------------------------------------------
>> [ERROR] -> [Help 1]
>> [ERROR]
>> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e
>> switch.
>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>> [ERROR]
>> [ERROR] For more information about the errors and possible solutions, please
>> read the following articles:
>> [ERROR] [Help 1]
>> http://cwiki.apache.org/confluence/display/MAVEN/PluginContainerException
>> --- end error message ---
>>
>> Is there something else I need to do in addition to specifying a different
>> version as a dependency for this to work? Or any ideas on what's wrong? Here
>> is the POM I'm using:
>>
>> https://github.com/countvajhula/pilot/blob/master/pom.xml
>>
>> Thanks for any help!
>> -Sid
>>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email