Dependency issues installing Groovy Eclipse plugin

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Dependency issues installing Groovy Eclipse plugin

martin
Hello

I've just installed Eclipse 3.7.1 on my PC and already have Groovy 1.8  
installed as well.

But upon trying to install the plugin from:

http://dist.springsource.org/release/GRECLIPSE/e3.7/

I was able to install the optional Groovy Eclipse SDK but not Groovy  
Eclipse. Upon trying to install this, I receive messages as follow:

Cannot complete the install because of a conflicting dependency.
   Software being installed: Groovy-Eclipse Feature  
2.5.2.xx-20110929-1800-e37  
(org.codehaus.groovy.eclipse.feature.feature.group  
2.5.2.xx-20110929-1800-e37)
    Software currently installed: Shared profile 1.0.0.1315600366384  
(SharedProfile_SDKProfile 1.0.0.1315600366384)
    Only one of the following can be installed at once:
     Java Development Tools Core 3.7.1.xx-20110929-1800-e37  
(org.eclipse.jdt.core 3.7.1.xx-20110929-1800-e37)
      Java Development Tools Core 3.7.1.v_B76_R37x  
(org.eclipse.jdt.core 3.7.1.v_B76_R37x)
    Cannot satisfy dependency:
     From: Shared profile 1.0.0.1315600366384  
(SharedProfile_SDKProfile 1.0.0.1315600366384)
      To: org.eclipse.jdt.core [3.7.1.v_B76_R37x]
   Cannot satisfy dependency:
     From: Shared profile 1.0.0.1315600366384  
(SharedProfile_SDKProfile 1.0.0.1315600366384)
      To: org.eclipse.jdt.feature.group  
[3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK]
    Cannot satisfy dependency:
     From: Groovy-Eclipse Feature 2.5.2.xx-20110929-1800-e37  
(org.codehaus.groovy.eclipse.feature.feature.group  
2.5.2.xx-20110929-1800-e37)
      To: org.codehaus.groovy.jdt.patch.feature.group  
[2.5.2.xx-20110929-1800-e37]
    Cannot satisfy dependency:
     From Patch: org.codehaus.groovy.jdt.patch.feature.group  
2.5.2.xx-20110929-1800-e37 Eclipse Java Development Tools  
3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK  
(org.eclipse.jdt.feature.group  
3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK)
      To: org.eclipse.jdt.core [3.7.1.xx-20110929-1800-e37]

Can anyone advise?

Thanks

Martin O'Shea.


----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Dependency issues installing Groovy Eclipse plugin

Andrew Eisenberg
You are hitting this bug:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=332158

In order to install Groovy-Eclipse, your eclipse instance must be in a
directory that is writable by the current user.  Either make the
directory writable or move your instance.  If you are in windows, then
it cannot be in C:\Program Files.

On Wed, Oct 5, 2011 at 2:12 AM,  <[hidden email]> wrote:

> Hello
>
> I've just installed Eclipse 3.7.1 on my PC and already have Groovy 1.8
> installed as well.
>
> But upon trying to install the plugin from:
>
> http://dist.springsource.org/release/GRECLIPSE/e3.7/
>
> I was able to install the optional Groovy Eclipse SDK but not Groovy
> Eclipse. Upon trying to install this, I receive messages as follow:
>
> Cannot complete the install because of a conflicting dependency.
>  Software being installed: Groovy-Eclipse Feature 2.5.2.xx-20110929-1800-e37
> (org.codehaus.groovy.eclipse.feature.feature.group
> 2.5.2.xx-20110929-1800-e37)
>   Software currently installed: Shared profile 1.0.0.1315600366384
> (SharedProfile_SDKProfile 1.0.0.1315600366384)
>   Only one of the following can be installed at once:
>    Java Development Tools Core 3.7.1.xx-20110929-1800-e37
> (org.eclipse.jdt.core 3.7.1.xx-20110929-1800-e37)
>     Java Development Tools Core 3.7.1.v_B76_R37x (org.eclipse.jdt.core
> 3.7.1.v_B76_R37x)
>   Cannot satisfy dependency:
>    From: Shared profile 1.0.0.1315600366384 (SharedProfile_SDKProfile
> 1.0.0.1315600366384)
>     To: org.eclipse.jdt.core [3.7.1.v_B76_R37x]
>  Cannot satisfy dependency:
>    From: Shared profile 1.0.0.1315600366384 (SharedProfile_SDKProfile
> 1.0.0.1315600366384)
>     To: org.eclipse.jdt.feature.group
> [3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK]
>   Cannot satisfy dependency:
>    From: Groovy-Eclipse Feature 2.5.2.xx-20110929-1800-e37
> (org.codehaus.groovy.eclipse.feature.feature.group
> 2.5.2.xx-20110929-1800-e37)
>     To: org.codehaus.groovy.jdt.patch.feature.group
> [2.5.2.xx-20110929-1800-e37]
>   Cannot satisfy dependency:
>    From Patch: org.codehaus.groovy.jdt.patch.feature.group
> 2.5.2.xx-20110929-1800-e37 Eclipse Java Development Tools
> 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK
> (org.eclipse.jdt.feature.group
> 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK)
>     To: org.eclipse.jdt.core [3.7.1.xx-20110929-1800-e37]
>
> Can anyone advise?
>
> Thanks
>
> Martin O'Shea.
>
>
> ----------------------------------------------------------------
> This message was sent using IMP, the Internet Messaging Program.
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>   http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email