Eclipse 3.7.1 and Groovy-Eclipse

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Eclipse 3.7.1 and Groovy-Eclipse

Andy Clement
Eclipse 3.7.1 was released today.  If you want to use Groovy-Eclipse
with it, you will need to install todays dev build. The update site
for the 3.7.1 compatible version is:

http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.7/

Note: STS 2.8.0.M2 just came out but is still based on Eclipse 3.7.0.
The final release of STS 2.8.0 will be on an Eclipse 3.7.1 base.

These dev builds of Groovy-Eclipse should install just fine for anyone
choosing to stay on Eclipse 3.7.0.

Any problems, send an email or raise a Jira.

thanks,
Andy

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Eclipse 3.7.1 and Groovy-Eclipse

Peter Niederwieser
Administrator
Is this still true as of today? I just installed latest Eclipse JEE 3.7 SR1 and latest Groovy Eclipse (including the Groovy 1.8 compiler) from the 3.7 update site. At first it seemed to work, but after switching to the Groovy 1.7 compiler in the Groovy Eclipse preferences (which prompted me to restart Eclipse), Eclipse no longer starts. Unsure what to do at this point. I've attached the log.

Cheers,
Peter

!SESSION 2011-11-05 13:53:02.009 -----------------------------------------------
eclipse.buildId=M20110909-1335
java.version=1.6.0_26
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.jee.product -keyring /Users/pniederw/.eclipse_keyring -showlocation
Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -product org.eclipse.epp.package.jee.product -keyring /Users/pniederw/.eclipse_keyring -showlocation

!ENTRY org.eclipse.osgi 2 0 2011-11-05 13:53:05.531
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-11-05 13:53:05.531
!MESSAGE Bundle org.codehaus.groovy_1.8.2.xx-20110929-1800-e37 [762] was not resolved.
!SUBENTRY 2 org.codehaus.groovy 2 0 2011-11-05 13:53:05.531
!MESSAGE The bundle is disabled: "org.eclipse.pde.ui:Disabled via PDE"

!ENTRY org.eclipse.osgi 4 0 2011-11-05 13:53:05.558
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse 3.7.1 and Groovy-Eclipse

Andrew Eisenberg
Try editing the eclipse.ini file and add the lines (before the vmargs section):

-groovy.compiler.level
17

This will force Eclipse to start with 1.7.  Switch to 1.8 to run with 1.8.

Alternatively, you can create shell scripts that launch Eclipse with
the appropriate compiler level so you don't need to be mucking with
configuration to switch compilers.

On Sat, Nov 5, 2011 at 7:00 PM, Peter Niederwieser <[hidden email]> wrote:

> Is this still true as of today? I just installed latest Eclipse JEE 3.7 SR1
> and latest Groovy Eclipse (including the Groovy 1.8 compiler) from the 3.7
> update site. At first it seemed to work, but after switching to the Groovy
> 1.7 compiler in the Groovy Eclipse preferences (which prompted me to restart
> Eclipse), Eclipse no longer starts. Unsure what to do at this point. I've
> attached the log.
>
> Cheers,
> Peter
>
> !SESSION 2011-11-05 13:53:02.009
> -----------------------------------------------
> eclipse.buildId=M20110909-1335
> java.version=1.6.0_26
> java.vendor=Apple Inc.
> BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
> Framework arguments:  -product org.eclipse.epp.package.jee.product -keyring
> /Users/pniederw/.eclipse_keyring -showlocation
> Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -product
> org.eclipse.epp.package.jee.product -keyring
> /Users/pniederw/.eclipse_keyring -showlocation
>
> !ENTRY org.eclipse.osgi 2 0 2011-11-05 13:53:05.531
> !MESSAGE The following is a complete list of bundles which are not resolved,
> see the prior log entry for the root cause if it exists:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-11-05 13:53:05.531
> !MESSAGE Bundle org.codehaus.groovy_1.8.2.xx-20110929-1800-e37 [762] was not
> resolved.
> !SUBENTRY 2 org.codehaus.groovy 2 0 2011-11-05 13:53:05.531
> !MESSAGE The bundle is disabled: "org.eclipse.pde.ui:Disabled via PDE"
>
> !ENTRY org.eclipse.osgi 4 0 2011-11-05 13:53:05.558
> !MESSAGE Application error
> !STACK 1
> java.lang.IllegalStateException: Unable to acquire application service.
> Ensure that the org.eclipse.core.runtime bundle is resolved and started (see
> config.ini).
>        at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
>        at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
>        at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
>        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>        at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>        at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>        at java.lang.reflect.Method.invoke(Method.java:597)
>        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
>        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
>        at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
>
> --
> View this message in context: http://groovy-eclipse-plugin.42567.n3.nabble.com/Eclipse-3-7-1-and-Groovy-Eclipse-tp3363013p3483069.html
> Sent from the groovy-eclipse-plugin-user mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Eclipse 3.7.1 and Groovy-Eclipse

Peter Niederwieser
Administrator
Thanks Andrew, that worked. Just for the record: On a Mac, the eclipse.ini file is inside eclipse.app, and the correct value for "groovy.compiler.level" is "1.7" (not "17").

Cheers,
Peter