Eclipse Groovy plugin installation issue: Bug-498 solution not working.

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Eclipse Groovy plugin installation issue: Bug-498 solution not working.

Matthew Eggers
Hello,

I am unable to install the Eclipse Plugin for Groovy on my current installation. I've researched
But I've already tried those solutions. I am running:

Version: 3.5.2
Build id: M20100211-1343

On Debian Squeeze 2.6.32-5-686

I receive the same error:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Groovy-Eclipse Feature 2.1.0.20100926-2100-e35-RC1 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.0.20100926-2100-e35-RC1)
  Software currently installed: Eclipse Platform 3.5.2 (Eclipse Platform 3.5.2)
  Only one of the following can be installed at once:
    Java Development Tools Core 3.5.2.v_981_R35x (org.eclipse.jdt.core 3.5.2.v_981_R35x)
    Java Development Tools Core 3.5.1.v_972_R35x (org.eclipse.jdt.core 3.5.1.v_972_R35x)
    Java Development Tools Core 3.5.2.20100926-2100-e35-RC1 (org.eclipse.jdt.core 3.5.2.20100926-2100-e35-RC1)
    Java Development Tools Core 3.5.2.20101020-2100-e35-release (org.eclipse.jdt.core 3.5.2.20101020-2100-e35-release)
  Cannot satisfy dependency:
    From: Eclipse Platform 3.5.2 (Eclipse Platform 3.5.2)
    To: org.eclipse.jdt.core [3.5.2.v_981_R35x]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.5.2 (Eclipse Platform 3.5.2)
    To: org.eclipse.jdt.feature.group [3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ]
  Cannot satisfy dependency:
    From: Groovy-Eclipse Feature 2.1.0.20100926-2100-e35-RC1 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.0.20100926-2100-e35-RC1)
    To: org.codehaus.groovy.jdt.patch.feature.group [2.1.0.20100926-2100-e35-RC1]
  Cannot satisfy dependency:
    From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.1.0.20100926-2100-e35-RC1 Eclipse Java Development Tools 3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ (org.eclipse.jdt.feature.group 3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ)
    To: org.eclipse.jdt.core [3.5.2.20100926-2100-e35-RC1]
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse Groovy plugin installation issue: Bug-498 solution not working.

Andrew Eisenberg
My first suggestion is to upgrade to a more recent version of Eclipse
(3.6 or 3.7) and then try to install.  But, if that is not possible
for some reason, then there are some more thing you can try:

1. Which update site are you trying to install from?   Make sure to
remove all other update sites that might contain Groovy-Eclipse.
2. Make sure that "Contact all update sites..." is unchecked.

Also, are you uisng and Eclipse downloaded from eclipse.org, or has it
been repackaged by Debian?

On Thu, Jun 23, 2011 at 12:17 PM, Matthew Eggers
<[hidden email]> wrote:

> Hello,
>
> I am unable to install the Eclipse Plugin for Groovy on my current
> installation. I've researched
>
> GRECLIPSE-498
>
> But I've already tried those solutions. I am running:
>
> Version: 3.5.2
> Build id: M20100211-1343
>
> On Debian Squeeze 2.6.32-5-686
>
> I receive the same error:
>
> Cannot complete the install because of a conflicting dependency.
>   Software being installed: Groovy-Eclipse Feature
> 2.1.0.20100926-2100-e35-RC1
> (org.codehaus.groovy.eclipse.feature.feature.group
> 2.1.0.20100926-2100-e35-RC1)
>   Software currently installed: Eclipse Platform 3.5.2 (Eclipse Platform
> 3.5.2)
>   Only one of the following can be installed at once:
>     Java Development Tools Core 3.5.2.v_981_R35x (org.eclipse.jdt.core
> 3.5.2.v_981_R35x)
>     Java Development Tools Core 3.5.1.v_972_R35x (org.eclipse.jdt.core
> 3.5.1.v_972_R35x)
>     Java Development Tools Core 3.5.2.20100926-2100-e35-RC1
> (org.eclipse.jdt.core 3.5.2.20100926-2100-e35-RC1)
>     Java Development Tools Core 3.5.2.20101020-2100-e35-release
> (org.eclipse.jdt.core 3.5.2.20101020-2100-e35-release)
>   Cannot satisfy dependency:
>     From: Eclipse Platform 3.5.2 (Eclipse Platform 3.5.2)
>     To: org.eclipse.jdt.core [3.5.2.v_981_R35x]
>   Cannot satisfy dependency:
>     From: Eclipse Platform 3.5.2 (Eclipse Platform 3.5.2)
>     To: org.eclipse.jdt.feature.group
> [3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ]
>   Cannot satisfy dependency:
>     From: Groovy-Eclipse Feature 2.1.0.20100926-2100-e35-RC1
> (org.codehaus.groovy.eclipse.feature.feature.group
> 2.1.0.20100926-2100-e35-RC1)
>     To: org.codehaus.groovy.jdt.patch.feature.group
> [2.1.0.20100926-2100-e35-RC1]
>   Cannot satisfy dependency:
>     From Patch: org.codehaus.groovy.jdt.patch.feature.group
> 2.1.0.20100926-2100-e35-RC1 Eclipse Java Development Tools
> 3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ
> (org.eclipse.jdt.feature.group
> 3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ)
>     To: org.eclipse.jdt.core [3.5.2.20100926-2100-e35-RC1]

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Eclipse Groovy plugin installation issue: Bug-498 solution not working.

Matthew Eggers
I just tried Downloading 3.7 with another conflict. (Sorry, I removed the install before I saved it.)
I initially installed the debian Gallileo install (3.5.2.xxx). I've just downloaded 3.6.2 . . .

To answer your questions:

1. Which update site are you trying to install from?   Make sure to
remove all other update sites that might contain Groovy-Eclipse.
I did remove them from 3.52

2. Make sure that "Contact all update sites..." is unchecked.
Will do.

I've just started 3.6.2 'Helios' and will let you know shortly.



----- Original Message -----
From: Andrew Eisenberg <[hidden email]>
To: [hidden email]
Sent: Thu, 23 Jun 2011 12:47:34 -0700 (PDT)
Subject: Re: [groovy-eclipse-plugin-user] Eclipse Groovy plugin installation issue: Bug-498 solution not working.

My first suggestion is to upgrade to a more recent version of Eclipse
(3.6 or 3.7) and then try to install.  But, if that is not possible
for some reason, then there are some more thing you can try:

1. Which update site are you trying to install from?   Make sure to
remove all other update sites that might contain Groovy-Eclipse.
2. Make sure that "Contact all update sites..." is unchecked.

Also, are you uisng and Eclipse downloaded from eclipse.org, or has it
been repackaged by Debian?

On Thu, Jun 23, 2011 at 12:17 PM, Matthew Eggers
<[hidden email]> wrote:

> Hello,
>
> I am unable to install the Eclipse Plugin for Groovy on my current
> installation. I've researched
>
> GRECLIPSE-498
>
> But I've already tried those solutions. I am running:
>
> Version: 3.5.2
> Build id: M20100211-1343
>
> On Debian Squeeze 2.6.32-5-686
>
> I receive the same error:
>
> Cannot complete the install because of a conflicting dependency.
>   Software being installed: Groovy-Eclipse Feature
> 2.1.0.20100926-2100-e35-RC1
> (org.codehaus.groovy.eclipse.feature.feature.group
> 2.1.0.20100926-2100-e35-RC1)
>   Software currently installed: Eclipse Platform 3.5.2 (Eclipse Platform
> 3.5.2)
>   Only one of the following can be installed at once:
>     Java Development Tools Core 3.5.2.v_981_R35x (org.eclipse.jdt.core
> 3.5.2.v_981_R35x)
>     Java Development Tools Core 3.5.1.v_972_R35x (org.eclipse.jdt.core
> 3.5.1.v_972_R35x)
>     Java Development Tools Core 3.5.2.20100926-2100-e35-RC1
> (org.eclipse.jdt.core 3.5.2.20100926-2100-e35-RC1)
>     Java Development Tools Core 3.5.2.20101020-2100-e35-release
> (org.eclipse.jdt.core 3.5.2.20101020-2100-e35-release)
>   Cannot satisfy dependency:
>     From: Eclipse Platform 3.5.2 (Eclipse Platform 3.5.2)
>     To: org.eclipse.jdt.core [3.5.2.v_981_R35x]
>   Cannot satisfy dependency:
>     From: Eclipse Platform 3.5.2 (Eclipse Platform 3.5.2)
>     To: org.eclipse.jdt.feature.group
> [3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ]
>   Cannot satisfy dependency:
>     From: Groovy-Eclipse Feature 2.1.0.20100926-2100-e35-RC1
> (org.codehaus.groovy.eclipse.feature.feature.group
> 2.1.0.20100926-2100-e35-RC1)
>     To: org.codehaus.groovy.jdt.patch.feature.group
> [2.1.0.20100926-2100-e35-RC1]
>   Cannot satisfy dependency:
>     From Patch: org.codehaus.groovy.jdt.patch.feature.group
> 2.1.0.20100926-2100-e35-RC1 Eclipse Java Development Tools
> 3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ
> (org.eclipse.jdt.feature.group
> 3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ)
>     To: org.eclipse.jdt.core [3.5.2.20100926-2100-e35-RC1]

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email




---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Eclipse Groovy plugin installation issue: Bug-498 solution not working.

Matthew Eggers
It looks like downloading version 6.2 was successful. Thanks for the help. You may want to post a note on the Install Groovy-Eclipse Plugin page on Confluence for Debian / Ubuntu users, since that package is the Gallileo package and I do know that Debian will tweak certain packages to make them stable with the release.

I guess that's the payoff of having a secure, fast, stable OS.

Thanks!

Matthew EggersSoftware DeveloperFULL CIRCLE | Live the good food [hidden email]

----- Original Message -----
From: Matthew Eggers <[hidden email]>
To: [hidden email]
Sent: Thu, 23 Jun 2011 12:56:20 -0700 (PDT)
Subject: Re: [groovy-eclipse-plugin-user] Eclipse Groovy plugin installation issue: Bug-498 solution not working.

I just tried Downloading 3.7 with another conflict. (Sorry, I removed the install before I saved it.)
I initially installed the debian Gallileo install (3.5.2.xxx). I've just downloaded 3.6.2 . . .

To answer your questions:

1. Which update site are you trying to install from?   Make sure to
remove all other update sites that might contain Groovy-Eclipse.
I did remove them from 3.52

2. Make sure that "Contact all update sites..." is unchecked.
Will do.

I've just started 3.6.2 'Helios' and will let you know shortly.



----- Original Message -----
From: Andrew Eisenberg <[hidden email]>
To: [hidden email]
Sent: Thu, 23 Jun 2011 12:47:34 -0700 (PDT)
Subject: Re: [groovy-eclipse-plugin-user] Eclipse Groovy plugin installation issue: Bug-498 solution not working.

My first suggestion is to upgrade to a more recent version of Eclipse
(3.6 or 3.7) and then try to install.  But, if that is not possible
for some reason, then there are some more thing you can try:

1. Which update site are you trying to install from?   Make sure to
remove all other update sites that might contain Groovy-Eclipse.
2. Make sure that "Contact all update sites..." is unchecked.

Also, are you uisng and Eclipse downloaded from eclipse.org, or has it
been repackaged by Debian?

On Thu, Jun 23, 2011 at 12:17 PM, Matthew Eggers
<[hidden email]> wrote:

> Hello,
>
> I am unable to install the Eclipse Plugin for Groovy on my current
> installation. I've researched
>
> GRECLIPSE-498
>
> But I've already tried those solutions. I am running:
>
> Version: 3.5.2
> Build id: M20100211-1343
>
> On Debian Squeeze 2.6.32-5-686
>
> I receive the same error:
>
> Cannot complete the install because of a conflicting dependency.
>   Software being installed: Groovy-Eclipse Feature
> 2.1.0.20100926-2100-e35-RC1
> (org.codehaus.groovy.eclipse.feature.feature.group
> 2.1.0.20100926-2100-e35-RC1)
>   Software currently installed: Eclipse Platform 3.5.2 (Eclipse Platform
> 3.5.2)
>   Only one of the following can be installed at once:
>     Java Development Tools Core 3.5.2.v_981_R35x (org.eclipse.jdt.core
> 3.5.2.v_981_R35x)
>     Java Development Tools Core 3.5.1.v_972_R35x (org.eclipse.jdt.core
> 3.5.1.v_972_R35x)
>     Java Development Tools Core 3.5.2.20100926-2100-e35-RC1
> (org.eclipse.jdt.core 3.5.2.20100926-2100-e35-RC1)
>     Java Development Tools Core 3.5.2.20101020-2100-e35-release
> (org.eclipse.jdt.core 3.5.2.20101020-2100-e35-release)
>   Cannot satisfy dependency:
>     From: Eclipse Platform 3.5.2 (Eclipse Platform 3.5.2)
>     To: org.eclipse.jdt.core [3.5.2.v_981_R35x]
>   Cannot satisfy dependency:
>     From: Eclipse Platform 3.5.2 (Eclipse Platform 3.5.2)
>     To: org.eclipse.jdt.feature.group
> [3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ]
>   Cannot satisfy dependency:
>     From: Groovy-Eclipse Feature 2.1.0.20100926-2100-e35-RC1
> (org.codehaus.groovy.eclipse.feature.feature.group
> 2.1.0.20100926-2100-e35-RC1)
>     To: org.codehaus.groovy.jdt.patch.feature.group
> [2.1.0.20100926-2100-e35-RC1]
>   Cannot satisfy dependency:
>     From Patch: org.codehaus.groovy.jdt.patch.feature.group
> 2.1.0.20100926-2100-e35-RC1 Eclipse Java Development Tools
> 3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ
> (org.eclipse.jdt.feature.group
> 3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ)
>     To: org.eclipse.jdt.core [3.5.2.20100926-2100-e35-RC1]

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email




---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email




---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Eclipse Groovy plugin installation issue: Bug-498 solution not working.

Andrew Eisenberg
Thanks for the feedback.  I updated the FAQ:
http://docs.codehaus.org/display/GROOVY/Eclipse+Plugin+FAQ#EclipsePluginFAQ-Q.IamrunningLinuxandcannotinstallGroovyEclipse

Let me know if there's anything you want to add.

On Thu, Jun 23, 2011 at 1:02 PM, Matthew Eggers <[hidden email]> wrote:

> It looks like downloading version 6.2 was successful. Thanks for the help. You may want to post a note on the Install Groovy-Eclipse Plugin page on Confluence for Debian / Ubuntu users, since that package is the Gallileo package and I do know that Debian will tweak certain packages to make them stable with the release.
>
> I guess that's the payoff of having a secure, fast, stable OS.
>
> Thanks!
>
> Matthew EggersSoftware DeveloperFULL CIRCLE | Live the good food [hidden email]
>
> ----- Original Message -----
> From: Matthew Eggers <[hidden email]>
> To: [hidden email]
> Sent: Thu, 23 Jun 2011 12:56:20 -0700 (PDT)
> Subject: Re: [groovy-eclipse-plugin-user] Eclipse Groovy plugin installation issue: Bug-498 solution not working.
>
> I just tried Downloading 3.7 with another conflict. (Sorry, I removed the install before I saved it.)
> I initially installed the debian Gallileo install (3.5.2.xxx). I've just downloaded 3.6.2 . . .
>
> To answer your questions:
>
> 1. Which update site are you trying to install from?   Make sure to
> remove all other update sites that might contain Groovy-Eclipse.
> I did remove them from 3.52
>
> 2. Make sure that "Contact all update sites..." is unchecked.
> Will do.
>
> I've just started 3.6.2 'Helios' and will let you know shortly.
>
>
>
> ----- Original Message -----
> From: Andrew Eisenberg <[hidden email]>
> To: [hidden email]
> Sent: Thu, 23 Jun 2011 12:47:34 -0700 (PDT)
> Subject: Re: [groovy-eclipse-plugin-user] Eclipse Groovy plugin installation issue: Bug-498 solution not working.
>
> My first suggestion is to upgrade to a more recent version of Eclipse
> (3.6 or 3.7) and then try to install.  But, if that is not possible
> for some reason, then there are some more thing you can try:
>
> 1. Which update site are you trying to install from?   Make sure to
> remove all other update sites that might contain Groovy-Eclipse.
> 2. Make sure that "Contact all update sites..." is unchecked.
>
> Also, are you uisng and Eclipse downloaded from eclipse.org, or has it
> been repackaged by Debian?
>
> On Thu, Jun 23, 2011 at 12:17 PM, Matthew Eggers
> <[hidden email]> wrote:
>> Hello,
>>
>> I am unable to install the Eclipse Plugin for Groovy on my current
>> installation. I've researched
>>
>> GRECLIPSE-498
>>
>> But I've already tried those solutions. I am running:
>>
>> Version: 3.5.2
>> Build id: M20100211-1343
>>
>> On Debian Squeeze 2.6.32-5-686
>>
>> I receive the same error:
>>
>> Cannot complete the install because of a conflicting dependency.
>>   Software being installed: Groovy-Eclipse Feature
>> 2.1.0.20100926-2100-e35-RC1
>> (org.codehaus.groovy.eclipse.feature.feature.group
>> 2.1.0.20100926-2100-e35-RC1)
>>   Software currently installed: Eclipse Platform 3.5.2 (Eclipse Platform
>> 3.5.2)
>>   Only one of the following can be installed at once:
>>     Java Development Tools Core 3.5.2.v_981_R35x (org.eclipse.jdt.core
>> 3.5.2.v_981_R35x)
>>     Java Development Tools Core 3.5.1.v_972_R35x (org.eclipse.jdt.core
>> 3.5.1.v_972_R35x)
>>     Java Development Tools Core 3.5.2.20100926-2100-e35-RC1
>> (org.eclipse.jdt.core 3.5.2.20100926-2100-e35-RC1)
>>     Java Development Tools Core 3.5.2.20101020-2100-e35-release
>> (org.eclipse.jdt.core 3.5.2.20101020-2100-e35-release)
>>   Cannot satisfy dependency:
>>     From: Eclipse Platform 3.5.2 (Eclipse Platform 3.5.2)
>>     To: org.eclipse.jdt.core [3.5.2.v_981_R35x]
>>   Cannot satisfy dependency:
>>     From: Eclipse Platform 3.5.2 (Eclipse Platform 3.5.2)
>>     To: org.eclipse.jdt.feature.group
>> [3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ]
>>   Cannot satisfy dependency:
>>     From: Groovy-Eclipse Feature 2.1.0.20100926-2100-e35-RC1
>> (org.codehaus.groovy.eclipse.feature.feature.group
>> 2.1.0.20100926-2100-e35-RC1)
>>     To: org.codehaus.groovy.jdt.patch.feature.group
>> [2.1.0.20100926-2100-e35-RC1]
>>   Cannot satisfy dependency:
>>     From Patch: org.codehaus.groovy.jdt.patch.feature.group
>> 2.1.0.20100926-2100-e35-RC1 Eclipse Java Development Tools
>> 3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ
>> (org.eclipse.jdt.feature.group
>> 3.5.2.r352_v20100108-7r88FEwFH4SRsd9dz0fZ6z-rwffZ)
>>     To: org.eclipse.jdt.core [3.5.2.20100926-2100-e35-RC1]
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email