Error in Eclipse compiler plugin for mvn dependencies?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Error in Eclipse compiler plugin for mvn dependencies?

B Fitz
Hi,

I'm trying to use the Eclipse compiler plugin version 2.5.1 for maven as described at: http://groovy.codehaus.org/Groovy-Eclipse+compiler+plugin+for+Maven

However running a "mvn install"  I'm getting maven errors saying that  1.7.10-SNAPSHOT of groovy-eclipse-batch  cannot be found.

This appears to be caused by its dependency on groovy-eclipse-batch.

The dependency in the pom is specified as: 

<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-eclipse-batch</artifactId>
<version>[1.7.10-SNAPSHOT],[1.8.0-SNAPSHOT]</version>
</dependency>

(From: http://repo1.maven.org/maven2/org/codehaus/groovy/groovy-eclipse-compiler/2.5.1/groovy-eclipse-compiler-2.5.1.pom )

Should this instead be -  <version>[1.7.10-02,1.7.10-99],[1.8.0-03,1.8.0-99]</version> ?

Thanks,

Barry

Reply | Threaded
Open this post in threaded view
|

Re: Error in Eclipse compiler plugin for mvn dependencies?

Andrew Eisenberg
Yes, it looks like the pom in the repo that you are linking to somehow
does have some outdated dependency info.  The repository here:
https://nexus.codehaus.org/content/repositories/releases/
which is supposed to be synced with maven central does have correct
dependency information.

Are you explicitly declaring a dependency on groovy-eclipse-batch?  If
not, can you try this and see if it works?  Use 1.7.10-01 or 1.8.0-03.

If this still doesn't work, then try grabbing the
groovy-eclipse-compiler artifact from the codehaus releases repository
instead:
https://nexus.codehaus.org/content/repositories/releases/

I'm not sure why this outdated pom is available from maven central.
Looking at the timestamp and size of of groovy-eclipse-compiler.jar,
it is consistent on both repostories, even if the pom is not.

Let me know if this works for you.

On Thu, Jul 7, 2011 at 9:43 AM, B Fitz <[hidden email]> wrote:

> Hi,
> I'm trying to use the Eclipse compiler plugin version 2.5.1 for maven as
> described
> at: http://groovy.codehaus.org/Groovy-Eclipse+compiler+plugin+for+Maven
> However running a "mvn install"  I'm getting maven errors saying that
>  1.7.10-SNAPSHOT of groovy-eclipse-batch  cannot be found.
> This appears to be caused by its dependency on groovy-eclipse-batch.
> The dependency in the pom is specified as:
> <dependency>
> <groupId>org.codehaus.groovy</groupId>
> <artifactId>groovy-eclipse-batch</artifactId>
> <version>[1.7.10-SNAPSHOT],[1.8.0-SNAPSHOT]</version>
> </dependency>
> (From: http://repo1.maven.org/maven2/org/codehaus/groovy/groovy-eclipse-compiler/2.5.1/groovy-eclipse-compiler-2.5.1.pom )
> Should this instead be -
>  <version>[1.7.10-02,1.7.10-99],[1.8.0-03,1.8.0-99]</version> ?
> Thanks,
> Barry
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email