Examples / reported plugin&dependency versions not working

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Examples / reported plugin&dependency versions not working

Milan Aleksic
Hi all,

I am having blocking issues with all of the examples from (nothing could be compiled) https://svn.codehaus.org/groovy/eclipse/trunk/extras

I also didn't find the "winning combination" of plugin and dependency versions, since it seems that on my Maven 2.2.1 also compiler is not working from your examples (attachment has the "clean compile" output).

Can anyone say if and when production-ready artifacts can be expected, or if that is already the case to update the example on page http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+compiler+plugin+for+Maven with exact artifact/plugin versions that are operational?


d:\Temp\groovy-eclipse-maven-tests>mvn --version
Apache Maven 2.2.1 (r801777; 2009-08-06 21:16:01+0200)
Java version: 1.6.0_18
Java home: c:\Program Files\Java\jdk1.6.0_18\jre
Default locale: en_US, platform encoding: Cp1252
OS name: "windows 7" version: "6.1" arch: "x86" Family: "windows"

---
Милан Алексић
email/gtalk: [hidden email]
cell: +381 64 702 69 67
http://www.milanaleksic.net

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email

groovy-eclipse-maven-tests.txt (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Examples / reported plugin&dependency versions not working

Andrew Eisenberg
I think there is a problem with the version number in the sample
project for groovy-eclipse-compiler.

Try using 2.5.1-M3 instead of 2.5.1-SNAPSHOT.  I updated the doc page,
but didn't update the sample project.

On Wed, Jun 1, 2011 at 7:19 AM, Milan Aleksic <[hidden email]> wrote:

> Hi all,
> I am having blocking issues with all of the examples from (nothing could be
> compiled) https://svn.codehaus.org/groovy/eclipse/trunk/extras
> I also didn't find the "winning combination" of plugin and dependency
> versions, since it seems that on my Maven 2.2.1 also compiler is not working
> from your examples (attachment has the "clean compile" output).
> Can anyone say if and when production-ready artifacts can be expected, or if
> that is already the case to update the example on
> page http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+compiler+plugin+for+Maven with
> exact artifact/plugin versions that are operational?
>
> d:\Temp\groovy-eclipse-maven-tests>mvn --version
> Apache Maven 2.2.1 (r801777; 2009-08-06 21:16:01+0200)
> Java version: 1.6.0_18
> Java home: c:\Program Files\Java\jdk1.6.0_18\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 7" version: "6.1" arch: "x86" Family: "windows"
> ---
> Милан Алексић
> email/gtalk: [hidden email]
> cell: +381 64 702 69 67
> http://www.milanaleksic.net
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Examples / reported plugin&dependency versions not working

Andrew Eisenberg
And an updated version of the test project is now available from the repository.

On Wed, Jun 1, 2011 at 8:54 AM, Andrew Eisenberg <[hidden email]> wrote:

> I think there is a problem with the version number in the sample
> project for groovy-eclipse-compiler.
>
> Try using 2.5.1-M3 instead of 2.5.1-SNAPSHOT.  I updated the doc page,
> but didn't update the sample project.
>
> On Wed, Jun 1, 2011 at 7:19 AM, Milan Aleksic <[hidden email]> wrote:
>> Hi all,
>> I am having blocking issues with all of the examples from (nothing could be
>> compiled) https://svn.codehaus.org/groovy/eclipse/trunk/extras
>> I also didn't find the "winning combination" of plugin and dependency
>> versions, since it seems that on my Maven 2.2.1 also compiler is not working
>> from your examples (attachment has the "clean compile" output).
>> Can anyone say if and when production-ready artifacts can be expected, or if
>> that is already the case to update the example on
>> page http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+compiler+plugin+for+Maven with
>> exact artifact/plugin versions that are operational?
>>
>> d:\Temp\groovy-eclipse-maven-tests>mvn --version
>> Apache Maven 2.2.1 (r801777; 2009-08-06 21:16:01+0200)
>> Java version: 1.6.0_18
>> Java home: c:\Program Files\Java\jdk1.6.0_18\jre
>> Default locale: en_US, platform encoding: Cp1252
>> OS name: "windows 7" version: "6.1" arch: "x86" Family: "windows"
>> ---
>> Милан Алексић
>> email/gtalk: [hidden email]
>> cell: +381 64 702 69 67
>> http://www.milanaleksic.net
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Examples / reported plugin&dependency versions not working

Milan Aleksic
Hi,

thanks for your help, but still none of items in https://svn.codehaus.org/groovy/eclipse/trunk/extras is prepared enough for "mvn clean compile" still.

Ok, probably I will have to continue experimenting until I get it correct.

Kind regards
---
Милан Алексић
email/gtalk: [hidden email]
cell: +381 64 702 69 67
http://www.milanaleksic.net


On Wed, Jun 1, 2011 at 6:01 PM, Andrew Eisenberg <[hidden email]> wrote:
And an updated version of the test project is now available from the repository.

On Wed, Jun 1, 2011 at 8:54 AM, Andrew Eisenberg <[hidden email]> wrote:
> I think there is a problem with the version number in the sample
> project for groovy-eclipse-compiler.
>
> Try using 2.5.1-M3 instead of 2.5.1-SNAPSHOT.  I updated the doc page,
> but didn't update the sample project.
>
> On Wed, Jun 1, 2011 at 7:19 AM, Milan Aleksic <[hidden email]> wrote:
>> Hi all,
>> I am having blocking issues with all of the examples from (nothing could be
>> compiled) https://svn.codehaus.org/groovy/eclipse/trunk/extras
>> I also didn't find the "winning combination" of plugin and dependency
>> versions, since it seems that on my Maven 2.2.1 also compiler is not working
>> from your examples (attachment has the "clean compile" output).
>> Can anyone say if and when production-ready artifacts can be expected, or if
>> that is already the case to update the example on
>> page http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+compiler+plugin+for+Maven with
>> exact artifact/plugin versions that are operational?
>>
>> d:\Temp\groovy-eclipse-maven-tests>mvn --version
>> Apache Maven 2.2.1 (r801777; 2009-08-06 21:16:01+0200)
>> Java version: 1.6.0_18
>> Java home: c:\Program Files\Java\jdk1.6.0_18\jre
>> Default locale: en_US, platform encoding: Cp1252
>> OS name: "windows 7" version: "6.1" arch: "x86" Family: "windows"
>> ---
>> Милан Алексић
>> email/gtalk: [hidden email]
>> cell: <a href="tel:%2B381%2064%20702%2069%2067" value="+381647026967">+381 64 702 69 67
>> http://www.milanaleksic.net
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: Examples / reported plugin&dependency versions not working

Andrew Eisenberg
I just uploaded an archetype project, which may be easier for you to
use.  Try running this command:

mvn archetype:generate \
    -DarchetypeGroupId=org.codehaus.groovy \
    -DarchetypeArtifactId=groovy-eclipse-quickstart \
    -DarchetypeVersion=2.5.1-M3-SNAPSHOT \
    -DgroupId=foo \
    -DartifactId=bar \
    -Dversion=1 \
    -DinteractiveMode=false \
    -DarchetypeRepository=https://nexus.codehaus.org/content/repositories/snapshots/



On Wed, Jun 1, 2011 at 9:40 AM, Milan Aleksic <[hidden email]> wrote:

> Hi,
> thanks for your help, but still none of items
> in https://svn.codehaus.org/groovy/eclipse/trunk/extras is prepared enough
> for "mvn clean compile" still.
> Ok, probably I will have to continue experimenting until I get it correct.
> Kind regards
> ---
> Милан Алексић
> email/gtalk: [hidden email]
> cell: +381 64 702 69 67
> http://www.milanaleksic.net
>
>
> On Wed, Jun 1, 2011 at 6:01 PM, Andrew Eisenberg <[hidden email]>
> wrote:
>>
>> And an updated version of the test project is now available from the
>> repository.
>>
>> On Wed, Jun 1, 2011 at 8:54 AM, Andrew Eisenberg <[hidden email]>
>> wrote:
>> > I think there is a problem with the version number in the sample
>> > project for groovy-eclipse-compiler.
>> >
>> > Try using 2.5.1-M3 instead of 2.5.1-SNAPSHOT.  I updated the doc page,
>> > but didn't update the sample project.
>> >
>> > On Wed, Jun 1, 2011 at 7:19 AM, Milan Aleksic <[hidden email]>
>> > wrote:
>> >> Hi all,
>> >> I am having blocking issues with all of the examples from (nothing
>> >> could be
>> >> compiled) https://svn.codehaus.org/groovy/eclipse/trunk/extras
>> >> I also didn't find the "winning combination" of plugin and dependency
>> >> versions, since it seems that on my Maven 2.2.1 also compiler is not
>> >> working
>> >> from your examples (attachment has the "clean compile" output).
>> >> Can anyone say if and when production-ready artifacts can be expected,
>> >> or if
>> >> that is already the case to update the example on
>> >>
>> >> page http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+compiler+plugin+for+Maven with
>> >> exact artifact/plugin versions that are operational?
>> >>
>> >> d:\Temp\groovy-eclipse-maven-tests>mvn --version
>> >> Apache Maven 2.2.1 (r801777; 2009-08-06 21:16:01+0200)
>> >> Java version: 1.6.0_18
>> >> Java home: c:\Program Files\Java\jdk1.6.0_18\jre
>> >> Default locale: en_US, platform encoding: Cp1252
>> >> OS name: "windows 7" version: "6.1" arch: "x86" Family: "windows"
>> >> ---
>> >> Милан Алексић
>> >> email/gtalk: [hidden email]
>> >> cell: +381 64 702 69 67
>> >> http://www.milanaleksic.net
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe from this list, please visit:
>> >>
>> >>    http://xircles.codehaus.org/manage_email
>> >>
>> >>
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Examples / reported plugin&dependency versions not working

Milan Aleksic
Works perfectly!

I took a look at the generated pom.xml for the winning combination:
maven-compiler-plugin: 2.3.3
groovy-eclipse-compiler: 2.5.1-M3
groovy-eclipse-batch: 1.8.0-03

Thanks a lot! 
As I guessed, this approach works way cooler than gmaven :)

Bye
---
Милан Алексић
email/gtalk: [hidden email]
cell: +381 64 702 69 67
http://www.milanaleksic.net


On Wed, Jun 1, 2011 at 6:44 PM, Andrew Eisenberg <[hidden email]> wrote:
I just uploaded an archetype project, which may be easier for you to
use.  Try running this command:

mvn archetype:generate \
   -DarchetypeGroupId=org.codehaus.groovy \
   -DarchetypeArtifactId=groovy-eclipse-quickstart \
   -DarchetypeVersion=2.5.1-M3-SNAPSHOT \
   -DgroupId=foo \
   -DartifactId=bar \
   -Dversion=1 \
   -DinteractiveMode=false \
   -DarchetypeRepository=https://nexus.codehaus.org/content/repositories/snapshots/



On Wed, Jun 1, 2011 at 9:40 AM, Milan Aleksic <[hidden email]> wrote:
> Hi,
> thanks for your help, but still none of items
> in https://svn.codehaus.org/groovy/eclipse/trunk/extras is prepared enough
> for "mvn clean compile" still.
> Ok, probably I will have to continue experimenting until I get it correct.
> Kind regards
> ---
> Милан Алексић
> email/gtalk: [hidden email]
> cell: <a href="tel:%2B381%2064%20702%2069%2067" value="+381647026967">+381 64 702 69 67
> http://www.milanaleksic.net
>
>
> On Wed, Jun 1, 2011 at 6:01 PM, Andrew Eisenberg <[hidden email]>
> wrote:
>>
>> And an updated version of the test project is now available from the
>> repository.
>>
>> On Wed, Jun 1, 2011 at 8:54 AM, Andrew Eisenberg <[hidden email]>
>> wrote:
>> > I think there is a problem with the version number in the sample
>> > project for groovy-eclipse-compiler.
>> >
>> > Try using 2.5.1-M3 instead of 2.5.1-SNAPSHOT.  I updated the doc page,
>> > but didn't update the sample project.
>> >
>> > On Wed, Jun 1, 2011 at 7:19 AM, Milan Aleksic <[hidden email]>
>> > wrote:
>> >> Hi all,
>> >> I am having blocking issues with all of the examples from (nothing
>> >> could be
>> >> compiled) https://svn.codehaus.org/groovy/eclipse/trunk/extras
>> >> I also didn't find the "winning combination" of plugin and dependency
>> >> versions, since it seems that on my Maven 2.2.1 also compiler is not
>> >> working
>> >> from your examples (attachment has the "clean compile" output).
>> >> Can anyone say if and when production-ready artifacts can be expected,
>> >> or if
>> >> that is already the case to update the example on
>> >>
>> >> page http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+compiler+plugin+for+Maven with
>> >> exact artifact/plugin versions that are operational?
>> >>
>> >> d:\Temp\groovy-eclipse-maven-tests>mvn --version
>> >> Apache Maven 2.2.1 (r801777; 2009-08-06 21:16:01+0200)
>> >> Java version: 1.6.0_18
>> >> Java home: c:\Program Files\Java\jdk1.6.0_18\jre
>> >> Default locale: en_US, platform encoding: Cp1252
>> >> OS name: "windows 7" version: "6.1" arch: "x86" Family: "windows"
>> >> ---
>> >> Милан Алексић
>> >> email/gtalk: [hidden email]
>> >> cell: <a href="tel:%2B381%2064%20702%2069%2067" value="+381647026967">+381 64 702 69 67
>> >> http://www.milanaleksic.net
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe from this list, please visit:
>> >>
>> >>    http://xircles.codehaus.org/manage_email
>> >>
>> >>
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: Examples / reported plugin&dependency versions not working

Andrew Eisenberg
Glad you were able to get it working and thanks for the feedback.  The
final release will be out at the end of June.

On Wed, Jun 1, 2011 at 10:01 AM, Milan Aleksic <[hidden email]> wrote:

> Works perfectly!
> I took a look at the generated pom.xml for the winning combination:
> maven-compiler-plugin: 2.3.3
> groovy-eclipse-compiler: 2.5.1-M3
> groovy-eclipse-batch: 1.8.0-03
> Thanks a lot!
> As I guessed, this approach works way cooler than gmaven :)
> Bye
> ---
> Милан Алексић
> email/gtalk: [hidden email]
> cell: +381 64 702 69 67
> http://www.milanaleksic.net
>
>
> On Wed, Jun 1, 2011 at 6:44 PM, Andrew Eisenberg <[hidden email]>
> wrote:
>>
>> I just uploaded an archetype project, which may be easier for you to
>> use.  Try running this command:
>>
>> mvn archetype:generate \
>>    -DarchetypeGroupId=org.codehaus.groovy \
>>    -DarchetypeArtifactId=groovy-eclipse-quickstart \
>>    -DarchetypeVersion=2.5.1-M3-SNAPSHOT \
>>    -DgroupId=foo \
>>    -DartifactId=bar \
>>    -Dversion=1 \
>>    -DinteractiveMode=false \
>>
>>  -DarchetypeRepository=https://nexus.codehaus.org/content/repositories/snapshots/
>>
>>
>>
>> On Wed, Jun 1, 2011 at 9:40 AM, Milan Aleksic <[hidden email]>
>> wrote:
>> > Hi,
>> > thanks for your help, but still none of items
>> > in https://svn.codehaus.org/groovy/eclipse/trunk/extras is prepared
>> > enough
>> > for "mvn clean compile" still.
>> > Ok, probably I will have to continue experimenting until I get it
>> > correct.
>> > Kind regards
>> > ---
>> > Милан Алексић
>> > email/gtalk: [hidden email]
>> > cell: +381 64 702 69 67
>> > http://www.milanaleksic.net
>> >
>> >
>> > On Wed, Jun 1, 2011 at 6:01 PM, Andrew Eisenberg <[hidden email]>
>> > wrote:
>> >>
>> >> And an updated version of the test project is now available from the
>> >> repository.
>> >>
>> >> On Wed, Jun 1, 2011 at 8:54 AM, Andrew Eisenberg <[hidden email]>
>> >> wrote:
>> >> > I think there is a problem with the version number in the sample
>> >> > project for groovy-eclipse-compiler.
>> >> >
>> >> > Try using 2.5.1-M3 instead of 2.5.1-SNAPSHOT.  I updated the doc
>> >> > page,
>> >> > but didn't update the sample project.
>> >> >
>> >> > On Wed, Jun 1, 2011 at 7:19 AM, Milan Aleksic
>> >> > <[hidden email]>
>> >> > wrote:
>> >> >> Hi all,
>> >> >> I am having blocking issues with all of the examples from (nothing
>> >> >> could be
>> >> >> compiled) https://svn.codehaus.org/groovy/eclipse/trunk/extras
>> >> >> I also didn't find the "winning combination" of plugin and
>> >> >> dependency
>> >> >> versions, since it seems that on my Maven 2.2.1 also compiler is not
>> >> >> working
>> >> >> from your examples (attachment has the "clean compile" output).
>> >> >> Can anyone say if and when production-ready artifacts can be
>> >> >> expected,
>> >> >> or if
>> >> >> that is already the case to update the example on
>> >> >>
>> >> >>
>> >> >> page http://docs.codehaus.org/display/GROOVY/Groovy-Eclipse+compiler+plugin+for+Maven with
>> >> >> exact artifact/plugin versions that are operational?
>> >> >>
>> >> >> d:\Temp\groovy-eclipse-maven-tests>mvn --version
>> >> >> Apache Maven 2.2.1 (r801777; 2009-08-06 21:16:01+0200)
>> >> >> Java version: 1.6.0_18
>> >> >> Java home: c:\Program Files\Java\jdk1.6.0_18\jre
>> >> >> Default locale: en_US, platform encoding: Cp1252
>> >> >> OS name: "windows 7" version: "6.1" arch: "x86" Family: "windows"
>> >> >> ---
>> >> >> Милан Алексић
>> >> >> email/gtalk: [hidden email]
>> >> >> cell: +381 64 702 69 67
>> >> >> http://www.milanaleksic.net
>> >> >>
>> >> >>
>> >> >> ---------------------------------------------------------------------
>> >> >> To unsubscribe from this list, please visit:
>> >> >>
>> >> >>    http://xircles.codehaus.org/manage_email
>> >> >>
>> >> >>
>> >> >
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe from this list, please visit:
>> >>
>> >>    http://xircles.codehaus.org/manage_email
>> >>
>> >>
>> >
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email