Groovy 2.0 for Eclipse 3.5 (Galileo)?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Groovy 2.0 for Eclipse 3.5 (Galileo)?

Torsten Witte
Hi!

I have an Eclipse RCP application that uses Groovy code inside. The
target platform is Eclipse 3.5.2 and contains the corresponding Groovy
plugin(s) from http://groovy.codehaus.org/Eclipse+Plugin which seem to
use Groovy 1.6.7/1.7.5.
Now I want to use Groovy 2.0 and update the plugins in the target
platform but there are no new plugin versions for Eclipse 3.5.
For some other reasons I can not update the whole target platform to
Eclipse 3.7. or 4.2. at the moment.

Will there come any updates of the Eclipse 3.5 plugins with an actual
Groovy inside?

Regards

    Torsten

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.0 for Eclipse 3.5 (Galileo)?

Andrew Eisenberg
We are no longer supporting Groovy-Eclipse on eclipse 3.5.  APIs have
changed between then and now and it is not feasible to make all
changes backwards compatible.

Can you be more specific about why you can't upgrade to 3.7 or 4.2?
Maybe there's a workaroud that we can do.

On Wed, Sep 19, 2012 at 8:57 AM, Torsten Witte <[hidden email]> wrote:

> Hi!
>
> I have an Eclipse RCP application that uses Groovy code inside. The target
> platform is Eclipse 3.5.2 and contains the corresponding Groovy plugin(s)
> from http://groovy.codehaus.org/Eclipse+Plugin which seem to use Groovy
> 1.6.7/1.7.5.
> Now I want to use Groovy 2.0 and update the plugins in the target platform
> but there are no new plugin versions for Eclipse 3.5.
> For some other reasons I can not update the whole target platform to Eclipse
> 3.7. or 4.2. at the moment.
>
> Will there come any updates of the Eclipse 3.5 plugins with an actual Groovy
> inside?
>
> Regards
>
>    Torsten
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.0 for Eclipse 3.5 (Galileo)?

Torsten Witte
Hello Andrew!

Thanks for your reply.
The reason why I can not upgrade to Eclipse 3.7 or later has nothing to
do with Groovy. It's something about the p2 update mechanism I can not
fix at the moment.

I don't need the full IDE integration for Groovy in Eclipse 3.5. The
only thing I have is a dependency to the org.codehaus.groovy plugin and
the org.codehaus.groovy.eclipse.ant.GroovyCompilerAdapter in the
build.properties for PDE build, like described here:
http://www.subshell.com/en/subshell/blog/Using-Groovy-In-Eclipse-RCP100.html 
(I just see you know about how it works :-) )
For development I use Eclipse 3.7 / 4.2.

Is it possible to extract only that functionality for using (not
developing!) Groovy 2.0 code in a Eclipse 3.5 application?

Regards

    Torsten


Am 19.09.2012 19:23, schrieb Andrew Eisenberg:

> We are no longer supporting Groovy-Eclipse on eclipse 3.5.  APIs have
> changed between then and now and it is not feasible to make all
> changes backwards compatible.
>
> Can you be more specific about why you can't upgrade to 3.7 or 4.2?
> Maybe there's a workaroud that we can do.
>
> On Wed, Sep 19, 2012 at 8:57 AM, Torsten Witte<[hidden email]>  wrote:
>    
>> Hi!
>>
>> I have an Eclipse RCP application that uses Groovy code inside. The target
>> platform is Eclipse 3.5.2 and contains the corresponding Groovy plugin(s)
>> from http://groovy.codehaus.org/Eclipse+Plugin which seem to use Groovy
>> 1.6.7/1.7.5.
>> Now I want to use Groovy 2.0 and update the plugins in the target platform
>> but there are no new plugin versions for Eclipse 3.5.
>> For some other reasons I can not update the whole target platform to Eclipse
>> 3.7. or 4.2. at the moment.
>>
>> Will there come any updates of the Eclipse 3.5 plugins with an actual Groovy
>> inside?
>>
>> Regards
>>
>>     Torsten
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>     http://xircles.codehaus.org/manage_email
>>
>>
>>      
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>      http://xircles.codehaus.org/manage_email
>
>
>    


--
Torsten Witte
subshell GmbH
Hongkongstrasse 5
D-20457 Hamburg
fon +49.40 431 362 21
fax +49.40 431 362 29
[hidden email]
http://www.subshell.com


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.0 for Eclipse 3.5 (Galileo)?

Andrew Eisenberg
The groovy 2.0 plugin (not the feature) has no dependencies on
anything in Eclipse 3.6 or later (with a little refactoring, I think
we can remove those dependencies from the feature).

What this means is that you can install the groovy 2.0 plugin from the
command line using the p2 director application.

I think this was installed by default into E3.5.  See the docs here
(for Eclipse Galileo 3.5):
http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse.platform.doc.isv/guide/p2_director.html

You will need to do something like this:

 <targetProductFolder>/eclipsec.exe
   -application org.eclipse.equinox.p2.director
   -repository http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e4.2/
   -installIU org.codehaus.groovy/2.0.0




On Thu, Sep 20, 2012 at 12:41 AM, Torsten Witte <[hidden email]> wrote:

> Hello Andrew!
>
> Thanks for your reply.
> The reason why I can not upgrade to Eclipse 3.7 or later has nothing to do
> with Groovy. It's something about the p2 update mechanism I can not fix at
> the moment.
>
> I don't need the full IDE integration for Groovy in Eclipse 3.5. The only
> thing I have is a dependency to the org.codehaus.groovy plugin and the
> org.codehaus.groovy.eclipse.ant.GroovyCompilerAdapter in the
> build.properties for PDE build, like described here:
> http://www.subshell.com/en/subshell/blog/Using-Groovy-In-Eclipse-RCP100.html
> (I just see you know about how it works :-) )
> For development I use Eclipse 3.7 / 4.2.
>
> Is it possible to extract only that functionality for using (not
> developing!) Groovy 2.0 code in a Eclipse 3.5 application?
>
> Regards
>
>    Torsten
>
>
> Am 19.09.2012 19:23, schrieb Andrew Eisenberg:
>
>> We are no longer supporting Groovy-Eclipse on eclipse 3.5.  APIs have
>> changed between then and now and it is not feasible to make all
>> changes backwards compatible.
>>
>> Can you be more specific about why you can't upgrade to 3.7 or 4.2?
>> Maybe there's a workaroud that we can do.
>>
>> On Wed, Sep 19, 2012 at 8:57 AM, Torsten Witte<[hidden email]>  wrote:
>>
>>>
>>> Hi!
>>>
>>> I have an Eclipse RCP application that uses Groovy code inside. The
>>> target
>>> platform is Eclipse 3.5.2 and contains the corresponding Groovy plugin(s)
>>> from http://groovy.codehaus.org/Eclipse+Plugin which seem to use Groovy
>>> 1.6.7/1.7.5.
>>> Now I want to use Groovy 2.0 and update the plugins in the target
>>> platform
>>> but there are no new plugin versions for Eclipse 3.5.
>>> For some other reasons I can not update the whole target platform to
>>> Eclipse
>>> 3.7. or 4.2. at the moment.
>>>
>>> Will there come any updates of the Eclipse 3.5 plugins with an actual
>>> Groovy
>>> inside?
>>>
>>> Regards
>>>
>>>     Torsten
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe from this list, please visit:
>>>
>>>     http://xircles.codehaus.org/manage_email
>>>
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>      http://xircles.codehaus.org/manage_email
>>
>>
>>
>
>
>
> --
> Torsten Witte
> subshell GmbH
> Hongkongstrasse 5
> D-20457 Hamburg
> fon +49.40 431 362 21
> fax +49.40 431 362 29
> [hidden email]
> http://www.subshell.com
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.0 for Eclipse 3.5 (Galileo)?

Torsten Witte
Hello Andrew!

Thanks for your advice. Simply adding the newest version of the org.codehaus.groovy plugin (org.codehaus.groovy_2.0.4.xx-20120921-2000-e42RELEASE) to my target platform and changing the version number in the dependencies of my plugins works fine for me.

Regards

   Torsten


Am 20.09.2012 17:23, schrieb Andrew Eisenberg:
The groovy 2.0 plugin (not the feature) has no dependencies on
anything in Eclipse 3.6 or later (with a little refactoring, I think
we can remove those dependencies from the feature).

What this means is that you can install the groovy 2.0 plugin from the
command line using the p2 director application.

I think this was installed by default into E3.5.  See the docs here
(for Eclipse Galileo 3.5):
http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse.platform.doc.isv/guide/p2_director.html

You will need to do something like this:

 <targetProductFolder>/eclipsec.exe
   -application org.eclipse.equinox.p2.director
   -repository http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e4.2/
   -installIU org.codehaus.groovy/2.0.0




On Thu, Sep 20, 2012 at 12:41 AM, Torsten Witte [hidden email] wrote:
  
Hello Andrew!

Thanks for your reply.
The reason why I can not upgrade to Eclipse 3.7 or later has nothing to do
with Groovy. It's something about the p2 update mechanism I can not fix at
the moment.

I don't need the full IDE integration for Groovy in Eclipse 3.5. The only
thing I have is a dependency to the org.codehaus.groovy plugin and the
org.codehaus.groovy.eclipse.ant.GroovyCompilerAdapter in the
build.properties for PDE build, like described here:
http://www.subshell.com/en/subshell/blog/Using-Groovy-In-Eclipse-RCP100.html
(I just see you know about how it works :-) )
For development I use Eclipse 3.7 / 4.2.

Is it possible to extract only that functionality for using (not
developing!) Groovy 2.0 code in a Eclipse 3.5 application?

Regards

   Torsten


Am 19.09.2012 19:23, schrieb Andrew Eisenberg:

    
We are no longer supporting Groovy-Eclipse on eclipse 3.5.  APIs have
changed between then and now and it is not feasible to make all
changes backwards compatible.

Can you be more specific about why you can't upgrade to 3.7 or 4.2?
Maybe there's a workaroud that we can do.

On Wed, Sep 19, 2012 at 8:57 AM, Torsten Witte[hidden email]  wrote:

      
Hi!

I have an Eclipse RCP application that uses Groovy code inside. The
target
platform is Eclipse 3.5.2 and contains the corresponding Groovy plugin(s)
from http://groovy.codehaus.org/Eclipse+Plugin which seem to use Groovy
1.6.7/1.7.5.
Now I want to use Groovy 2.0 and update the plugins in the target
platform
but there are no new plugin versions for Eclipse 3.5.
For some other reasons I can not update the whole target platform to
Eclipse
3.7. or 4.2. at the moment.

Will there come any updates of the Eclipse 3.5 plugins with an actual
Groovy
inside?

Regards

    Torsten

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



        
---------------------------------------------------------------------
To unsubscribe from this list, please visit:

     http://xircles.codehaus.org/manage_email



      






---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email


    
---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email