Groovy-Eclipse Plugin Installation Problems

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Groovy-Eclipse Plugin Installation Problems

Nikolay Sorokin

Hi

 

I've a need to do some development in Groovy and decided to install Groovy-Eclipse plugin into my Eclipse environment. However installation from URL http://dist.springsource.org/release/GRECLIPSE/e3.6/ did not completed because of conflicting dependency (p2 installation message):

Cannot complete the install because of a conflicting dependency.

  Software being installed: Groovy-Eclipse Feature 2.1.2.xx-20110310-1500-e36 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.2.xx-20110310-1500-e36)

  Software currently installed: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)

  Only one of the following can be installed at once:

    Java Development Tools Core 3.6.2.xx-20110321-1600-e36 (org.eclipse.jdt.core 3.6.2.xx-20110321-1600-e36)

    Java Development Tools Core 3.6.2.xx-20110310-1500-e36 (org.eclipse.jdt.core 3.6.2.xx-20110310-1500-e36)

    Java Development Tools Core 3.6.1.v_A68_R36x (org.eclipse.jdt.core 3.6.1.v_A68_R36x)

  Cannot satisfy dependency:

    From: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)

    To: org.eclipse.jdt.core [3.6.1.v_A68_R36x]

  Cannot satisfy dependency:

    From: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)

    To: org.eclipse.jdt.feature.group [3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH]

  Cannot satisfy dependency:

    From: Groovy-Eclipse Feature 2.1.2.xx-20110310-1500-e36 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.2.xx-20110310-1500-e36)

    To: org.codehaus.groovy.jdt.patch.feature.group [2.1.2.xx-20110310-1500-e36]

  Cannot satisfy dependency:

    From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.1.2.xx-20110310-1500-e36 Eclipse Java Development Tools 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH (org.eclipse.jdt.feature.group 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH)

    To: org.eclipse.jdt.core [3.6.2.xx-20110310-1500-e36]

 

While attempting to install with Eclipse classic update from downloaded Groovy-Eclipse plugin groovy.archive-2.1.2.xx-20110310-1500-e36.zip the following message

JDT Core patch for Groovy-Eclipse plugin  (2.1.2.xx-20110310-1500-e36) requires feature "org.eclipse.jdt (3.6.0.v20100124-2000-7z8WFRAFMTdeCo0y7FJt1Zi45027)".

is issued by Eclipse update function.

 

The base Eclipse version is Eclipse SDK Version: 3.6.1 Build id: M20100909-0800. I'm not able to install both 32 and 64-bit Windows versions. I've also tried to install the snapshot of Groovy-Eclipse plugin with the same results. My understanding of the installation problem is that Groovy-Eclipse plugin depends on specific version of Eclipse JDT (specifically 3.6.0.v20100124-2000-7z8WFRAFMTdeCo0y7FJt1Zi45027 - seems to be intermediate milestone of Helios release) but this version is not available for download from Eclipse site and it is quite old.

 

I would be very thankful if I'll be provided with help on installation of the Groovy-Eclipse plugin into Eclipse 3.6.x environment.

 

Regards

Nick Sorokin

 

This message was scanned at Tuesday, March 22, 2011 10:51:49 AM GMT by Trend Micro IMHS on behalf of
White Clarke Group - www.whiteclarkegroup.com.

White Clarke Group Ltd - Registered in England - Registered number 03435619.
Registered address: Fairfax House, 15 Fulwood Place, London, WC1V 6AY 
Reply | Threaded
Open this post in threaded view
|

Re: Groovy-Eclipse Plugin Installation Problems

Andrew Eisenberg
I think that you are hitting this problem:
http://grails.org/STS+FAQ
See section called:  "Help, I can't install Groovy-Eclipse!"

And here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=332158


On Tue, Mar 22, 2011 at 3:51 AM, Nikolay Sorokin
<[hidden email]> wrote:

>
> Hi
>
>
>
> I've a need to do some development in Groovy and decided to install Groovy-Eclipse plugin into my Eclipse environment. However installation from URL http://dist.springsource.org/release/GRECLIPSE/e3.6/ did not completed because of conflicting dependency (p2 installation message):
>
> Cannot complete the install because of a conflicting dependency.
>
>   Software being installed: Groovy-Eclipse Feature 2.1.2.xx-20110310-1500-e36 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.2.xx-20110310-1500-e36)
>
>   Software currently installed: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)
>
>   Only one of the following can be installed at once:
>
>     Java Development Tools Core 3.6.2.xx-20110321-1600-e36 (org.eclipse.jdt.core 3.6.2.xx-20110321-1600-e36)
>
>     Java Development Tools Core 3.6.2.xx-20110310-1500-e36 (org.eclipse.jdt.core 3.6.2.xx-20110310-1500-e36)
>
>     Java Development Tools Core 3.6.1.v_A68_R36x (org.eclipse.jdt.core 3.6.1.v_A68_R36x)
>
>   Cannot satisfy dependency:
>
>     From: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)
>
>     To: org.eclipse.jdt.core [3.6.1.v_A68_R36x]
>
>   Cannot satisfy dependency:
>
>     From: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)
>
>     To: org.eclipse.jdt.feature.group [3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH]
>
>   Cannot satisfy dependency:
>
>     From: Groovy-Eclipse Feature 2.1.2.xx-20110310-1500-e36 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.2.xx-20110310-1500-e36)
>
>     To: org.codehaus.groovy.jdt.patch.feature.group [2.1.2.xx-20110310-1500-e36]
>
>   Cannot satisfy dependency:
>
>     From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.1.2.xx-20110310-1500-e36 Eclipse Java Development Tools 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH (org.eclipse.jdt.feature.group 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH)
>
>     To: org.eclipse.jdt.core [3.6.2.xx-20110310-1500-e36]
>
>
>
> While attempting to install with Eclipse classic update from downloaded Groovy-Eclipse plugin groovy.archive-2.1.2.xx-20110310-1500-e36.zip the following message
>
> JDT Core patch for Groovy-Eclipse plugin  (2.1.2.xx-20110310-1500-e36) requires feature "org.eclipse.jdt (3.6.0.v20100124-2000-7z8WFRAFMTdeCo0y7FJt1Zi45027)".
>
> is issued by Eclipse update function.
>
>
>
> The base Eclipse version is Eclipse SDK Version: 3.6.1 Build id: M20100909-0800. I'm not able to install both 32 and 64-bit Windows versions. I've also tried to install the snapshot of Groovy-Eclipse plugin with the same results. My understanding of the installation problem is that Groovy-Eclipse plugin depends on specific version of Eclipse JDT (specifically 3.6.0.v20100124-2000-7z8WFRAFMTdeCo0y7FJt1Zi45027 - seems to be intermediate milestone of Helios release) but this version is not available for download from Eclipse site and it is quite old.
>
>
>
> I would be very thankful if I'll be provided with help on installation of the Groovy-Eclipse plugin into Eclipse 3.6.x environment.
>
>
>
> Regards
>
> Nick Sorokin
>
>
>
> This message was scanned at Tuesday, March 22, 2011 10:51:49 AM GMT by Trend Micro IMHS on behalf of
> White Clarke Group - www.whiteclarkegroup.com.
>
> White Clarke Group Ltd - Registered in England - Registered number 03435619.
> Registered address: Fairfax House, 15 Fulwood Place, London, WC1V 6AY

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

RE: Groovy-Eclipse Plugin Installation Problems

Nikolay Sorokin
Thanks Andrew,

Just before the reply came to me I've managed to install Groovy-Eclipse plugin.

The main difference between these two attempts is the way it was performed. In both cases pure Eclipse SDK was used, in both cases I've used p2 process for installation. The only difference was: in unsuccessful attempt I've use -configuration parameter with configuration folder outside of default location, in second attempt the default location was used. This may be attributed as Eclipse p2 bug, but I use non-default location for configuration files throughout organisation and I didn't experience this problem before. So, at this moment my suspicion  would be with Groove-Eclipse, but I may be very wrong.

I'm currently OK with the way it is installed because Groovy plugin is sort of extension of the standard JDT which is a core of most Eclipse installation, but I would appreciate a better than JDT patch solution for installation of the plugin.

Regards,
Nick

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
Sent: 22 March 2011 16:30
To: [hidden email]
Subject: Re: [groovy-eclipse-plugin-dev] Groovy-Eclipse Plugin Installation Problems

I think that you are hitting this problem:
http://grails.org/STS+FAQ
See section called:  "Help, I can't install Groovy-Eclipse!"

And here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=332158


On Tue, Mar 22, 2011 at 3:51 AM, Nikolay Sorokin
<[hidden email]> wrote:

>
> Hi
>
>
>
> I've a need to do some development in Groovy and decided to install Groovy-Eclipse plugin into my Eclipse environment. However installation from URL http://dist.springsource.org/release/GRECLIPSE/e3.6/ did not completed because of conflicting dependency (p2 installation message):
>
> Cannot complete the install because of a conflicting dependency.
>
>   Software being installed: Groovy-Eclipse Feature 2.1.2.xx-20110310-1500-e36 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.2.xx-20110310-1500-e36)
>
>   Software currently installed: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)
>
>   Only one of the following can be installed at once:
>
>     Java Development Tools Core 3.6.2.xx-20110321-1600-e36 (org.eclipse.jdt.core 3.6.2.xx-20110321-1600-e36)
>
>     Java Development Tools Core 3.6.2.xx-20110310-1500-e36 (org.eclipse.jdt.core 3.6.2.xx-20110310-1500-e36)
>
>     Java Development Tools Core 3.6.1.v_A68_R36x (org.eclipse.jdt.core 3.6.1.v_A68_R36x)
>
>   Cannot satisfy dependency:
>
>     From: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)
>
>     To: org.eclipse.jdt.core [3.6.1.v_A68_R36x]
>
>   Cannot satisfy dependency:
>
>     From: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)
>
>     To: org.eclipse.jdt.feature.group [3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH]
>
>   Cannot satisfy dependency:
>
>     From: Groovy-Eclipse Feature 2.1.2.xx-20110310-1500-e36 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.2.xx-20110310-1500-e36)
>
>     To: org.codehaus.groovy.jdt.patch.feature.group [2.1.2.xx-20110310-1500-e36]
>
>   Cannot satisfy dependency:
>
>     From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.1.2.xx-20110310-1500-e36 Eclipse Java Development Tools 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH (org.eclipse.jdt.feature.group 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH)
>
>     To: org.eclipse.jdt.core [3.6.2.xx-20110310-1500-e36]
>
>
>
> While attempting to install with Eclipse classic update from downloaded Groovy-Eclipse plugin groovy.archive-2.1.2.xx-20110310-1500-e36.zip the following message
>
> JDT Core patch for Groovy-Eclipse plugin  (2.1.2.xx-20110310-1500-e36) requires feature "org.eclipse.jdt (3.6.0.v20100124-2000-7z8WFRAFMTdeCo0y7FJt1Zi45027)".
>
> is issued by Eclipse update function.
>
>
>
> The base Eclipse version is Eclipse SDK Version: 3.6.1 Build id: M20100909-0800. I'm not able to install both 32 and 64-bit Windows versions. I've also tried to install the snapshot of Groovy-Eclipse plugin with the same results. My understanding of the installation problem is that Groovy-Eclipse plugin depends on specific version of Eclipse JDT (specifically 3.6.0.v20100124-2000-7z8WFRAFMTdeCo0y7FJt1Zi45027 - seems to be intermediate milestone of Helios release) but this version is not available for download from Eclipse site and it is quite old.
>
>
>
> I would be very thankful if I'll be provided with help on installation of the Groovy-Eclipse plugin into Eclipse 3.6.x environment.
>
>
>
> Regards
>
> Nick Sorokin
>
>
>
> This message was scanned at Tuesday, March 22, 2011 10:51:49 AM GMT by Trend Micro IMHS on behalf of
> White Clarke Group - www.whiteclarkegroup.com.
>
> White Clarke Group Ltd - Registered in England - Registered number 03435619.
> Registered address: Fairfax House, 15 Fulwood Place, London, WC1V 6AY

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



This message was scanned at Tuesday, March 22, 2011 4:30:46 PM GMT by Trend Micro IMHS on behalf of White Clarke Group

This message was scanned at Tuesday, March 22, 2011 5:04:15 PM GMT by Trend Micro IMHS on behalf of
White Clarke Group - www.whiteclarkegroup.com.

White Clarke Group Ltd - Registered in England - Registered number 03435619.
Registered address: Fairfax House, 15 Fulwood Place, London, WC1V 6AY

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Groovy-Eclipse Plugin Installation Problems

Andrew Eisenberg
Hi Nick,

Your environment is something that I have not come across before.
Using an external configuration folder is indeed very similar to using
a read-only eclipse installation directory (the effect is the
same---both cause configuration information to be written and plugins
to be stored in a separate location).

Although the effect is that it is difficult to install Groovy-Eclipse
in this scenario, it is really out of our control to do things
differently.  Since we require a patch for the JDT, the Groovy-Eclipse
plugins (and configuration) must be installed in the same directory as
JDT.  If not, then you get the very cryptic error message that you
received when installing.

I raised a bug for the read-only problem, but this should also help
your situation as well:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=332158
unfortunately, the p2 team has not been able to do much to help with this yet.

On Tue, Mar 22, 2011 at 10:04 AM, Nikolay Sorokin
<[hidden email]> wrote:

> Thanks Andrew,
>
> Just before the reply came to me I've managed to install Groovy-Eclipse plugin.
>
> The main difference between these two attempts is the way it was performed. In both cases pure Eclipse SDK was used, in both cases I've used p2 process for installation. The only difference was: in unsuccessful attempt I've use -configuration parameter with configuration folder outside of default location, in second attempt the default location was used. This may be attributed as Eclipse p2 bug, but I use non-default location for configuration files throughout organisation and I didn't experience this problem before. So, at this moment my suspicion  would be with Groove-Eclipse, but I may be very wrong.
>
> I'm currently OK with the way it is installed because Groovy plugin is sort of extension of the standard JDT which is a core of most Eclipse installation, but I would appreciate a better than JDT patch solution for installation of the plugin.
>
> Regards,
> Nick
>
> -----Original Message-----
> From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
> Sent: 22 March 2011 16:30
> To: [hidden email]
> Subject: Re: [groovy-eclipse-plugin-dev] Groovy-Eclipse Plugin Installation Problems
>
> I think that you are hitting this problem:
> http://grails.org/STS+FAQ
> See section called:  "Help, I can't install Groovy-Eclipse!"
>
> And here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=332158
>
>
> On Tue, Mar 22, 2011 at 3:51 AM, Nikolay Sorokin
> <[hidden email]> wrote:
>>
>> Hi
>>
>>
>>
>> I've a need to do some development in Groovy and decided to install Groovy-Eclipse plugin into my Eclipse environment. However installation from URL http://dist.springsource.org/release/GRECLIPSE/e3.6/ did not completed because of conflicting dependency (p2 installation message):
>>
>> Cannot complete the install because of a conflicting dependency.
>>
>>   Software being installed: Groovy-Eclipse Feature 2.1.2.xx-20110310-1500-e36 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.2.xx-20110310-1500-e36)
>>
>>   Software currently installed: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)
>>
>>   Only one of the following can be installed at once:
>>
>>     Java Development Tools Core 3.6.2.xx-20110321-1600-e36 (org.eclipse.jdt.core 3.6.2.xx-20110321-1600-e36)
>>
>>     Java Development Tools Core 3.6.2.xx-20110310-1500-e36 (org.eclipse.jdt.core 3.6.2.xx-20110310-1500-e36)
>>
>>     Java Development Tools Core 3.6.1.v_A68_R36x (org.eclipse.jdt.core 3.6.1.v_A68_R36x)
>>
>>   Cannot satisfy dependency:
>>
>>     From: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)
>>
>>     To: org.eclipse.jdt.core [3.6.1.v_A68_R36x]
>>
>>   Cannot satisfy dependency:
>>
>>     From: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)
>>
>>     To: org.eclipse.jdt.feature.group [3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH]
>>
>>   Cannot satisfy dependency:
>>
>>     From: Groovy-Eclipse Feature 2.1.2.xx-20110310-1500-e36 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.2.xx-20110310-1500-e36)
>>
>>     To: org.codehaus.groovy.jdt.patch.feature.group [2.1.2.xx-20110310-1500-e36]
>>
>>   Cannot satisfy dependency:
>>
>>     From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.1.2.xx-20110310-1500-e36 Eclipse Java Development Tools 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH (org.eclipse.jdt.feature.group 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH)
>>
>>     To: org.eclipse.jdt.core [3.6.2.xx-20110310-1500-e36]
>>
>>
>>
>> While attempting to install with Eclipse classic update from downloaded Groovy-Eclipse plugin groovy.archive-2.1.2.xx-20110310-1500-e36.zip the following message
>>
>> JDT Core patch for Groovy-Eclipse plugin  (2.1.2.xx-20110310-1500-e36) requires feature "org.eclipse.jdt (3.6.0.v20100124-2000-7z8WFRAFMTdeCo0y7FJt1Zi45027)".
>>
>> is issued by Eclipse update function.
>>
>>
>>
>> The base Eclipse version is Eclipse SDK Version: 3.6.1 Build id: M20100909-0800. I'm not able to install both 32 and 64-bit Windows versions. I've also tried to install the snapshot of Groovy-Eclipse plugin with the same results. My understanding of the installation problem is that Groovy-Eclipse plugin depends on specific version of Eclipse JDT (specifically 3.6.0.v20100124-2000-7z8WFRAFMTdeCo0y7FJt1Zi45027 - seems to be intermediate milestone of Helios release) but this version is not available for download from Eclipse site and it is quite old.
>>
>>
>>
>> I would be very thankful if I'll be provided with help on installation of the Groovy-Eclipse plugin into Eclipse 3.6.x environment.
>>
>>
>>
>> Regards
>>
>> Nick Sorokin
>>
>>
>>
>> This message was scanned at Tuesday, March 22, 2011 10:51:49 AM GMT by Trend Micro IMHS on behalf of
>> White Clarke Group - www.whiteclarkegroup.com.
>>
>> White Clarke Group Ltd - Registered in England - Registered number 03435619.
>> Registered address: Fairfax House, 15 Fulwood Place, London, WC1V 6AY
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>
> This message was scanned at Tuesday, March 22, 2011 4:30:46 PM GMT by Trend Micro IMHS on behalf of White Clarke Group
>
> This message was scanned at Tuesday, March 22, 2011 5:04:15 PM GMT by Trend Micro IMHS on behalf of
> White Clarke Group - www.whiteclarkegroup.com.
>
> White Clarke Group Ltd - Registered in England - Registered number 03435619.
> Registered address: Fairfax House, 15 Fulwood Place, London, WC1V 6AY
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

RE: Groovy-Eclipse Plugin Installation Problems

Nikolay Sorokin
Hi Andrew,

There were the reasons to go with additional configuration folders and one of them was decision of p2 team to exclude old (classic) method of Eclipse configuring - using standard p2 approach I'm not able to clone Eclipse installation easily. Your explanation gives me the idea that read-only is a logical p2 view of the folders rather than actual file/folders attributes.

At this moment I can live with way of Groovy-Eclipse plugin install because I do not need this configuration to be cloned but I need to investigate what may be the underwater stones with other extensions I require.

Thanks for help.

Regards,
Nick

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
Sent: 22 March 2011 18:19
To: [hidden email]
Subject: Re: [groovy-eclipse-plugin-dev] Groovy-Eclipse Plugin Installation Problems

Hi Nick,

Your environment is something that I have not come across before.
Using an external configuration folder is indeed very similar to using
a read-only eclipse installation directory (the effect is the
same---both cause configuration information to be written and plugins
to be stored in a separate location).

Although the effect is that it is difficult to install Groovy-Eclipse
in this scenario, it is really out of our control to do things
differently.  Since we require a patch for the JDT, the Groovy-Eclipse
plugins (and configuration) must be installed in the same directory as
JDT.  If not, then you get the very cryptic error message that you
received when installing.

I raised a bug for the read-only problem, but this should also help
your situation as well:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=332158
unfortunately, the p2 team has not been able to do much to help with this yet.

On Tue, Mar 22, 2011 at 10:04 AM, Nikolay Sorokin
<[hidden email]> wrote:

> Thanks Andrew,
>
> Just before the reply came to me I've managed to install Groovy-Eclipse plugin.
>
> The main difference between these two attempts is the way it was performed. In both cases pure Eclipse SDK was used, in both cases I've used p2 process for installation. The only difference was: in unsuccessful attempt I've use -configuration parameter with configuration folder outside of default location, in second attempt the default location was used. This may be attributed as Eclipse p2 bug, but I use non-default location for configuration files throughout organisation and I didn't experience this problem before. So, at this moment my suspicion  would be with Groove-Eclipse, but I may be very wrong.
>
> I'm currently OK with the way it is installed because Groovy plugin is sort of extension of the standard JDT which is a core of most Eclipse installation, but I would appreciate a better than JDT patch solution for installation of the plugin.
>
> Regards,
> Nick
>
> -----Original Message-----
> From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
> Sent: 22 March 2011 16:30
> To: [hidden email]
> Subject: Re: [groovy-eclipse-plugin-dev] Groovy-Eclipse Plugin Installation Problems
>
> I think that you are hitting this problem:
> http://grails.org/STS+FAQ
> See section called:  "Help, I can't install Groovy-Eclipse!"
>
> And here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=332158
>
>
> On Tue, Mar 22, 2011 at 3:51 AM, Nikolay Sorokin
> <[hidden email]> wrote:
>>
>> Hi
>>
>>
>>
>> I've a need to do some development in Groovy and decided to install Groovy-Eclipse plugin into my Eclipse environment. However installation from URL http://dist.springsource.org/release/GRECLIPSE/e3.6/ did not completed because of conflicting dependency (p2 installation message):
>>
>> Cannot complete the install because of a conflicting dependency.
>>
>>   Software being installed: Groovy-Eclipse Feature 2.1.2.xx-20110310-1500-e36 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.2.xx-20110310-1500-e36)
>>
>>   Software currently installed: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)
>>
>>   Only one of the following can be installed at once:
>>
>>     Java Development Tools Core 3.6.2.xx-20110321-1600-e36 (org.eclipse.jdt.core 3.6.2.xx-20110321-1600-e36)
>>
>>     Java Development Tools Core 3.6.2.xx-20110310-1500-e36 (org.eclipse.jdt.core 3.6.2.xx-20110310-1500-e36)
>>
>>     Java Development Tools Core 3.6.1.v_A68_R36x (org.eclipse.jdt.core 3.6.1.v_A68_R36x)
>>
>>   Cannot satisfy dependency:
>>
>>     From: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)
>>
>>     To: org.eclipse.jdt.core [3.6.1.v_A68_R36x]
>>
>>   Cannot satisfy dependency:
>>
>>     From: Shared profile 1.0.0.1284043999431 (SharedProfile_SDKProfile 1.0.0.1284043999431)
>>
>>     To: org.eclipse.jdt.feature.group [3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH]
>>
>>   Cannot satisfy dependency:
>>
>>     From: Groovy-Eclipse Feature 2.1.2.xx-20110310-1500-e36 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.2.xx-20110310-1500-e36)
>>
>>     To: org.codehaus.groovy.jdt.patch.feature.group [2.1.2.xx-20110310-1500-e36]
>>
>>   Cannot satisfy dependency:
>>
>>     From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.1.2.xx-20110310-1500-e36 Eclipse Java Development Tools 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH (org.eclipse.jdt.feature.group 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH)
>>
>>     To: org.eclipse.jdt.core [3.6.2.xx-20110310-1500-e36]
>>
>>
>>
>> While attempting to install with Eclipse classic update from downloaded Groovy-Eclipse plugin groovy.archive-2.1.2.xx-20110310-1500-e36.zip the following message
>>
>> JDT Core patch for Groovy-Eclipse plugin  (2.1.2.xx-20110310-1500-e36) requires feature "org.eclipse.jdt (3.6.0.v20100124-2000-7z8WFRAFMTdeCo0y7FJt1Zi45027)".
>>
>> is issued by Eclipse update function.
>>
>>
>>
>> The base Eclipse version is Eclipse SDK Version: 3.6.1 Build id: M20100909-0800. I'm not able to install both 32 and 64-bit Windows versions. I've also tried to install the snapshot of Groovy-Eclipse plugin with the same results. My understanding of the installation problem is that Groovy-Eclipse plugin depends on specific version of Eclipse JDT (specifically 3.6.0.v20100124-2000-7z8WFRAFMTdeCo0y7FJt1Zi45027 - seems to be intermediate milestone of Helios release) but this version is not available for download from Eclipse site and it is quite old.
>>
>>
>>
>> I would be very thankful if I'll be provided with help on installation of the Groovy-Eclipse plugin into Eclipse 3.6.x environment.
>>
>>
>>
>> Regards
>>
>> Nick Sorokin
>>
>>
>>
>> This message was scanned at Tuesday, March 22, 2011 10:51:49 AM GMT by Trend Micro IMHS on behalf of
>> White Clarke Group - www.whiteclarkegroup.com.
>>
>> White Clarke Group Ltd - Registered in England - Registered number 03435619.
>> Registered address: Fairfax House, 15 Fulwood Place, London, WC1V 6AY
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>
> This message was scanned at Tuesday, March 22, 2011 4:30:46 PM GMT by Trend Micro IMHS on behalf of White Clarke Group
>
> This message was scanned at Tuesday, March 22, 2011 5:04:15 PM GMT by Trend Micro IMHS on behalf of
> White Clarke Group - www.whiteclarkegroup.com.
>
> White Clarke Group Ltd - Registered in England - Registered number 03435619.
> Registered address: Fairfax House, 15 Fulwood Place, London, WC1V 6AY
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



This message was scanned at Tuesday, March 22, 2011 6:18:49 PM GMT by Trend Micro IMHS on behalf of White Clarke Group

This message was scanned at Tuesday, March 22, 2011 8:54:27 PM GMT by Trend Micro IMHS on behalf of
White Clarke Group - www.whiteclarkegroup.com.

White Clarke Group Ltd - Registered in England - Registered number 03435619.
Registered address: Fairfax House, 15 Fulwood Place, London, WC1V 6AY

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email