Groovy eclipse plugin.

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Groovy eclipse plugin.

Krzysztof Gabaja
Hello,

I'm using groovy complier v. 1.7.0.20100219-1700-e35 with groovy.eclipse
plugin v. 2.0.1.20100219-1700-e35 and I'm having few problems with them.
1) Sometimes context assist doesn't work properly (from time to time it
fails to find all of methods where polimorphism is used)
2) More often than not when I'm trying to add another import to my
project using content assist it is put above the line of package.
Has any of those issues been fixed in later versions of the plugin? What
is the newest version of eclipse groovy plugin that I can use with my
compiler? Is there a way to get the source code of groovy eclipse
plugin? If so, how do I obtain them?

Kind regards,
Krzysztof Gabaja

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Groovy eclipse plugin.

Kris De Volder
> Has any of those issues been fixed in later versions of the plugin?

I can not say for sure, but, number 2 sounds very familiar, lik a problem that was fixed a very long time ago.
Number 1 I am not so sure about. It could be some of the recent work on improving support for overloaded style methods and inference might help.
But only by trying a newer version can you really know for sure if it fixes the specific cases you are running into.

Kris




On Tue, Jul 22, 2014 at 5:36 AM, Krzysztof Gabaja <[hidden email]> wrote:
Hello,

I'm using groovy complier v. 1.7.0.20100219-1700-e35 with groovy.eclipse plugin v. 2.0.1.20100219-1700-e35 and I'm having few problems with them.
1) Sometimes context assist doesn't work properly (from time to time it fails to find all of methods where polimorphism is used)
2) More often than not when I'm trying to add another import to my project using content assist it is put above the line of package.
Has any of those issues been fixed in later versions of the plugin? What is the newest version of eclipse groovy plugin that I can use with my compiler? Is there a way to get the source code of groovy eclipse plugin? If so, how do I obtain them?

Kind regards,
Krzysztof Gabaja

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Groovy eclipse plugin.

Kris De Volder
Just to be clear, we no longer support the 1.7 compiler so if that's a requirement for you, you should probably stick to the old version of greclipse you are using.

Kris


On Tue, Jul 22, 2014 at 8:19 AM, Kris De Volder <[hidden email]> wrote:
> Has any of those issues been fixed in later versions of the plugin?

I can not say for sure, but, number 2 sounds very familiar, lik a problem that was fixed a very long time ago.
Number 1 I am not so sure about. It could be some of the recent work on improving support for overloaded style methods and inference might help.
But only by trying a newer version can you really know for sure if it fixes the specific cases you are running into.

Kris




On Tue, Jul 22, 2014 at 5:36 AM, Krzysztof Gabaja <[hidden email]> wrote:
Hello,

I'm using groovy complier v. 1.7.0.20100219-1700-e35 with groovy.eclipse plugin v. 2.0.1.20100219-1700-e35 and I'm having few problems with them.
1) Sometimes context assist doesn't work properly (from time to time it fails to find all of methods where polimorphism is used)
2) More often than not when I'm trying to add another import to my project using content assist it is put above the line of package.
Has any of those issues been fixed in later versions of the plugin? What is the newest version of eclipse groovy plugin that I can use with my compiler? Is there a way to get the source code of groovy eclipse plugin? If so, how do I obtain them?

Kind regards,
Krzysztof Gabaja

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email




Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Groovy eclipse plugin.

Krzysztof Gabaja
In reply to this post by Krzysztof Gabaja
Thank you very much for your replies. What's the newest version of the
plugin that I can use with my compiler?
Is there a way to obtain source codes?

Kind regards,
Krzysztof Gabaja

> Hello,
>
> I'm using groovy complier v. 1.7.0.20100219-1700-e35 with
> groovy.eclipse plugin v. 2.0.1.20100219-1700-e35 and I'm having few
> problems with them.
> 1) Sometimes context assist doesn't work properly (from time to time
> it fails to find all of methods where polimorphism is used)
> 2) More often than not when I'm trying to add another import to my
> project using content assist it is put above the line of package.
> Has any of those issues been fixed in later versions of the plugin?
> What is the newest version of eclipse groovy plugin that I can use
> with my compiler? Is there a way to get the source code of groovy
> eclipse plugin? If so, how do I obtain them?
>
> Kind regards,
> Krzysztof Gabaja


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Groovy eclipse plugin.

Andy Clement
I think the greclipse 2.8.0 release included 1.7.10 support, so you could try that. It may still have the bug in though, it is over a year old.

See the readme at the github project for instructions on setting up the sources:


cheers,
Andy


On 23 July 2014 04:54, Krzysztof Gabaja <[hidden email]> wrote:
Thank you very much for your replies. What's the newest version of the plugin that I can use with my compiler?
Is there a way to obtain source codes?

Kind regards,
Krzysztof Gabaja

Hello,

I'm using groovy complier v. 1.7.0.20100219-1700-e35 with groovy.eclipse plugin v. 2.0.1.20100219-1700-e35 and I'm having few problems with them.
1) Sometimes context assist doesn't work properly (from time to time it fails to find all of methods where polimorphism is used)
2) More often than not when I'm trying to add another import to my project using content assist it is put above the line of package.
Has any of those issues been fixed in later versions of the plugin? What is the newest version of eclipse groovy plugin that I can use with my compiler? Is there a way to get the source code of groovy eclipse plugin? If so, how do I obtain them?

Kind regards,
Krzysztof Gabaja


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Loading...