IllegalArgumentException with GRECLIPSE 2.5.2 and Eclipse 3.7.1

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

IllegalArgumentException with GRECLIPSE 2.5.2 and Eclipse 3.7.1

Craig Setera
Ever since I upgraded to Eclipse 3.7 (and just recently tried again on 3.7.1), I've been unable to install and use the Groovy Eclipse support.  I'm really missing the great support that this plugin has given me in the past and I'm hoping to get it resolved.  I'd love any help anyone can offer.

After installing from the update site, I'm unable to start Eclipse and I get the following error in the Eclipse log.  To get Eclipse started, have to forcibly remove the plugins and feature from the file system.

!ENTRY org.eclipse.osgi 4 0 2011-10-20 12:57:50.038
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Exception in org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start() of bundle org.eclipse.osgi.
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
at org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:225)
at org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:655)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:273)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
Caused by: java.lang.IllegalArgumentException: Specified version of Groovy not found. Available versions are: 
at org.codehaus.groovy.frameworkadapter.CompilerHook.checkVersionFound(CompilerHook.java:121)
at org.codehaus.groovy.frameworkadapter.CompilerHook.frameworkStart(CompilerHook.java:105)
at org.eclipse.osgi.baseadaptor.BaseAdaptor.frameworkStart(BaseAdaptor.java:253)
at org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start(SystemBundleActivator.java:60)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
... 12 more
Root exception:
java.lang.IllegalArgumentException: Specified version of Groovy not found. Available versions are: 
at org.codehaus.groovy.frameworkadapter.CompilerHook.checkVersionFound(CompilerHook.java:121)
at org.codehaus.groovy.frameworkadapter.CompilerHook.frameworkStart(CompilerHook.java:105)
at org.eclipse.osgi.baseadaptor.BaseAdaptor.frameworkStart(BaseAdaptor.java:253)
at org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start(SystemBundleActivator.java:60)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
at org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:225)
at org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:655)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:273)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)


Thanks,
Craig

--
Craig Setera
Director, Product Engineering
mFoundry
p 415.324.5801


Reply | Threaded
Open this post in threaded view
|

Re: IllegalArgumentException with GRECLIPSE 2.5.2 and Eclipse 3.7.1

Andrew Eisenberg
Hi Craig,

I just committed a fix that may address your problem.  The dev build
should be available in a couple of hours.

For some reason, when you restart, the groovy bundles are not being
found immediately.  It's probably that since they have just been
installed the osgi framework isn't aware of them until a refresh is
done.  However, before that is done, we do a compiler check to see if
you are starting with a valid compiler version.  Since there are no
groovy compilers available yet, there is a failure.

The change is to let Eclipse continue to load if no compilers are
found (instead of performing a compiler check and failing).  The
assumption is that the compilers would be initialized later in the
process.

Please upgrade to a dev build when it is available in about 2 hours
and let me know if this works for you.

Update site:
http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.7/

Alternatively, go to:
eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info
make a backup of the file
then edit it to remove the line for:
org.codehaus.groovy.frameworkadapter
(this will remove support for switching compilers.  It's not something
I'd recommend for the long term, but should get you working.)

On Thu, Oct 20, 2011 at 11:14 AM, Craig Setera <[hidden email]> wrote:

> Ever since I upgraded to Eclipse 3.7 (and just recently tried again on
> 3.7.1), I've been unable to install and use the Groovy Eclipse support.  I'm
> really missing the great support that this plugin has given me in the past
> and I'm hoping to get it resolved.  I'd love any help anyone can offer.
> After installing from the update site, I'm unable to start Eclipse and I get
> the following error in the Eclipse log.  To get Eclipse started, have to
> forcibly remove the plugins and feature from the file system.
> !ENTRY org.eclipse.osgi 4 0 2011-10-20 12:57:50.038
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Exception in
> org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start() of
> bundle org.eclipse.osgi.
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
> at
> org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:225)
> at
> org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:655)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:273)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
> Caused by: java.lang.IllegalArgumentException: Specified version of Groovy
> not found. Available versions are:
> at
> org.codehaus.groovy.frameworkadapter.CompilerHook.checkVersionFound(CompilerHook.java:121)
> at
> org.codehaus.groovy.frameworkadapter.CompilerHook.frameworkStart(CompilerHook.java:105)
> at
> org.eclipse.osgi.baseadaptor.BaseAdaptor.frameworkStart(BaseAdaptor.java:253)
> at
> org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start(SystemBundleActivator.java:60)
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
> at java.security.AccessController.doPrivileged(Native Method)
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
> ... 12 more
> Root exception:
> java.lang.IllegalArgumentException: Specified version of Groovy not found.
> Available versions are:
> at
> org.codehaus.groovy.frameworkadapter.CompilerHook.checkVersionFound(CompilerHook.java:121)
> at
> org.codehaus.groovy.frameworkadapter.CompilerHook.frameworkStart(CompilerHook.java:105)
> at
> org.eclipse.osgi.baseadaptor.BaseAdaptor.frameworkStart(BaseAdaptor.java:253)
> at
> org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start(SystemBundleActivator.java:60)
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
> at java.security.AccessController.doPrivileged(Native Method)
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
> at
> org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:225)
> at
> org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:655)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:273)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
>
> Thanks,
> Craig
> --
> Craig Setera
> Director, Product Engineering
> mFoundry
> p 415.324.5801
> [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: IllegalArgumentException with GRECLIPSE 2.5.2 and Eclipse 3.7.1

Andrew Eisenberg
The new build is now available.

On Thu, Oct 20, 2011 at 12:50 PM, Andrew Eisenberg <[hidden email]> wrote:

> Hi Craig,
>
> I just committed a fix that may address your problem.  The dev build
> should be available in a couple of hours.
>
> For some reason, when you restart, the groovy bundles are not being
> found immediately.  It's probably that since they have just been
> installed the osgi framework isn't aware of them until a refresh is
> done.  However, before that is done, we do a compiler check to see if
> you are starting with a valid compiler version.  Since there are no
> groovy compilers available yet, there is a failure.
>
> The change is to let Eclipse continue to load if no compilers are
> found (instead of performing a compiler check and failing).  The
> assumption is that the compilers would be initialized later in the
> process.
>
> Please upgrade to a dev build when it is available in about 2 hours
> and let me know if this works for you.
>
> Update site:
> http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.7/
>
> Alternatively, go to:
> eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info
> make a backup of the file
> then edit it to remove the line for:
> org.codehaus.groovy.frameworkadapter
> (this will remove support for switching compilers.  It's not something
> I'd recommend for the long term, but should get you working.)
>
> On Thu, Oct 20, 2011 at 11:14 AM, Craig Setera <[hidden email]> wrote:
>> Ever since I upgraded to Eclipse 3.7 (and just recently tried again on
>> 3.7.1), I've been unable to install and use the Groovy Eclipse support.  I'm
>> really missing the great support that this plugin has given me in the past
>> and I'm hoping to get it resolved.  I'd love any help anyone can offer.
>> After installing from the update site, I'm unable to start Eclipse and I get
>> the following error in the Eclipse log.  To get Eclipse started, have to
>> forcibly remove the plugins and feature from the file system.
>> !ENTRY org.eclipse.osgi 4 0 2011-10-20 12:57:50.038
>> !MESSAGE FrameworkEvent ERROR
>> !STACK 0
>> org.osgi.framework.BundleException: Exception in
>> org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start() of
>> bundle org.eclipse.osgi.
>> at
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
>> at
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
>> at
>> org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:225)
>> at
>> org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:655)
>> at
>> org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:273)
>> at
>> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
>> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>> at
>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>> at
>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>> at java.lang.reflect.Method.invoke(Method.java:597)
>> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
>> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
>> at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
>> Caused by: java.lang.IllegalArgumentException: Specified version of Groovy
>> not found. Available versions are:
>> at
>> org.codehaus.groovy.frameworkadapter.CompilerHook.checkVersionFound(CompilerHook.java:121)
>> at
>> org.codehaus.groovy.frameworkadapter.CompilerHook.frameworkStart(CompilerHook.java:105)
>> at
>> org.eclipse.osgi.baseadaptor.BaseAdaptor.frameworkStart(BaseAdaptor.java:253)
>> at
>> org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start(SystemBundleActivator.java:60)
>> at
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
>> at java.security.AccessController.doPrivileged(Native Method)
>> at
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
>> ... 12 more
>> Root exception:
>> java.lang.IllegalArgumentException: Specified version of Groovy not found.
>> Available versions are:
>> at
>> org.codehaus.groovy.frameworkadapter.CompilerHook.checkVersionFound(CompilerHook.java:121)
>> at
>> org.codehaus.groovy.frameworkadapter.CompilerHook.frameworkStart(CompilerHook.java:105)
>> at
>> org.eclipse.osgi.baseadaptor.BaseAdaptor.frameworkStart(BaseAdaptor.java:253)
>> at
>> org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start(SystemBundleActivator.java:60)
>> at
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
>> at java.security.AccessController.doPrivileged(Native Method)
>> at
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
>> at
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
>> at
>> org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:225)
>> at
>> org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:655)
>> at
>> org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:273)
>> at
>> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
>> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>> at
>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>> at
>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>> at java.lang.reflect.Method.invoke(Method.java:597)
>> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
>> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
>> at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
>>
>> Thanks,
>> Craig
>> --
>> Craig Setera
>> Director, Product Engineering
>> mFoundry
>> p 415.324.5801
>> [hidden email]
>>
>>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: IllegalArgumentException with GRECLIPSE 2.5.2 and Eclipse 3.7.1

Craig Setera
You beat me to the punch.  I was just going to say that I downloaded it and it seems to be working for me.  Thanks!

On Thursday, October 20, 2011, Andrew Eisenberg wrote:
The new build is now available.

On Thu, Oct 20, 2011 at 12:50 PM, Andrew Eisenberg <[hidden email]> wrote:
> Hi Craig,
>
> I just committed a fix that may address your problem.  The dev build
> should be available in a couple of hours.
>
> For some reason, when you restart, the groovy bundles are not being
> found immediately.  It's probably that since they have just been
> installed the osgi framework isn't aware of them until a refresh is
> done.  However, before that is done, we do a compiler check to see if
> you are starting with a valid compiler version.  Since there are no
> groovy compilers available yet, there is a failure.
>
> The change is to let Eclipse continue to load if no compilers are
> found (instead of performing a compiler check and failing).  The
> assumption is that the compilers would be initialized later in the
> process.
>
> Please upgrade to a dev build when it is available in about 2 hours
> and let me know if this works for you.
>
> Update site:
> http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.7/
>
> Alternatively, go to:
> eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info
> make a backup of the file
> then edit it to remove the line for:
> org.codehaus.groovy.frameworkadapter
> (this will remove support for switching compilers.  It's not something
> I'd recommend for the long term, but should get you working.)
>
> On Thu, Oct 20, 2011 at 11:14 AM, Craig Setera <[hidden email]> wrote:
>> Ever since I upgraded to Eclipse 3.7 (and just recently tried again on
>> 3.7.1), I've been unable to install and use the Groovy Eclipse support.  I'm
>> really missing the great support that this plugin has given me in the past
>> and I'm hoping to get it resolved.  I'd love any help anyone can offer.
>> After installing from the update site, I'm unable to start Eclipse and I get
>> the following error in the Eclipse log.  To get Eclipse started, have to
>> forcibly remove the plugins and feature from the file system.
>> !ENTRY org.eclipse.osgi 4 0 2011-10-20 12:57:50.038
>> !MESSAGE FrameworkEvent ERROR
>> !STACK 0
>> org.osgi.framework.BundleException: Exception in
>> org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start() of
>> bundle org.eclipse.osgi.
>> at
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
>> at
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
>> at
>> org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:225)
>> at
>> org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:655)
>> at
>> org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:273)
>> at
>> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
>> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>> at
>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>> at
>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>> at java.lang.reflect.Method.invoke(Method.java:597)
>> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
>> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
>> at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
>> Caused by: java.lang.IllegalArgumentException: Specified version of Groovy
>> not found. Available versions are:
>> at
>> org.codehaus.groovy.frameworkadapter.CompilerHook.checkVersionFound(CompilerHook.java:121)
>> at
>> org.codehaus.groovy.frameworkadapter.CompilerHook.frameworkStart(CompilerHook.java:105)


--
Craig Setera
Director, Product Engineering
mFoundry
p 415.324.5801


Reply | Threaded
Open this post in threaded view
|

Re: IllegalArgumentException with GRECLIPSE 2.5.2 and Eclipse 3.7.1

Andrew Eisenberg
Excellent.  Thanks for getting back to me.

On Thu, Oct 20, 2011 at 3:05 PM, Craig Setera <[hidden email]> wrote:

> You beat me to the punch.  I was just going to say that I downloaded it and
> it seems to be working for me.  Thanks!
>
> On Thursday, October 20, 2011, Andrew Eisenberg wrote:
>>
>> The new build is now available.
>>
>> On Thu, Oct 20, 2011 at 12:50 PM, Andrew Eisenberg <[hidden email]>
>> wrote:
>> > Hi Craig,
>> >
>> > I just committed a fix that may address your problem.  The dev build
>> > should be available in a couple of hours.
>> >
>> > For some reason, when you restart, the groovy bundles are not being
>> > found immediately.  It's probably that since they have just been
>> > installed the osgi framework isn't aware of them until a refresh is
>> > done.  However, before that is done, we do a compiler check to see if
>> > you are starting with a valid compiler version.  Since there are no
>> > groovy compilers available yet, there is a failure.
>> >
>> > The change is to let Eclipse continue to load if no compilers are
>> > found (instead of performing a compiler check and failing).  The
>> > assumption is that the compilers would be initialized later in the
>> > process.
>> >
>> > Please upgrade to a dev build when it is available in about 2 hours
>> > and let me know if this works for you.
>> >
>> > Update site:
>> > http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.7/
>> >
>> > Alternatively, go to:
>> >
>> > eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info
>> > make a backup of the file
>> > then edit it to remove the line for:
>> > org.codehaus.groovy.frameworkadapter
>> > (this will remove support for switching compilers.  It's not something
>> > I'd recommend for the long term, but should get you working.)
>> >
>> > On Thu, Oct 20, 2011 at 11:14 AM, Craig Setera <[hidden email]>
>> > wrote:
>> >> Ever since I upgraded to Eclipse 3.7 (and just recently tried again on
>> >> 3.7.1), I've been unable to install and use the Groovy Eclipse support.
>> >>  I'm
>> >> really missing the great support that this plugin has given me in the
>> >> past
>> >> and I'm hoping to get it resolved.  I'd love any help anyone can offer.
>> >> After installing from the update site, I'm unable to start Eclipse and
>> >> I get
>> >> the following error in the Eclipse log.  To get Eclipse started, have
>> >> to
>> >> forcibly remove the plugins and feature from the file system.
>> >> !ENTRY org.eclipse.osgi 4 0 2011-10-20 12:57:50.038
>> >> !MESSAGE FrameworkEvent ERROR
>> >> !STACK 0
>> >> org.osgi.framework.BundleException: Exception in
>> >> org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start()
>> >> of
>> >> bundle org.eclipse.osgi.
>> >> at
>> >>
>> >> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
>> >> at
>> >>
>> >> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
>> >> at
>> >>
>> >> org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:225)
>> >> at
>> >>
>> >> org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:655)
>> >> at
>> >>
>> >> org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:273)
>> >> at
>> >>
>> >> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
>> >> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>> >> at
>> >>
>> >> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>> >> at
>> >>
>> >> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>> >> at java.lang.reflect.Method.invoke(Method.java:597)
>> >> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
>> >> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
>> >> at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
>> >> Caused by: java.lang.IllegalArgumentException: Specified version of
>> >> Groovy
>> >> not found. Available versions are:
>> >> at
>> >>
>> >> org.codehaus.groovy.frameworkadapter.CompilerHook.checkVersionFound(CompilerHook.java:121)
>> >> at
>> >>
>> >> org.codehaus.groovy.frameworkadapter.CompilerHook.frameworkStart(CompilerHook.java:105)
>
>
> --
> Craig Setera
> Director, Product Engineering
> mFoundry
> p 415.324.5801
> [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email