Java 8 support?

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

Java 8 support?

Martijn Verburg
Hi all,

We're hoping to upgrade to Java 8 but have a mixed Groovy and Java codebase. When we set the compiler level to 1.8, the groovy-eclipse-compiler seems to fail to correctly pass that value through and/or deal with it, leading to a message similar to:

...
Compilation failure:
found 0 errors and 0 warnings.
...

Is this expected behaviour or is Java 8 support still to arrive in an upcoming release?

Cheers,
Martijn
Reply | Threaded
Open this post in threaded view
|

Re: Java 8 support?

Thomas Modeneis
Hi Martijn,

This is up to come, you can ping the thread and ask Andy how is it going...


On Mon, Mar 24, 2014 at 2:49 PM, Martijn Verburg <[hidden email]> wrote:
Hi all,

We're hoping to upgrade to Java 8 but have a mixed Groovy and Java codebase. When we set the compiler level to 1.8, the groovy-eclipse-compiler seems to fail to correctly pass that value through and/or deal with it, leading to a message similar to:

...
Compilation failure:
found 0 errors and 0 warnings.
...

Is this expected behaviour or is Java 8 support still to arrive in an upcoming release?

Cheers,
Martijn

Reply | Threaded
Open this post in threaded view
|

Re: Java 8 support?

Andy Clement
We are just doing the final testing around the groovy-java8 stuff.  We have to 'patch the patch' (patch the java8 patch to open it up for groovy).  It should be available in the next day or so in the IDE - the maven integration might take a little bit longer.

cheers,
Andy


On 24 March 2014 07:50, Thomas Modeneis <[hidden email]> wrote:
Hi Martijn,

This is up to come, you can ping the thread and ask Andy how is it going...


On Mon, Mar 24, 2014 at 2:49 PM, Martijn Verburg <[hidden email]> wrote:
Hi all,

We're hoping to upgrade to Java 8 but have a mixed Groovy and Java codebase. When we set the compiler level to 1.8, the groovy-eclipse-compiler seems to fail to correctly pass that value through and/or deal with it, leading to a message similar to:

...
Compilation failure:
found 0 errors and 0 warnings.
...

Is this expected behaviour or is Java 8 support still to arrive in an upcoming release?

Cheers,
Martijn


Reply | Threaded
Open this post in threaded view
|

Re: Java 8 support?

Martijn Verburg
Hi Andy,

Awesome! Let me know if you want us to test early (I've got a Maven build that can point at SNAPSHOT plugins from the Codehaus repo).

Cheers,
Martijn


On 24 March 2014 15:22, Andy Clement <[hidden email]> wrote:
We are just doing the final testing around the groovy-java8 stuff.  We have to 'patch the patch' (patch the java8 patch to open it up for groovy).  It should be available in the next day or so in the IDE - the maven integration might take a little bit longer.

cheers,
Andy


On 24 March 2014 07:50, Thomas Modeneis <[hidden email]> wrote:
Hi Martijn,

This is up to come, you can ping the thread and ask Andy how is it going...


On Mon, Mar 24, 2014 at 2:49 PM, Martijn Verburg <[hidden email]> wrote:
Hi all,

We're hoping to upgrade to Java 8 but have a mixed Groovy and Java codebase. When we set the compiler level to 1.8, the groovy-eclipse-compiler seems to fail to correctly pass that value through and/or deal with it, leading to a message similar to:

...
Compilation failure:
found 0 errors and 0 warnings.
...

Is this expected behaviour or is Java 8 support still to arrive in an upcoming release?

Cheers,
Martijn



Reply | Threaded
Open this post in threaded view
|

Re: Java 8 support?

Andy Clement
We might be having some issues because I'm hearing groovy isn't behaving too well on Java8. Still investigating. We'll provide an update soon.

cheers,
Andy


On 25 March 2014 02:01, Martijn Verburg <[hidden email]> wrote:
Hi Andy,

Awesome! Let me know if you want us to test early (I've got a Maven build that can point at SNAPSHOT plugins from the Codehaus repo).

Cheers,
Martijn


On 24 March 2014 15:22, Andy Clement <[hidden email]> wrote:
We are just doing the final testing around the groovy-java8 stuff.  We have to 'patch the patch' (patch the java8 patch to open it up for groovy).  It should be available in the next day or so in the IDE - the maven integration might take a little bit longer.

cheers,
Andy


On 24 March 2014 07:50, Thomas Modeneis <[hidden email]> wrote:
Hi Martijn,

This is up to come, you can ping the thread and ask Andy how is it going...


On Mon, Mar 24, 2014 at 2:49 PM, Martijn Verburg <[hidden email]> wrote:
Hi all,

We're hoping to upgrade to Java 8 but have a mixed Groovy and Java codebase. When we set the compiler level to 1.8, the groovy-eclipse-compiler seems to fail to correctly pass that value through and/or deal with it, leading to a message similar to:

...
Compilation failure:
found 0 errors and 0 warnings.
...

Is this expected behaviour or is Java 8 support still to arrive in an upcoming release?

Cheers,
Martijn




Reply | Threaded
Open this post in threaded view
|

Re: Java 8 support?

Martijn Verburg
Hi Andy,

From what I could tell Groovy isn't officially supporting Java 8 until they release 2.3 (next couple of weeks), HTH.

Cheers,
Martijn


On 27 March 2014 04:08, Andy Clement <[hidden email]> wrote:
We might be having some issues because I'm hearing groovy isn't behaving too well on Java8. Still investigating. We'll provide an update soon.

cheers,
Andy


On 25 March 2014 02:01, Martijn Verburg <[hidden email]> wrote:
Hi Andy,

Awesome! Let me know if you want us to test early (I've got a Maven build that can point at SNAPSHOT plugins from the Codehaus repo).

Cheers,
Martijn


On 24 March 2014 15:22, Andy Clement <[hidden email]> wrote:
We are just doing the final testing around the groovy-java8 stuff.  We have to 'patch the patch' (patch the java8 patch to open it up for groovy).  It should be available in the next day or so in the IDE - the maven integration might take a little bit longer.

cheers,
Andy


On 24 March 2014 07:50, Thomas Modeneis <[hidden email]> wrote:
Hi Martijn,

This is up to come, you can ping the thread and ask Andy how is it going...


On Mon, Mar 24, 2014 at 2:49 PM, Martijn Verburg <[hidden email]> wrote:
Hi all,

We're hoping to upgrade to Java 8 but have a mixed Groovy and Java codebase. When we set the compiler level to 1.8, the groovy-eclipse-compiler seems to fail to correctly pass that value through and/or deal with it, leading to a message similar to:

...
Compilation failure:
found 0 errors and 0 warnings.
...

Is this expected behaviour or is Java 8 support still to arrive in an upcoming release?

Cheers,
Martijn





Reply | Threaded
Open this post in threaded view
|

Re: Java 8 support?

steve.ash
Groovy 2.3 is out now.  Any ETA on a groovy-eclipse-batch release that incorporates it?  Can't wait to get on Java8!


On Thu, Mar 27, 2014 at 8:20 AM, Martijn Verburg <[hidden email]> wrote:
Hi Andy,

From what I could tell Groovy isn't officially supporting Java 8 until they release 2.3 (next couple of weeks), HTH.

Cheers,
Martijn


On 27 March 2014 04:08, Andy Clement <[hidden email]> wrote:
We might be having some issues because I'm hearing groovy isn't behaving too well on Java8. Still investigating. We'll provide an update soon.

cheers,
Andy


On 25 March 2014 02:01, Martijn Verburg <[hidden email]> wrote:
Hi Andy,

Awesome! Let me know if you want us to test early (I've got a Maven build that can point at SNAPSHOT plugins from the Codehaus repo).

Cheers,
Martijn


On 24 March 2014 15:22, Andy Clement <[hidden email]> wrote:
We are just doing the final testing around the groovy-java8 stuff.  We have to 'patch the patch' (patch the java8 patch to open it up for groovy).  It should be available in the next day or so in the IDE - the maven integration might take a little bit longer.

cheers,
Andy


On 24 March 2014 07:50, Thomas Modeneis <[hidden email]> wrote:
Hi Martijn,

This is up to come, you can ping the thread and ask Andy how is it going...


On Mon, Mar 24, 2014 at 2:49 PM, Martijn Verburg <[hidden email]> wrote:
Hi all,

We're hoping to upgrade to Java 8 but have a mixed Groovy and Java codebase. When we set the compiler level to 1.8, the groovy-eclipse-compiler seems to fail to correctly pass that value through and/or deal with it, leading to a message similar to:

...
Compilation failure:
found 0 errors and 0 warnings.
...

Is this expected behaviour or is Java 8 support still to arrive in an upcoming release?

Cheers,
Martijn






Reply | Threaded
Open this post in threaded view
|

Re: Java 8 support?

Andy Clement
We are thinking about a groovy-eclipse 2.9.0 release shortly (in May), this work would be included as part of that. Up until yesterday greclipse was using groovy 2.3.0.rc1 but now we are updated to 2.3.0 final. I'd probably recommend you raise a jira to ensure we track getting the batch work done.

I don't think Kris has fully automated the release of the batch thing yet, which slows down getting it out there, unfortunately.

cheers,
Andy


On 10 May 2014 08:02, Steve Ash <[hidden email]> wrote:
Groovy 2.3 is out now.  Any ETA on a groovy-eclipse-batch release that incorporates it?  Can't wait to get on Java8!


On Thu, Mar 27, 2014 at 8:20 AM, Martijn Verburg <[hidden email]> wrote:
Hi Andy,

From what I could tell Groovy isn't officially supporting Java 8 until they release 2.3 (next couple of weeks), HTH.

Cheers,
Martijn


On 27 March 2014 04:08, Andy Clement <[hidden email]> wrote:
We might be having some issues because I'm hearing groovy isn't behaving too well on Java8. Still investigating. We'll provide an update soon.

cheers,
Andy


On 25 March 2014 02:01, Martijn Verburg <[hidden email]> wrote:
Hi Andy,

Awesome! Let me know if you want us to test early (I've got a Maven build that can point at SNAPSHOT plugins from the Codehaus repo).

Cheers,
Martijn


On 24 March 2014 15:22, Andy Clement <[hidden email]> wrote:
We are just doing the final testing around the groovy-java8 stuff.  We have to 'patch the patch' (patch the java8 patch to open it up for groovy).  It should be available in the next day or so in the IDE - the maven integration might take a little bit longer.

cheers,
Andy


On 24 March 2014 07:50, Thomas Modeneis <[hidden email]> wrote:
Hi Martijn,

This is up to come, you can ping the thread and ask Andy how is it going...


On Mon, Mar 24, 2014 at 2:49 PM, Martijn Verburg <[hidden email]> wrote:
Hi all,

We're hoping to upgrade to Java 8 but have a mixed Groovy and Java codebase. When we set the compiler level to 1.8, the groovy-eclipse-compiler seems to fail to correctly pass that value through and/or deal with it, leading to a message similar to:

...
Compilation failure:
found 0 errors and 0 warnings.
...

Is this expected behaviour or is Java 8 support still to arrive in an upcoming release?

Cheers,
Martijn







Reply | Threaded
Open this post in threaded view
|

Re: Java 8 support?

steve.ash


On Tue, May 13, 2014 at 2:05 PM, Andy Clement <[hidden email]> wrote:
We are thinking about a groovy-eclipse 2.9.0 release shortly (in May), this work would be included as part of that. Up until yesterday greclipse was using groovy 2.3.0.rc1 but now we are updated to 2.3.0 final. I'd probably recommend you raise a jira to ensure we track getting the batch work done.

I don't think Kris has fully automated the release of the batch thing yet, which slows down getting it out there, unfortunately.

cheers,
Andy


On 10 May 2014 08:02, Steve Ash <[hidden email]> wrote:
Groovy 2.3 is out now.  Any ETA on a groovy-eclipse-batch release that incorporates it?  Can't wait to get on Java8!


On Thu, Mar 27, 2014 at 8:20 AM, Martijn Verburg <[hidden email]> wrote:
Hi Andy,

From what I could tell Groovy isn't officially supporting Java 8 until they release 2.3 (next couple of weeks), HTH.

Cheers,
Martijn


On 27 March 2014 04:08, Andy Clement <[hidden email]> wrote:
We might be having some issues because I'm hearing groovy isn't behaving too well on Java8. Still investigating. We'll provide an update soon.

cheers,
Andy


On 25 March 2014 02:01, Martijn Verburg <[hidden email]> wrote:
Hi Andy,

Awesome! Let me know if you want us to test early (I've got a Maven build that can point at SNAPSHOT plugins from the Codehaus repo).

Cheers,
Martijn


On 24 March 2014 15:22, Andy Clement <[hidden email]> wrote:
We are just doing the final testing around the groovy-java8 stuff.  We have to 'patch the patch' (patch the java8 patch to open it up for groovy).  It should be available in the next day or so in the IDE - the maven integration might take a little bit longer.

cheers,
Andy


On 24 March 2014 07:50, Thomas Modeneis <[hidden email]> wrote:
Hi Martijn,

This is up to come, you can ping the thread and ask Andy how is it going...


On Mon, Mar 24, 2014 at 2:49 PM, Martijn Verburg <[hidden email]> wrote:
Hi all,

We're hoping to upgrade to Java 8 but have a mixed Groovy and Java codebase. When we set the compiler level to 1.8, the groovy-eclipse-compiler seems to fail to correctly pass that value through and/or deal with it, leading to a message similar to:

...
Compilation failure:
found 0 errors and 0 warnings.
...

Is this expected behaviour or is Java 8 support still to arrive in an upcoming release?

Cheers,
Martijn








Reply | Threaded
Open this post in threaded view
|

RE: Java 8 support?

Skeptic .
In reply to this post by Andy Clement
Will the 2.9.0 release be available for eclipse 3.7 or only 4.x ?


Date: Tue, 13 May 2014 12:05:27 -0700
From: [hidden email]
To: [hidden email]
Subject: Re: [groovy-eclipse-plugin-user] Java 8 support?

We are thinking about a groovy-eclipse 2.9.0 release shortly (in May), this work would be included as part of that. Up until yesterday greclipse was using groovy 2.3.0.rc1 but now we are updated to 2.3.0 final. I'd probably recommend you raise a jira to ensure we track getting the batch work done.

I don't think Kris has fully automated the release of the batch thing yet, which slows down getting it out there, unfortunately.

cheers,
Andy


On 10 May 2014 08:02, Steve Ash <[hidden email]> wrote:
Groovy 2.3 is out now.  Any ETA on a groovy-eclipse-batch release that incorporates it?  Can't wait to get on Java8!


On Thu, Mar 27, 2014 at 8:20 AM, Martijn Verburg <[hidden email]> wrote:
Hi Andy,

From what I could tell Groovy isn't officially supporting Java 8 until they release 2.3 (next couple of weeks), HTH.

Cheers,
Martijn


On 27 March 2014 04:08, Andy Clement <[hidden email]> wrote:
We might be having some issues because I'm hearing groovy isn't behaving too well on Java8. Still investigating. We'll provide an update soon.

cheers,
Andy


On 25 March 2014 02:01, Martijn Verburg <[hidden email]> wrote:
Hi Andy,

Awesome! Let me know if you want us to test early (I've got a Maven build that can point at SNAPSHOT plugins from the Codehaus repo).

Cheers,
Martijn


On 24 March 2014 15:22, Andy Clement <[hidden email]> wrote:
We are just doing the final testing around the groovy-java8 stuff.  We have to 'patch the patch' (patch the java8 patch to open it up for groovy).  It should be available in the next day or so in the IDE - the maven integration might take a little bit longer.

cheers,
Andy


On 24 March 2014 07:50, Thomas Modeneis <[hidden email]> wrote:
Hi Martijn,

This is up to come, you can ping the thread and ask Andy how is it going...


On Mon, Mar 24, 2014 at 2:49 PM, Martijn Verburg <[hidden email]> wrote:
Hi all,

We're hoping to upgrade to Java 8 but have a mixed Groovy and Java codebase. When we set the compiler level to 1.8, the groovy-eclipse-compiler seems to fail to correctly pass that value through and/or deal with it, leading to a message similar to:

...
Compilation failure:
found 0 errors and 0 warnings.
...

Is this expected behaviour or is Java 8 support still to arrive in an upcoming release?

Cheers,
Martijn







Reply | Threaded
Open this post in threaded view
|

Re: Java 8 support?

Andy Clement
If the builds are working, or can be made to work easily, for 3.7, we would probably include that. Right now the important one is 4.3 based greclipse and looking ahead a good 4.4 based release.  The 3.7 builds don't look so healthy at the moment: https://build.spring.io/browse/GRECLIPSE-E37P

Andy


On 13 May 2014 12:54, Skeptic . <[hidden email]> wrote:
Will the 2.9.0 release be available for eclipse 3.7 or only 4.x ?


Date: Tue, 13 May 2014 12:05:27 -0700
From: [hidden email]
To: [hidden email]
Subject: Re: [groovy-eclipse-plugin-user] Java 8 support?


We are thinking about a groovy-eclipse 2.9.0 release shortly (in May), this work would be included as part of that. Up until yesterday greclipse was using groovy 2.3.0.rc1 but now we are updated to 2.3.0 final. I'd probably recommend you raise a jira to ensure we track getting the batch work done.

I don't think Kris has fully automated the release of the batch thing yet, which slows down getting it out there, unfortunately.

cheers,
Andy


On 10 May 2014 08:02, Steve Ash <[hidden email]> wrote:
Groovy 2.3 is out now.  Any ETA on a groovy-eclipse-batch release that incorporates it?  Can't wait to get on Java8!


On Thu, Mar 27, 2014 at 8:20 AM, Martijn Verburg <[hidden email]> wrote:
Hi Andy,

From what I could tell Groovy isn't officially supporting Java 8 until they release 2.3 (next couple of weeks), HTH.

Cheers,
Martijn


On 27 March 2014 04:08, Andy Clement <[hidden email]> wrote:
We might be having some issues because I'm hearing groovy isn't behaving too well on Java8. Still investigating. We'll provide an update soon.

cheers,
Andy


On 25 March 2014 02:01, Martijn Verburg <[hidden email]> wrote:
Hi Andy,

Awesome! Let me know if you want us to test early (I've got a Maven build that can point at SNAPSHOT plugins from the Codehaus repo).

Cheers,
Martijn


On 24 March 2014 15:22, Andy Clement <[hidden email]> wrote:
We are just doing the final testing around the groovy-java8 stuff.  We have to 'patch the patch' (patch the java8 patch to open it up for groovy).  It should be available in the next day or so in the IDE - the maven integration might take a little bit longer.

cheers,
Andy


On 24 March 2014 07:50, Thomas Modeneis <[hidden email]> wrote:
Hi Martijn,

This is up to come, you can ping the thread and ask Andy how is it going...


On Mon, Mar 24, 2014 at 2:49 PM, Martijn Verburg <[hidden email]> wrote:
Hi all,

We're hoping to upgrade to Java 8 but have a mixed Groovy and Java codebase. When we set the compiler level to 1.8, the groovy-eclipse-compiler seems to fail to correctly pass that value through and/or deal with it, leading to a message similar to:

...
Compilation failure:
found 0 errors and 0 warnings.
...

Is this expected behaviour or is Java 8 support still to arrive in an upcoming release?

Cheers,
Martijn








Reply | Threaded
Open this post in threaded view
|

RE: Java 8 support?

Skeptic .
Moving to 4.3/4 is a big step, as you surely know it, many less active plugins are still working only on 3.x, so having groovy 2.3 working on 3.7 would be meaningful for a lot of people IMHO.


Date: Tue, 13 May 2014 13:54:42 -0700
From: [hidden email]
To: [hidden email]
Subject: Re: [groovy-eclipse-plugin-user] Java 8 support?

If the builds are working, or can be made to work easily, for 3.7, we would probably include that. Right now the important one is 4.3 based greclipse and looking ahead a good 4.4 based release.  The 3.7 builds don't look so healthy at the moment: https://build.spring.io/browse/GRECLIPSE-E37P

Andy


On 13 May 2014 12:54, Skeptic . <[hidden email]> wrote:
Will the 2.9.0 release be available for eclipse 3.7 or only 4.x ?


Date: Tue, 13 May 2014 12:05:27 -0700
From: [hidden email]
To: [hidden email]
Subject: Re: [groovy-eclipse-plugin-user] Java 8 support?


We are thinking about a groovy-eclipse 2.9.0 release shortly (in May), this work would be included as part of that. Up until yesterday greclipse was using groovy 2.3.0.rc1 but now we are updated to 2.3.0 final. I'd probably recommend you raise a jira to ensure we track getting the batch work done.

I don't think Kris has fully automated the release of the batch thing yet, which slows down getting it out there, unfortunately.

cheers,
Andy


On 10 May 2014 08:02, Steve Ash <[hidden email]> wrote:
Groovy 2.3 is out now.  Any ETA on a groovy-eclipse-batch release that incorporates it?  Can't wait to get on Java8!


On Thu, Mar 27, 2014 at 8:20 AM, Martijn Verburg <[hidden email]> wrote:
Hi Andy,

From what I could tell Groovy isn't officially supporting Java 8 until they release 2.3 (next couple of weeks), HTH.

Cheers,
Martijn


On 27 March 2014 04:08, Andy Clement <[hidden email]> wrote:
We might be having some issues because I'm hearing groovy isn't behaving too well on Java8. Still investigating. We'll provide an update soon.

cheers,
Andy


On 25 March 2014 02:01, Martijn Verburg <[hidden email]> wrote:
Hi Andy,

Awesome! Let me know if you want us to test early (I've got a Maven build that can point at SNAPSHOT plugins from the Codehaus repo).

Cheers,
Martijn


On 24 March 2014 15:22, Andy Clement <[hidden email]> wrote:
We are just doing the final testing around the groovy-java8 stuff.  We have to 'patch the patch' (patch the java8 patch to open it up for groovy).  It should be available in the next day or so in the IDE - the maven integration might take a little bit longer.

cheers,
Andy


On 24 March 2014 07:50, Thomas Modeneis <[hidden email]> wrote:
Hi Martijn,

This is up to come, you can ping the thread and ask Andy how is it going...


On Mon, Mar 24, 2014 at 2:49 PM, Martijn Verburg <[hidden email]> wrote:
Hi all,

We're hoping to upgrade to Java 8 but have a mixed Groovy and Java codebase. When we set the compiler level to 1.8, the groovy-eclipse-compiler seems to fail to correctly pass that value through and/or deal with it, leading to a message similar to:

...
Compilation failure:
found 0 errors and 0 warnings.
...

Is this expected behaviour or is Java 8 support still to arrive in an upcoming release?

Cheers,
Martijn








Reply | Threaded
Open this post in threaded view
|

Re: Java 8 support?

johnmcclean
This post has NOT been accepted by the mailing list yet.
In reply to this post by Andy Clement
Hey guys,

We're having some problems with eclipse-batch 2.3.0-01-SNAPSHOT with JDK 8 and Lombok.

Lombok annotation handler class lombok.eclipse.handlers.HandleGetter failed
java.lang.IllegalStateException: Workspace is closed.

POM snippet below. Does anyone know of a working combination maven plugins (does not have to be Groovy 2.3)?

        <plugin>
                                <artifactId>maven-compiler-plugin</artifactId>
                                <version>3.0</version>
                                <configuration>
                                        <compilerId>groovy-eclipse-compiler</compilerId>
                                        <source>${java-version}</source>
                                        <target>${java-version}</target>
                                        <compilerVersion>${java-version}</compilerVersion>
                                        <verbose>true</verbose>
                                        <compilerArguments>
                                                <javaAgentClass>lombok.core.Agent</javaAgentClass>
                                        </compilerArguments>
                                        <fork>true</fork>
                                </configuration>
                                <dependencies>
                                        <dependency>
                                                <groupId>org.codehaus.groovy</groupId>
                                                <artifactId>groovy-eclipse-compiler</artifactId>
                                                <version>2.9.0-01-SNAPSHOT</version>
                                        </dependency>
                                       
                                        <dependency>
                                                <groupId>org.codehaus.groovy</groupId>
                                                <artifactId>groovy-eclipse-batch</artifactId>
                                                <version>2.3.0-01-SNAPSHOT</version>
                                               
                                        </dependency>
                                        <dependency>
                                                <groupId>org.projectlombok</groupId>
                                                <artifactId>lombok</artifactId>
                                                <version>1.14.2</version>
                                        </dependency>
                                </dependencies>
                        </plugin>
Reply | Threaded
Open this post in threaded view
|

Re: Java 8 support?

johnmcclean
This post has NOT been accepted by the mailing list yet.
For anyone else looking at a similar issue, I think that the problem may originate with Lombok. The problem does not occur with Lombok 1.12.6.