Java8 support?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Java8 support?

steve.ash
Since the current groovy eclipse compiler is based on the eclipse compiler- does it already support java8 source and target compiler levels?


Reply | Threaded
Open this post in threaded view
|

Re: Java8 support?

Andy Clement
I have just (last week) done the work to patch the Eclipse Java8 compiler to integrate groovy compilation. The first proper versions of this will be announced soon. I had to wait until the eclipse java 8 compiler was in a good state and eventually went with their RC2 version.

cheers,
Andy


On 10 March 2014 09:38, Steve Ash <[hidden email]> wrote:
Since the current groovy eclipse compiler is based on the eclipse compiler- does it already support java8 source and target compiler levels?