Missing snapshot dependencies for org.codehaus.groovy:groovy-eclipse-batch

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing snapshot dependencies for org.codehaus.groovy:groovy-eclipse-batch

Carr, Brian M
Hello all,

The POM for groovy-eclipse-plugin:2.5.1 seems to have a version range specified which includes a snapshot version range.  See the following error


No versions available for org.codehaus.groovy:groovy-eclipse-batch:jar:[1.7.10-SNAPSHOT],[1.8.0-SNAPSHOT] within specified range


It seems like sometime recently those snapshots were removed from maven central (probably because they don't allow snapshots there), and as such, unless you happened to have those snapshots on disk, you cannot build a project using the eclipse plugin.


The (ugly) workaround is:

  <build>
    <plugins>
      <plugin>
        <artifactId>maven-compiler-plugin</artifactId>
        <version>2.3.1</version>
        <configuration>
          <compilerId>groovy-eclipse-compiler</compilerId>
          <verbose>true</verbose>
        </configuration>
        <dependencies>
          <dependency>
            <groupId>org.codehaus.groovy</groupId>
            <artifactId>groovy-eclipse-compiler</artifactId>
            <version>2.5.1</version>
            <exclusions>
              <exclusion>
                <groupId>org.codehaus.groovy</groupId>
                <artifactId>groovy-eclipse-batch</artifactId>
              </exclusion>
            </exclusions>
          </dependency>
          <dependency>
            <groupId>org.codehaus.groovy</groupId>
            <artifactId>groovy-eclipse-batch</artifactId>
            <version>1.8.0-01</version>
          </dependency>
        </dependencies>
      </plugin>
    </plugins>
  </build>



any chance we can get a 2.5.1-1 pushed that points to the correct groovy-eclipse-batch non-snapshot dependencies?

___________________________
Brian M. Carr
Senior Software Engineer
Identity Management, ITS Applications
University of Texas at Austin
V: 512-232-6419
F: 512-471-5746
[hidden email]


smime.p7s (6K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Missing snapshot dependencies for org.codehaus.groovy:groovy-eclipse-batch

Andrew Eisenberg
I'll get that done in the next day and let you know when it is available.

On Tue, Jul 26, 2011 at 12:35 PM, Carr, Brian M
<[hidden email]> wrote:

> Hello all,
>
> The POM for groovy-eclipse-plugin:2.5.1 seems to have a version range specified which includes a snapshot version range.  See the following error
>
>
> No versions available for org.codehaus.groovy:groovy-eclipse-batch:jar:[1.7.10-SNAPSHOT],[1.8.0-SNAPSHOT] within specified range
>
>
> It seems like sometime recently those snapshots were removed from maven central (probably because they don't allow snapshots there), and as such, unless you happened to have those snapshots on disk, you cannot build a project using the eclipse plugin.
>
>
> The (ugly) workaround is:
>
>  <build>
>    <plugins>
>      <plugin>
>        <artifactId>maven-compiler-plugin</artifactId>
>        <version>2.3.1</version>
>        <configuration>
>          <compilerId>groovy-eclipse-compiler</compilerId>
>          <verbose>true</verbose>
>        </configuration>
>        <dependencies>
>          <dependency>
>            <groupId>org.codehaus.groovy</groupId>
>            <artifactId>groovy-eclipse-compiler</artifactId>
>            <version>2.5.1</version>
>            <exclusions>
>              <exclusion>
>                <groupId>org.codehaus.groovy</groupId>
>                <artifactId>groovy-eclipse-batch</artifactId>
>              </exclusion>
>            </exclusions>
>          </dependency>
>          <dependency>
>            <groupId>org.codehaus.groovy</groupId>
>            <artifactId>groovy-eclipse-batch</artifactId>
>            <version>1.8.0-01</version>
>          </dependency>
>        </dependencies>
>      </plugin>
>    </plugins>
>  </build>
>
>
>
> any chance we can get a 2.5.1-1 pushed that points to the correct groovy-eclipse-batch non-snapshot dependencies?
>
> ___________________________
> Brian M. Carr
> Senior Software Engineer
> Identity Management, ITS Applications
> University of Texas at Austin
> V: 512-232-6419
> F: 512-471-5746
> [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Missing snapshot dependencies for org.codehaus.groovy:groovy-eclipse-batch

Andrew Eisenberg
I just released version 2.5.1-1 of groovy-eclipse-compiler.  Please
let me know if this works for you.

On Tue, Jul 26, 2011 at 1:37 PM, Andrew Eisenberg <[hidden email]> wrote:

> I'll get that done in the next day and let you know when it is available.
>
> On Tue, Jul 26, 2011 at 12:35 PM, Carr, Brian M
> <[hidden email]> wrote:
>> Hello all,
>>
>> The POM for groovy-eclipse-plugin:2.5.1 seems to have a version range specified which includes a snapshot version range.  See the following error
>>
>>
>> No versions available for org.codehaus.groovy:groovy-eclipse-batch:jar:[1.7.10-SNAPSHOT],[1.8.0-SNAPSHOT] within specified range
>>
>>
>> It seems like sometime recently those snapshots were removed from maven central (probably because they don't allow snapshots there), and as such, unless you happened to have those snapshots on disk, you cannot build a project using the eclipse plugin.
>>
>>
>> The (ugly) workaround is:
>>
>>  <build>
>>    <plugins>
>>      <plugin>
>>        <artifactId>maven-compiler-plugin</artifactId>
>>        <version>2.3.1</version>
>>        <configuration>
>>          <compilerId>groovy-eclipse-compiler</compilerId>
>>          <verbose>true</verbose>
>>        </configuration>
>>        <dependencies>
>>          <dependency>
>>            <groupId>org.codehaus.groovy</groupId>
>>            <artifactId>groovy-eclipse-compiler</artifactId>
>>            <version>2.5.1</version>
>>            <exclusions>
>>              <exclusion>
>>                <groupId>org.codehaus.groovy</groupId>
>>                <artifactId>groovy-eclipse-batch</artifactId>
>>              </exclusion>
>>            </exclusions>
>>          </dependency>
>>          <dependency>
>>            <groupId>org.codehaus.groovy</groupId>
>>            <artifactId>groovy-eclipse-batch</artifactId>
>>            <version>1.8.0-01</version>
>>          </dependency>
>>        </dependencies>
>>      </plugin>
>>    </plugins>
>>  </build>
>>
>>
>>
>> any chance we can get a 2.5.1-1 pushed that points to the correct groovy-eclipse-batch non-snapshot dependencies?
>>
>> ___________________________
>> Brian M. Carr
>> Senior Software Engineer
>> Identity Management, ITS Applications
>> University of Texas at Austin
>> V: 512-232-6419
>> F: 512-471-5746
>> [hidden email]
>>
>>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Missing snapshot dependencies for org.codehaus.groovy:groovy-eclipse-batch

Carr, Brian M
This does the trick.  Thanks, Andrew!

--b
___________________________
Brian M. Carr
Senior Software Engineer
Identity Management, ITS Applications
University of Texas at Austin
V: 512-232-6419
F: 512-471-5746
[hidden email]

On Jul 27, 2011, at 2:20 PM, Andrew Eisenberg wrote:

> I just released version 2.5.1-1 of groovy-eclipse-compiler.  Please
> let me know if this works for you.
>
> On Tue, Jul 26, 2011 at 1:37 PM, Andrew Eisenberg <[hidden email]> wrote:
>> I'll get that done in the next day and let you know when it is available.
>>
>> On Tue, Jul 26, 2011 at 12:35 PM, Carr, Brian M
>> <[hidden email]> wrote:
>>> Hello all,
>>>
>>> The POM for groovy-eclipse-plugin:2.5.1 seems to have a version range specified which includes a snapshot version range.  See the following error
>>>
>>>
>>> No versions available for org.codehaus.groovy:groovy-eclipse-batch:jar:[1.7.10-SNAPSHOT],[1.8.0-SNAPSHOT] within specified range
>>>
>>>
>>> It seems like sometime recently those snapshots were removed from maven central (probably because they don't allow snapshots there), and as such, unless you happened to have those snapshots on disk, you cannot build a project using the eclipse plugin.
>>>
>>>
>>> The (ugly) workaround is:
>>>
>>>  <build>
>>>    <plugins>
>>>      <plugin>
>>>        <artifactId>maven-compiler-plugin</artifactId>
>>>        <version>2.3.1</version>
>>>        <configuration>
>>>          <compilerId>groovy-eclipse-compiler</compilerId>
>>>          <verbose>true</verbose>
>>>        </configuration>
>>>        <dependencies>
>>>          <dependency>
>>>            <groupId>org.codehaus.groovy</groupId>
>>>            <artifactId>groovy-eclipse-compiler</artifactId>
>>>            <version>2.5.1</version>
>>>            <exclusions>
>>>              <exclusion>
>>>                <groupId>org.codehaus.groovy</groupId>
>>>                <artifactId>groovy-eclipse-batch</artifactId>
>>>              </exclusion>
>>>            </exclusions>
>>>          </dependency>
>>>          <dependency>
>>>            <groupId>org.codehaus.groovy</groupId>
>>>            <artifactId>groovy-eclipse-batch</artifactId>
>>>            <version>1.8.0-01</version>
>>>          </dependency>
>>>        </dependencies>
>>>      </plugin>
>>>    </plugins>
>>>  </build>
>>>
>>>
>>>
>>> any chance we can get a 2.5.1-1 pushed that points to the correct groovy-eclipse-batch non-snapshot dependencies?
>>>
>>> ___________________________
>>> Brian M. Carr
>>> Senior Software Engineer
>>> Identity Management, ITS Applications
>>> University of Texas at Austin
>>> V: 512-232-6419
>>> F: 512-471-5746
>>> [hidden email]
>>>
>>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>


smime.p7s (6K) Download Attachment