Problem installing groovy-plugin on eclipse 3.5.1 on ubuntu 9.10

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem installing groovy-plugin on eclipse 3.5.1 on ubuntu 9.10

guypes@iol.it
Cannot complete the install because of a conflicting dependency.
  Software being installed: Groovy-Eclipse Feature 2.0.0.xx-20100115-0900-e35-
RELEASE (org.codehaus.groovy.eclipse.feature.feature.group 2.0.0.xx-20100115-
0900-e35-RELEASE)
  Software currently installed: Eclipse Platform 3.5.1 (Eclipse Platform
3.5.1)
  Only one of the following can be installed at once:
    Java Development Tools Core 3.5.2.v_981_R35x (org.eclipse.jdt.core 3.5.2.
v_981_R35x)
    Java Development Tools Core 3.5.1.xx-20100115-0900-e35-RELEASE (org.
eclipse.jdt.core 3.5.1.xx-20100115-0900-e35-RELEASE)
    Java Development Tools Core 3.5.1.v_972_R35x (org.eclipse.jdt.core 3.5.1.
v_972_R35x)
  Cannot satisfy dependency:
    From: Eclipse Platform 3.5.1 (Eclipse Platform 3.5.1)
    To: org.eclipse.jdt.core [3.5.1.v_972_R35x]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.5.1 (Eclipse Platform 3.5.1)
    To: org.eclipse.jdt.feature.group [3.5.1.r351_v20090810-0600-
7r88FEoFHxXYpY3s0jOJPn58EpLN]
  Cannot satisfy dependency:
    From: Groovy-Eclipse Feature 2.0.0.xx-20100115-0900-e35-RELEASE (org.
codehaus.groovy.eclipse.feature.feature.group 2.0.0.xx-20100115-0900-e35-
RELEASE)
    To: org.codehaus.groovy.jdt.patch.feature.group [2.0.0.xx-20100115-0900-
e35-RELEASE]
  Cannot satisfy dependency:
    From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20100115-
0900-e35-RELEASE Eclipse Java Development Tools 3.5.1.r351_v20090810-0600-
7r88FEoFHxXYpY3s0jOJPn58EpLN (org.eclipse.jdt.feature.group 3.5.1.
r351_v20090810-0600-7r88FEoFHxXYpY3s0jOJPn58EpLN)
    To: org.eclipse.jdt.core [3.5.1.xx-20100115-0900-e35-RELEASE]

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Problem installing groovy-plugin on eclipse 3.5.1 on ubuntu 9.10

Andrew Eisenberg
It is likely that you are hitting this bug:
http://jira.codehaus.org/browse/GRECLIPSE-498

If so, the solution is to upgrade to a fresh install of Eclipse 3.5.2
and then install Groovy-Eclipse.

On Mon, Apr 26, 2010 at 11:39 PM, [hidden email] <[hidden email]> wrote:

> Cannot complete the install because of a conflicting dependency.
>  Software being installed: Groovy-Eclipse Feature 2.0.0.xx-20100115-0900-e35-
> RELEASE (org.codehaus.groovy.eclipse.feature.feature.group 2.0.0.xx-20100115-
> 0900-e35-RELEASE)
>  Software currently installed: Eclipse Platform 3.5.1 (Eclipse Platform
> 3.5.1)
>  Only one of the following can be installed at once:
>    Java Development Tools Core 3.5.2.v_981_R35x (org.eclipse.jdt.core 3.5.2.
> v_981_R35x)
>    Java Development Tools Core 3.5.1.xx-20100115-0900-e35-RELEASE (org.
> eclipse.jdt.core 3.5.1.xx-20100115-0900-e35-RELEASE)
>    Java Development Tools Core 3.5.1.v_972_R35x (org.eclipse.jdt.core 3.5.1.
> v_972_R35x)
>  Cannot satisfy dependency:
>    From: Eclipse Platform 3.5.1 (Eclipse Platform 3.5.1)
>    To: org.eclipse.jdt.core [3.5.1.v_972_R35x]
>  Cannot satisfy dependency:
>    From: Eclipse Platform 3.5.1 (Eclipse Platform 3.5.1)
>    To: org.eclipse.jdt.feature.group [3.5.1.r351_v20090810-0600-
> 7r88FEoFHxXYpY3s0jOJPn58EpLN]
>  Cannot satisfy dependency:
>    From: Groovy-Eclipse Feature 2.0.0.xx-20100115-0900-e35-RELEASE (org.
> codehaus.groovy.eclipse.feature.feature.group 2.0.0.xx-20100115-0900-e35-
> RELEASE)
>    To: org.codehaus.groovy.jdt.patch.feature.group [2.0.0.xx-20100115-0900-
> e35-RELEASE]
>  Cannot satisfy dependency:
>    From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20100115-
> 0900-e35-RELEASE Eclipse Java Development Tools 3.5.1.r351_v20090810-0600-
> 7r88FEoFHxXYpY3s0jOJPn58EpLN (org.eclipse.jdt.feature.group 3.5.1.
> r351_v20090810-0600-7r88FEoFHxXYpY3s0jOJPn58EpLN)
>    To: org.eclipse.jdt.core [3.5.1.xx-20100115-0900-e35-RELEASE]
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email