Problem updating

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem updating

Eric Tiffany
I currently have  

Groovy-Eclipse Feature 2.0.2.20100504-2000-e35

installed on Eclipse Platform 
Version: 3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB
Build id: M20100211-1343

The update wizard claims there is a Groovy Plugin update, but when I click finish, it tries downloading and claims about 3% done and then gets this error.   

An error occurred while collecting items to be installed
  session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Collect, operand=, action=).
  No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse,2.0.2.20100506-2000-e35
  No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.ant,2.0.2.20100506-2000-e35
  No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.codeassist.completion,2.0.2.20100506-2000-e35
  No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.codebrowsing,2.0.2.20100506-2000-e35
  No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.core,2.0.2.20100506-2000-e35
  No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.core.help,2.0.2.20100506-2000-e35
  No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.cstviewer,2.0.2.20100506-2000-e35
  No repository found containing: org.eclipse.update.feature,org.codehaus.groovy.eclipse.feature,2.0.2.20100506-2000-e35
  No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.refactoring,2.0.2.20100506-2000-e35
  No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.ui,2.0.2.20100506-2000-e35
  No repository found containing: org.eclipse.update.feature,org.codehaus.groovy.jdt.patch,2.0.2.20100506-2000-e35
  No repository found containing: org.eclipse.update.feature,org.codehaus.groovy16.feature,2.0.2.20100506-2000-e35
  No repository found containing: org.eclipse.update.feature,org.codehaus.groovy17.feature,2.0.2.20100506-2000-e35
  No repository found containing: osgi.bundle,org.eclipse.jdt.core,3.5.2.20100506-2000-e35
  No repository found containing: osgi.bundle,org.eclipse.jdt.groovy.core,2.0.2.20100506-2000-e35
  No repository found containing: osgi.bundle,org.codehaus.groovy,1.6.7.20100506-2000-e35
  No repository found containing: osgi.bundle,org.codehaus.groovy,1.7.2.20100506-2000-e35





Reply | Threaded
Open this post in threaded view
|

Re: Problem updating

Andrew Eisenberg
It looks like your installer has not updated its metadata to the most
recent version of Groovy Eclipse.  It is trying to download the
2.0.2.20100506-2000-e35 version, but that is no longer available.
Instead, the 2.0.2.20100507-1600-e35 version is available.

Usually, all you need to do is restart Eclipse and try again.  It
should work.  Also, I recommend going through the "Install new
software..." wizard instead of "Check for updates".  Let me know if
this does not work for you.

On Sat, May 8, 2010 at 8:34 AM, Eric Tiffany <[hidden email]> wrote:

> I currently have
> Groovy-Eclipse Feature 2.0.2.20100504-2000-e35
> installed on Eclipse Platform
> Version: 3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB
> Build id: M20100211-1343
> The update wizard claims there is a Groovy Plugin update, but when I click
> finish, it tries downloading and claims about 3% done and then gets this
> error.
> An error occurred while collecting items to be installed
>   session context was:(profile=epp.package.jee,
> phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Collect,
> operand=, action=).
>   No repository found containing:
> osgi.bundle,org.codehaus.groovy.eclipse,2.0.2.20100506-2000-e35
>   No repository found containing:
> osgi.bundle,org.codehaus.groovy.eclipse.ant,2.0.2.20100506-2000-e35
>   No repository found containing:
> osgi.bundle,org.codehaus.groovy.eclipse.codeassist.completion,2.0.2.20100506-2000-e35
>   No repository found containing:
> osgi.bundle,org.codehaus.groovy.eclipse.codebrowsing,2.0.2.20100506-2000-e35
>   No repository found containing:
> osgi.bundle,org.codehaus.groovy.eclipse.core,2.0.2.20100506-2000-e35
>   No repository found containing:
> osgi.bundle,org.codehaus.groovy.eclipse.core.help,2.0.2.20100506-2000-e35
>   No repository found containing:
> osgi.bundle,org.codehaus.groovy.eclipse.cstviewer,2.0.2.20100506-2000-e35
>   No repository found containing:
> org.eclipse.update.feature,org.codehaus.groovy.eclipse.feature,2.0.2.20100506-2000-e35
>   No repository found containing:
> osgi.bundle,org.codehaus.groovy.eclipse.refactoring,2.0.2.20100506-2000-e35
>   No repository found containing:
> osgi.bundle,org.codehaus.groovy.eclipse.ui,2.0.2.20100506-2000-e35
>   No repository found containing:
> org.eclipse.update.feature,org.codehaus.groovy.jdt.patch,2.0.2.20100506-2000-e35
>   No repository found containing:
> org.eclipse.update.feature,org.codehaus.groovy16.feature,2.0.2.20100506-2000-e35
>   No repository found containing:
> org.eclipse.update.feature,org.codehaus.groovy17.feature,2.0.2.20100506-2000-e35
>   No repository found containing:
> osgi.bundle,org.eclipse.jdt.core,3.5.2.20100506-2000-e35
>   No repository found containing:
> osgi.bundle,org.eclipse.jdt.groovy.core,2.0.2.20100506-2000-e35
>   No repository found containing:
> osgi.bundle,org.codehaus.groovy,1.6.7.20100506-2000-e35
>   No repository found containing:
> osgi.bundle,org.codehaus.groovy,1.7.2.20100506-2000-e35
>
>
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Problem updating

Eric Tiffany
Hmm, I tried using the "Install New Software..." after restarting.

I seem to have two update sites available for Groovy Plugin


1. Groovy Update Site - http://dist.springsource.org/milestone/GRECLIPSE/e3.5/

If I select this site, it only says "All items are installed" under Groovy-Eclipse


2. Groovy Plugin - http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.5/

If I select this site, it shows only one option:

     Groovy-Eclipse Feature 2.0.2.20100507-0800-e35

(but note that the time on this listing is 0800 not 1600 which you said is the latest).  If I select this option and proceed, it actually updates and finishes.

Anyway, it seems mostly sorted.

Thanks.



On May 8, 2010, at 11:31 PM, Andrew Eisenberg wrote:

> It looks like your installer has not updated its metadata to the most
> recent version of Groovy Eclipse.  It is trying to download the
> 2.0.2.20100506-2000-e35 version, but that is no longer available.
> Instead, the 2.0.2.20100507-1600-e35 version is available.
>
> Usually, all you need to do is restart Eclipse and try again.  It
> should work.  Also, I recommend going through the "Install new
> software..." wizard instead of "Check for updates".  Let me know if
> this does not work for you.
>
> On Sat, May 8, 2010 at 8:34 AM, Eric Tiffany <[hidden email]> wrote:
>> I currently have
>> Groovy-Eclipse Feature 2.0.2.20100504-2000-e35
>> installed on Eclipse Platform
>> Version: 3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB
>> Build id: M20100211-1343
>> The update wizard claims there is a Groovy Plugin update, but when I click
>> finish, it tries downloading and claims about 3% done and then gets this
>> error.
>> An error occurred while collecting items to be installed
>>   session context was:(profile=epp.package.jee,
>> phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Collect,
>> operand=, action=).
>>   No repository found containing:
>> osgi.bundle,org.codehaus.groovy.eclipse,2.0.2.20100506-2000-e35
>>   No repository found containing:
>> osgi.bundle,org.codehaus.groovy.eclipse.ant,2.0.2.20100506-2000-e35
>>   No repository found containing:
>> osgi.bundle,org.codehaus.groovy.eclipse.codeassist.completion,2.0.2.20100506-2000-e35
>>   No repository found containing:
>> osgi.bundle,org.codehaus.groovy.eclipse.codebrowsing,2.0.2.20100506-2000-e35
>>   No repository found containing:
>> osgi.bundle,org.codehaus.groovy.eclipse.core,2.0.2.20100506-2000-e35
>>   No repository found containing:
>> osgi.bundle,org.codehaus.groovy.eclipse.core.help,2.0.2.20100506-2000-e35
>>   No repository found containing:
>> osgi.bundle,org.codehaus.groovy.eclipse.cstviewer,2.0.2.20100506-2000-e35
>>   No repository found containing:
>> org.eclipse.update.feature,org.codehaus.groovy.eclipse.feature,2.0.2.20100506-2000-e35
>>   No repository found containing:
>> osgi.bundle,org.codehaus.groovy.eclipse.refactoring,2.0.2.20100506-2000-e35
>>   No repository found containing:
>> osgi.bundle,org.codehaus.groovy.eclipse.ui,2.0.2.20100506-2000-e35
>>   No repository found containing:
>> org.eclipse.update.feature,org.codehaus.groovy.jdt.patch,2.0.2.20100506-2000-e35
>>   No repository found containing:
>> org.eclipse.update.feature,org.codehaus.groovy16.feature,2.0.2.20100506-2000-e35
>>   No repository found containing:
>> org.eclipse.update.feature,org.codehaus.groovy17.feature,2.0.2.20100506-2000-e35
>>   No repository found containing:
>> osgi.bundle,org.eclipse.jdt.core,3.5.2.20100506-2000-e35
>>   No repository found containing:
>> osgi.bundle,org.eclipse.jdt.groovy.core,2.0.2.20100506-2000-e35
>>   No repository found containing:
>> osgi.bundle,org.codehaus.groovy,1.6.7.20100506-2000-e35
>>   No repository found containing:
>> osgi.bundle,org.codehaus.groovy,1.7.2.20100506-2000-e35
>>
>>
>>
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Problem updating

Andrew Eisenberg
> 1. Groovy Update Site - http://dist.springsource.org/milestone/GRECLIPSE/e3.5/
This is the milestone update site the only version on it is 2.0.1.
You can safely remove this update site as it is not changed often.

> 2. Groovy Plugin - http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.5/
>
> If I select this site, it shows only one option:
>
>     Groovy-Eclipse Feature     2.0.2.20100507-0800-e35
>
That's right.  I miswrote the timestamp.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email