Re: [groovy-user] Strange error in Eclipse

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: [groovy-user] Strange error in Eclipse

Andrew Eisenberg
Hi Mark,

You'll probably get better support by sending a message to the
eclipse-plugin-user mailing list.

Is it possible that you have the groovy jars on your classpath more than once?

If you can isolate this problem in a simple script that you can send
my way and I can test, I can probably figure out what is going wrong.

On Mon, Dec 21, 2009 at 8:10 AM, Mark Russell
<[hidden email]> wrote:

> when I run a Groovy script in Eclipse I just started to get this error:
> Caught: java.lang.LinkageError: loader constraint violation: when resolving
> overridden method
> "com.instantiations.css.build.CssEditorBuild.super$2$inContext(Ljava/lang/String;Lgroovy/lang/Closure;)V"
> the class loader (instance of groovy/lang/GroovyClassLoader$InnerLoader) of
> the current class, com/instantiations/css/build/CssEditorBuild, and its
> superclass loader (instance of sun/misc/Launcher$AppClassLoader), have
> different Class objects for the type groovy/lang/Closure used in the
> signature
>
> Any ideas why I'm getting this?
> I'm using Eclipse 3.5.1 and Groovy feature 2.0.0.xx-20091218-1000-e35
> --
> Mark Russell
> Build Master
> Instantiations, Inc.
> +1 724-368-3331 (land line)
> http://www.instantiations.com
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email