Request for Groovy Eclipse build org.codehaus.groovy_2.0.7.xx-20130403-1600-e42

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Request for Groovy Eclipse build org.codehaus.groovy_2.0.7.xx-20130403-1600-e42

Luke de Gruchy
Hi,

I'm having an issue with Groovy Eclipse since our project requires certain jars only in org.codehaus.groovy_2.0.7.xx-20130403-1600-e42 to run our unit tests.  Among others, we need asm-4.0.jar. These jars have dissapeared in newer versions of the plugin such as the May and June 2013 builds.

After much searching, I'm unable to find a link for this archived build.  According to this page, I need to request such a build from this mailing list, as only this archive is linked:  archive-2.8.0.xx-20130603-1200-e42.zip

http://dist.springsource.org/snapshot/GRECLIPSE/e4.2/index.html

Could you please either send me this build as a zip or as a URL?

Thanks,
Luke
-- 
Luke de Gruchy
Senior Software Developer
Intelerad Medical Systems Incorporated
895 de la Gauchetiere W, Suite 400
Montreal, Quebec, Canada H3B 4G1
Tel: 514.931.6222 x7760
Fax: 514.931.4653
[hidden email]
www.intelerad.com


This email or any attachments may contain confidential or legally privileged information intended for the sole use of the addressees. Any use, redistribution, disclosure, or reproduction of this information, except as intended, is prohibited. If you received this email in error, please notify the sender and remove all copies of the message, including any attachments.

Reply | Threaded
Open this post in threaded view
|

Re: Request for Groovy Eclipse build org.codehaus.groovy_2.0.7.xx-20130403-1600-e42

Luke de Gruchy
BTW, I'm running Juno:

Eclipse SDK

Version: 4.2.2
Build id: M20130204-1200

On 06/05/2013 12:26 PM, Luke de Gruchy wrote:
Hi,

I'm having an issue with Groovy Eclipse since our project requires certain jars only in org.codehaus.groovy_2.0.7.xx-20130403-1600-e42 to run our unit tests.  Among others, we need asm-4.0.jar. These jars have dissapeared in newer versions of the plugin such as the May and June 2013 builds.

After much searching, I'm unable to find a link for this archived build.  According to this page, I need to request such a build from this mailing list, as only this archive is linked:  archive-2.8.0.xx-20130603-1200-e42.zip

http://dist.springsource.org/snapshot/GRECLIPSE/e4.2/index.html

Could you please either send me this build as a zip or as a URL?

Thanks,
Luke
-- 
Luke de Gruchy
Senior Software Developer
Intelerad Medical Systems Incorporated
895 de la Gauchetiere W, Suite 400
Montreal, Quebec, Canada H3B 4G1
Tel: 514.931.6222 x7760
Fax: 514.931.4653
[hidden email]
www.intelerad.com


-- 
Luke de Gruchy
Senior Software Developer
Intelerad Medical Systems Incorporated
895 de la Gauchetiere W, Suite 400
Montreal, Quebec, Canada H3B 4G1
Tel: 514.931.6222 x7760
Fax: 514.931.4653
[hidden email]
www.intelerad.com


This email or any attachments may contain confidential or legally privileged information intended for the sole use of the addressees. Any use, redistribution, disclosure, or reproduction of this information, except as intended, is prohibited. If you received this email in error, please notify the sender and remove all copies of the message, including any attachments.

Reply | Threaded
Open this post in threaded view
|

Re: Request for Groovy Eclipse build org.codehaus.groovy_2.0.7.xx-20130403-1600-e42

Andrew Eisenberg
Hi,

We removed the asm jars in order to trim the install size.  Now, we
only ship with groovy-all.  This saves about 20 Mb of install size and
so we feel that the change is worth it.  In the future, you will need
to get the asm jar from somewhere else, or simply rely on groovy-all's
asm, which exists in the jar with mangled package names.  I'd
recommend that you use something like maven or gradle to manage your
dependencies, instead of relying on what is inside of groovy-eclipse.

However, you can still get an older version of groovy-eclipse.  The
latest build of greclipse that has the asm jars is this one:

http://dist.springsource.org/milestone/GRECLIPSE/e4.2/archive-2.8.0.xx-20130417-1900-e42.zip

On Wed, Jun 5, 2013 at 10:06 AM, Luke de Gruchy
<[hidden email]> wrote:

> BTW, I'm running Juno:
>
> Eclipse SDK
>
> Version: 4.2.2
> Build id: M20130204-1200
>
>
> On 06/05/2013 12:26 PM, Luke de Gruchy wrote:
>
> Hi,
>
> I'm having an issue with Groovy Eclipse since our project requires certain
> jars only in org.codehaus.groovy_2.0.7.xx-20130403-1600-e42 to run our unit
> tests.  Among others, we need asm-4.0.jar. These jars have dissapeared in
> newer versions of the plugin such as the May and June 2013 builds.
>
> After much searching, I'm unable to find a link for this archived build.
> According to this page, I need to request such a build from this mailing
> list, as only this archive is linked:
> archive-2.8.0.xx-20130603-1200-e42.zip
>
> http://dist.springsource.org/snapshot/GRECLIPSE/e4.2/index.html
>
> Could you please either send me this build as a zip or as a URL?
>
> Thanks,
> Luke
>
> --
> Luke de Gruchy
> Senior Software Developer
> Intelerad Medical Systems Incorporated
> 895 de la Gauchetiere W, Suite 400
> Montreal, Quebec, Canada H3B 4G1
> Tel: 514.931.6222 x7760
> Fax: 514.931.4653
> [hidden email]
> www.intelerad.com
>
>
>
> --
> Luke de Gruchy
> Senior Software Developer
> Intelerad Medical Systems Incorporated
> 895 de la Gauchetiere W, Suite 400
> Montreal, Quebec, Canada H3B 4G1
> Tel: 514.931.6222 x7760
> Fax: 514.931.4653
> [hidden email]
> www.intelerad.com
>
>
>
> This email or any attachments may contain confidential or legally privileged
> information intended for the sole use of the addressees. Any use,
> redistribution, disclosure, or reproduction of this information, except as
> intended, is prohibited. If you received this email in error, please notify
> the sender and remove all copies of the message, including any attachments.
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Request for Groovy Eclipse build org.codehaus.groovy_2.0.7.xx-20130403-1600-e42

Luke de Gruchy
Thanks.

On 06/05/2013 01:38 PM, Andrew Eisenberg wrote:

> Hi,
>
> We removed the asm jars in order to trim the install size.  Now, we
> only ship with groovy-all.  This saves about 20 Mb of install size and
> so we feel that the change is worth it.  In the future, you will need
> to get the asm jar from somewhere else, or simply rely on groovy-all's
> asm, which exists in the jar with mangled package names.  I'd
> recommend that you use something like maven or gradle to manage your
> dependencies, instead of relying on what is inside of groovy-eclipse.
>
> However, you can still get an older version of groovy-eclipse.  The
> latest build of greclipse that has the asm jars is this one:
>
> http://dist.springsource.org/milestone/GRECLIPSE/e4.2/archive-2.8.0.xx-20130417-1900-e42.zip
>
> On Wed, Jun 5, 2013 at 10:06 AM, Luke de Gruchy
> <[hidden email]> wrote:
>> BTW, I'm running Juno:
>>
>> Eclipse SDK
>>
>> Version: 4.2.2
>> Build id: M20130204-1200
>>
>>
>> On 06/05/2013 12:26 PM, Luke de Gruchy wrote:
>>
>> Hi,
>>
>> I'm having an issue with Groovy Eclipse since our project requires certain
>> jars only in org.codehaus.groovy_2.0.7.xx-20130403-1600-e42 to run our unit
>> tests.  Among others, we need asm-4.0.jar. These jars have dissapeared in
>> newer versions of the plugin such as the May and June 2013 builds.
>>
>> After much searching, I'm unable to find a link for this archived build.
>> According to this page, I need to request such a build from this mailing
>> list, as only this archive is linked:
>> archive-2.8.0.xx-20130603-1200-e42.zip
>>
>> http://dist.springsource.org/snapshot/GRECLIPSE/e4.2/index.html
>>
>> Could you please either send me this build as a zip or as a URL?
>>
>> Thanks,
>> Luke
>>
>> --
>> Luke de Gruchy
>> Senior Software Developer
>> Intelerad Medical Systems Incorporated
>> 895 de la Gauchetiere W, Suite 400
>> Montreal, Quebec, Canada H3B 4G1
>> Tel: 514.931.6222 x7760
>> Fax: 514.931.4653
>> [hidden email]
>> www.intelerad.com
>>
>>
>>
>> --
>> Luke de Gruchy
>> Senior Software Developer
>> Intelerad Medical Systems Incorporated
>> 895 de la Gauchetiere W, Suite 400
>> Montreal, Quebec, Canada H3B 4G1
>> Tel: 514.931.6222 x7760
>> Fax: 514.931.4653
>> [hidden email]
>> www.intelerad.com
>>
>>
>>
>> This email or any attachments may contain confidential or legally privileged
>> information intended for the sole use of the addressees. Any use,
>> redistribution, disclosure, or reproduction of this information, except as
>> intended, is prohibited. If you received this email in error, please notify
>> the sender and remove all copies of the message, including any attachments.
>>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>      http://xircles.codehaus.org/manage_email
>
>


--
Luke de Gruchy
Senior Software Developer
Intelerad Medical Systems Incorporated
895 de la Gauchetiere W, Suite 400
Montreal, Quebec, Canada H3B 4G1
Tel: 514.931.6222 x7760
Fax: 514.931.4653
[hidden email]
www.intelerad.com


--

This email or any attachments may contain confidential or legally
privileged information intended for the sole use of the addressees. Any
use, redistribution, disclosure, or reproduction of this information,
except as intended, is prohibited. If you received this email in error,
please notify the sender and remove all copies of the message, including
any attachments.


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email