Semantic analysis exception with @Slf4j

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Semantic analysis exception with @Slf4j

Erwin Mueller
Hello, I have Eclise Indigo running and I did an Update of all components and
now I get the below described Exception with the @Slf4j AST annotation in my
tests.

Before I had:
    Groovy Compiler 2.0 Feature 2.7.0.xx-20120703-1400-e42-RELEASE
    Groovy-Eclipse Feature 2.7.0.xx-20120703-1400-e42-RELEASE
    Groovy-Eclipse M2E integration 2.7.0.xx-20120703-1400-e42-RELEASE
    m2e - Maven Integration for Eclipse 1.1.0.20120530-0009

With the update I have now:
    Groovy Compiler 2.0 Feature 2.7.1.xx-20120921-2000-e42RELEASE
    Groovy-Eclipse Feature 2.7.1.xx-20120921-2000-e42RELEASE
    Groovy-Eclipse M2E integration 2.7.1.xx-20120921-2000-e42RELEASE
    m2e - Maven Integration for Eclipse 1.2.0.20120903-1050

I have Slf4j in the maven dependencies, and if I run mvn clean test, it will
compile and test successfully.

Does anyone known how can I fix that?
I have created an issue: http://jira.codehaus.org/browse/GRECLIPSE-1520

Exception:
<----
Description Resource Path Location Type
General error during semantic analysis: null

groovy.lang.GroovyRuntimeException: null
        at
org.codehaus.groovy.transform.LogASTTransformation$AbstractLoggingStrategy.classNode(LogASTTransformation.java:235)
        at
groovy.util.logging.Slf4j$Slf4jLoggingStrategy.addLoggerFieldToClass(Slf4j.java:70)
        at
org.codehaus.groovy.transform.LogASTTransformation$1.visitClass(LogASTTransformation.java:91)
        at
org.codehaus.groovy.transform.LogASTTransformation.visit(LogASTTransformation.java:136)
        at
org.codehaus.groovy.transform.ASTTransformationVisitor.visitClass(ASTTransformationVisitor.java:147)
        at
org.codehaus.groovy.transform.ASTTransformationVisitor$2.call(ASTTransformationVisitor.java:220)
        at
org.codehaus.groovy.control.CompilationUnit.applyToPrimaryClassNodes(CompilationUnit.java:1191)
        at
org.codehaus.groovy.control.CompilationUnit.doPhaseOperation(CompilationUnit.java:623)
        at
org.codehaus.groovy.control.CompilationUnit.processPhaseOperations(CompilationUnit.java:601)
        at
org.codehaus.groovy.control.CompilationUnit.compile(CompilationUnit.java:578)
        at
org.codehaus.jdt.groovy.internal.compiler.ast.GroovyCompilationUnitDeclaration.processToPhase(GroovyCompilationUnitDeclaration.java:171)
        at
org.codehaus.jdt.groovy.internal.compiler.ast.GroovyCompilationUnitDeclaration.resolve(GroovyCompilationUnitDeclaration.java:1994)
        at org.eclipse.jdt.internal.compiler.Compiler.process(Compiler.java:827)
        at
org.eclipse.jdt.internal.compiler.ProcessTaskManager.run(ProcessTaskManager.java:137)
        at java.lang.Thread.run(Thread.java:722)
Caused by: java.lang.ClassNotFoundException: org.slf4j.Logger
        at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
        at groovy.lang.GroovyClassLoader.loadClass(GroovyClassLoader.java:648)
        at groovy.lang.GroovyClassLoader.loadClass(GroovyClassLoader.java:758)
        at groovy.lang.GroovyClassLoader.loadClass(GroovyClassLoader.java:746)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:264)
        at
org.codehaus.groovy.transform.LogASTTransformation$AbstractLoggingStrategy.classNode(LogASTTransformation.java:233)
        ... 14 more
        RunCsvProjectTest.groovy /fdsanalysiscli-
csvproject/src/test/groovy/com/anrisoftware/fdsanalysis/project/csv line 0
Java Problem
---->
--
Erwin Mueller
http://www.mueller-public.de - My site;
http://www.anr-institute.com - Advanced Natural Research Institute GmbH;

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Semantic analysis exception with @Slf4j

Erwin Mueller
On Saturday, October 20, 2012 12:24:48 PM you wrote:
> Hello, I have Eclise Indigo running and I did an Update of all components
> and now I get the below described Exception with the @Slf4j AST annotation
> in my tests.
[snip]

It tools like a duplicate of this bug:
https://jira.codehaus.org/browse/GRECLIPSE-1503
but with Slf4j and not Log4j AST annotation.

They did fix it for Log4j but forgot to test it for the other log-annotations.
Does anyone know if Slf4j is fixed for 2.7.2 release?
--
Erwin Mueller
http://www.mueller-public.de - My site;
http://www.anr-institute.com - Advanced Natural Research Institute GmbH;

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Semantic analysis exception with @Slf4j

Andrew Eisenberg
Have you upgraded to the latest snapshot?   I haven't tried this on
slf4j yet, but there is nothing specific about the fix that is log4j
only.  Use this update site:

 http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.7

On Sat, Oct 20, 2012 at 4:18 AM, Erwin Mueller
<[hidden email]> wrote:

> On Saturday, October 20, 2012 12:24:48 PM you wrote:
>> Hello, I have Eclise Indigo running and I did an Update of all components
>> and now I get the below described Exception with the @Slf4j AST annotation
>> in my tests.
> [snip]
>
> It tools like a duplicate of this bug:
> https://jira.codehaus.org/browse/GRECLIPSE-1503
> but with Slf4j and not Log4j AST annotation.
>
> They did fix it for Log4j but forgot to test it for the other log-annotations.
> Does anyone know if Slf4j is fixed for 2.7.2 release?
> --
> Erwin Mueller
> http://www.mueller-public.de - My site;
> http://www.anr-institute.com - Advanced Natural Research Institute GmbH;
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Semantic analysis exception with @Slf4j

Joris Kuipers
I had issues with @Slf4j as well until I updated to a recent snapshot: that made the issue go away.

2012/10/20 Andrew Eisenberg <[hidden email]>
Have you upgraded to the latest snapshot?   I haven't tried this on
slf4j yet, but there is nothing specific about the fix that is log4j
only.  Use this update site:

 http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.7

On Sat, Oct 20, 2012 at 4:18 AM, Erwin Mueller
<[hidden email]> wrote:
> On Saturday, October 20, 2012 12:24:48 PM you wrote:
>> Hello, I have Eclise Indigo running and I did an Update of all components
>> and now I get the below described Exception with the @Slf4j AST annotation
>> in my tests.
> [snip]
>
> It tools like a duplicate of this bug:
> https://jira.codehaus.org/browse/GRECLIPSE-1503
> but with Slf4j and not Log4j AST annotation.
>
> They did fix it for Log4j but forgot to test it for the other log-annotations.
> Does anyone know if Slf4j is fixed for 2.7.2 release?
> --
> Erwin Mueller
> http://www.mueller-public.de - My site;
> http://www.anr-institute.com - Advanced Natural Research Institute GmbH;
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: Semantic analysis exception with @Slf4j

Erwin Mueller
Hello, thank you. I try to update to snapshot but I get the error message in
the Eclipse updater. What update site do I need to add, I never used Groovy
snapshot before?

Error:

Your original request has been modified.
  "Groovy-Eclipse Feature" is already installed, so an update will be
performed instead.
Cannot complete the install because of a conflicting dependency.
  Software being installed: Groovy-Eclipse Feature 2.7.2.xx-20121019-2100-e37
(org.codehaus.groovy.eclipse.feature.feature.group 2.7.2.xx-20121019-2100-e37)
  Software currently installed: m2e - Maven Integration for Eclipse
1.2.0.20120903-1050 (org.eclipse.m2e.feature.feature.group
1.2.0.20120903-1050)
  Software currently installed: Eclipse SDK 4.2.1.M20120914-1800
(org.eclipse.sdk.ide 4.2.1.M20120914-1800)
  Only one of the following can be installed at once:
    Object Teams Development Tooling Core 3.8.1.v_OTDT_r210_201206090452
(org.eclipse.jdt.core 3.8.1.v_OTDT_r210_201206090452)
    Java Development Tools Core 3.8.2.xx-20120921-2000-e42RELEASE
(org.eclipse.jdt.core 3.8.2.xx-20120921-2000-e42RELEASE)
    Java Development Tools Core 3.8.1.v20120531-0637 (org.eclipse.jdt.core
3.8.1.v20120531-0637)
    Object Teams Development Tooling Core 3.8.2.v_OTDT_r211_201209011847
(org.eclipse.jdt.core 3.8.2.v_OTDT_r211_201209011847)
    Java Development Tools Core 3.8.2.v20120814-155456 (org.eclipse.jdt.core
3.8.2.v20120814-155456)
    Java Development Tools Core 3.7.3.xx-20121019-2100-e37
(org.eclipse.jdt.core 3.7.3.xx-20121019-2100-e37)
  Cannot satisfy dependency:
    From: Groovy-Eclipse Feature 2.7.2.xx-20121019-2100-e37
(org.codehaus.groovy.eclipse.feature.feature.group 2.7.2.xx-20121019-2100-e37)
    To: org.codehaus.groovy.jdt.patch.feature.group [2.7.1.xx-20121019-2100-
e37]
  Cannot satisfy dependency:
    From: Java Development Tools Launching Support 3.6.100.v20120523-1953
(org.eclipse.jdt.launching 3.6.100.v20120523-1953)
    To: bundle org.eclipse.jdt.core [3.8.0,4.0.0)
  Cannot satisfy dependency:
    From: m2e - Maven Integration for Eclipse 1.2.0.20120903-1050
(org.eclipse.m2e.feature.feature.group 1.2.0.20120903-1050)
    To: org.eclipse.m2e.launching [1.2.0.20120903-1050]
  Cannot satisfy dependency:
    From: Maven Integration for Eclipse Launching 1.2.0.20120903-1050
(org.eclipse.m2e.launching 1.2.0.20120903-1050)
    To: bundle org.eclipse.jdt.launching 0.0.0
  Cannot satisfy dependency:
    From: Eclipse Project SDK 4.2.1.v20120814-120134-7T7oDODQ-3Heq-
afCDlg7T4xJuvxaC2ohMfCfB5451Rz0 (org.eclipse.sdk.feature.group
4.2.1.v20120814-120134-7T7oDODQ-3Heq-afCDlg7T4xJuvxaC2ohMfCfB5451Rz0)
    To: org.eclipse.jdt.feature.group
[3.8.1.v20120814-104540-8-8nFqpFNOfwKDRVz-tXOcL5d_83]
  Cannot satisfy dependency:
    From: Eclipse SDK 4.2.1.M20120914-1800 (org.eclipse.sdk.ide
4.2.1.M20120914-1800)
    To: org.eclipse.sdk.feature.group [4.2.1.v20120814-120134-7T7oDODQ-3Heq-
afCDlg7T4xJuvxaC2ohMfCfB5451Rz0]
  Cannot satisfy dependency:
    From Patch: org.codehaus.groovy.jdt.patch.feature.group
2.7.1.xx-20121019-2100-e37 Eclipse Java Development Tools
3.8.1.v20120814-104540-8-8nFqpFNOfwKDRVz-tXOcL5d_83
(org.eclipse.jdt.feature.group 3.8.1.v20120814-104540-8-8nFqpFNOfwKDRVz-
tXOcL5d_83)
    To: org.eclipse.jdt.core [3.7.3.xx-20121019-2100-e37]

On Saturday, October 20, 2012 05:21:35 PM you wrote:

> I had issues with @Slf4j as well until I updated to a recent snapshot: that
> made the issue go away.
>
> 2012/10/20 Andrew Eisenberg <[hidden email]>
>
> > Have you upgraded to the latest snapshot?   I haven't tried this on
> > slf4j yet, but there is nothing specific about the fix that is log4j
> >
> > only.  Use this update site:
> >  http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.7
> >
[snip]
--
Erwin Mueller
http://www.mueller-public.de - My site;
http://www.anr-institute.com - Advanced Natural Research Institute GmbH;

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Semantic analysis exception with @Slf4j

Andrew Eisenberg
Try this update site instead:
http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e4.2

On Sat, Oct 20, 2012 at 9:00 PM, Erwin Mueller
<[hidden email]> wrote:

> Hello, thank you. I try to update to snapshot but I get the error message in
> the Eclipse updater. What update site do I need to add, I never used Groovy
> snapshot before?
>
> Error:
>
> Your original request has been modified.
>   "Groovy-Eclipse Feature" is already installed, so an update will be
> performed instead.
> Cannot complete the install because of a conflicting dependency.
>   Software being installed: Groovy-Eclipse Feature 2.7.2.xx-20121019-2100-e37
> (org.codehaus.groovy.eclipse.feature.feature.group 2.7.2.xx-20121019-2100-e37)
>   Software currently installed: m2e - Maven Integration for Eclipse
> 1.2.0.20120903-1050 (org.eclipse.m2e.feature.feature.group
> 1.2.0.20120903-1050)
>   Software currently installed: Eclipse SDK 4.2.1.M20120914-1800
> (org.eclipse.sdk.ide 4.2.1.M20120914-1800)
>   Only one of the following can be installed at once:
>     Object Teams Development Tooling Core 3.8.1.v_OTDT_r210_201206090452
> (org.eclipse.jdt.core 3.8.1.v_OTDT_r210_201206090452)
>     Java Development Tools Core 3.8.2.xx-20120921-2000-e42RELEASE
> (org.eclipse.jdt.core 3.8.2.xx-20120921-2000-e42RELEASE)
>     Java Development Tools Core 3.8.1.v20120531-0637 (org.eclipse.jdt.core
> 3.8.1.v20120531-0637)
>     Object Teams Development Tooling Core 3.8.2.v_OTDT_r211_201209011847
> (org.eclipse.jdt.core 3.8.2.v_OTDT_r211_201209011847)
>     Java Development Tools Core 3.8.2.v20120814-155456 (org.eclipse.jdt.core
> 3.8.2.v20120814-155456)
>     Java Development Tools Core 3.7.3.xx-20121019-2100-e37
> (org.eclipse.jdt.core 3.7.3.xx-20121019-2100-e37)
>   Cannot satisfy dependency:
>     From: Groovy-Eclipse Feature 2.7.2.xx-20121019-2100-e37
> (org.codehaus.groovy.eclipse.feature.feature.group 2.7.2.xx-20121019-2100-e37)
>     To: org.codehaus.groovy.jdt.patch.feature.group [2.7.1.xx-20121019-2100-
> e37]
>   Cannot satisfy dependency:
>     From: Java Development Tools Launching Support 3.6.100.v20120523-1953
> (org.eclipse.jdt.launching 3.6.100.v20120523-1953)
>     To: bundle org.eclipse.jdt.core [3.8.0,4.0.0)
>   Cannot satisfy dependency:
>     From: m2e - Maven Integration for Eclipse 1.2.0.20120903-1050
> (org.eclipse.m2e.feature.feature.group 1.2.0.20120903-1050)
>     To: org.eclipse.m2e.launching [1.2.0.20120903-1050]
>   Cannot satisfy dependency:
>     From: Maven Integration for Eclipse Launching 1.2.0.20120903-1050
> (org.eclipse.m2e.launching 1.2.0.20120903-1050)
>     To: bundle org.eclipse.jdt.launching 0.0.0
>   Cannot satisfy dependency:
>     From: Eclipse Project SDK 4.2.1.v20120814-120134-7T7oDODQ-3Heq-
> afCDlg7T4xJuvxaC2ohMfCfB5451Rz0 (org.eclipse.sdk.feature.group
> 4.2.1.v20120814-120134-7T7oDODQ-3Heq-afCDlg7T4xJuvxaC2ohMfCfB5451Rz0)
>     To: org.eclipse.jdt.feature.group
> [3.8.1.v20120814-104540-8-8nFqpFNOfwKDRVz-tXOcL5d_83]
>   Cannot satisfy dependency:
>     From: Eclipse SDK 4.2.1.M20120914-1800 (org.eclipse.sdk.ide
> 4.2.1.M20120914-1800)
>     To: org.eclipse.sdk.feature.group [4.2.1.v20120814-120134-7T7oDODQ-3Heq-
> afCDlg7T4xJuvxaC2ohMfCfB5451Rz0]
>   Cannot satisfy dependency:
>     From Patch: org.codehaus.groovy.jdt.patch.feature.group
> 2.7.1.xx-20121019-2100-e37 Eclipse Java Development Tools
> 3.8.1.v20120814-104540-8-8nFqpFNOfwKDRVz-tXOcL5d_83
> (org.eclipse.jdt.feature.group 3.8.1.v20120814-104540-8-8nFqpFNOfwKDRVz-
> tXOcL5d_83)
>     To: org.eclipse.jdt.core [3.7.3.xx-20121019-2100-e37]
>
> On Saturday, October 20, 2012 05:21:35 PM you wrote:
>> I had issues with @Slf4j as well until I updated to a recent snapshot: that
>> made the issue go away.
>>
>> 2012/10/20 Andrew Eisenberg <[hidden email]>
>>
>> > Have you upgraded to the latest snapshot?   I haven't tried this on
>> > slf4j yet, but there is nothing specific about the fix that is log4j
>> >
>> > only.  Use this update site:
>> >  http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.7
>> >
> [snip]
> --
> Erwin Mueller
> http://www.mueller-public.de - My site;
> http://www.anr-institute.com - Advanced Natural Research Institute GmbH;
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Semantic analysis exception with @Slf4j

Erwin Mueller
Thank you now the bug is gone.

On Sunday, October 21, 2012 08:05:45 AM you wrote:
> Try this update site instead:
> http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e4.2
>
> On Sat, Oct 20, 2012 at 9:00 PM, Erwin Mueller
[snip]

--
Erwin Mueller
http://www.mueller-public.de - My site;
http://www.anr-institute.com - Advanced Natural Research Institute GmbH;

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email