Spock compile error after upgrading Groovy Eclipse

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Spock compile error after upgrading Groovy Eclipse

Peter Niederwieser
Administrator
After updating Groovy Eclipse to the latest dev build, I'm getting a general error in the Spock transform (i.e. an unexpected exception). However, the problems view only shows the first line of the groovyc error message*, hence I don't know which exception was thrown and can't see the stack trace. Also there is no information in the Eclipse error log. Where else could I look?

Cheers,
Peter

*Error message is constructed with:
sourceUnit.getErrorCollector().addErrorAndContinue(new SimpleMessage("multi \n line \n string", sourceUnit))
Reply | Threaded
Open this post in threaded view
|

Re: Spock compile error after upgrading Groovy Eclipse

Andy Clement
Peter - is that with groovy set at the 1.6 or 1.7 level?

Andy

On 12 July 2010 05:51, Peter Niederwieser <[hidden email]> wrote:

>
> After updating Groovy Eclipse to the latest dev build, I'm getting a general
> error in the Spock transform (i.e. an unexpected exception). However, the
> problems view only shows the first line of the groovyc error message*, hence
> I don't know which exception was thrown and can't see the stack trace. Also
> there is no information in the Eclipse error log. Where else could I look?
>
> Cheers,
> Peter
>
> *Error message is constructed with:
> sourceUnit.getErrorCollector().addErrorAndContinue(new SimpleMessage("multi
> \n line \n string", sourceUnit))
> --
> View this message in context: http://groovy-eclipse-plugin.42567.n3.nabble.com/Spock-compile-error-after-upgrading-Groovy-Eclipse-tp960236p960236.html
> Sent from the groovy-eclipse-plugin-user mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Spock compile error after upgrading Groovy Eclipse

Peter Niederwieser
Administrator
Andy Clement wrote
Peter - is that with groovy set at the 1.6 or 1.7 level?
It's 1.7.
Reply | Threaded
Open this post in threaded view
|

Re: Spock compile error after upgrading Groovy Eclipse

Peter Niederwieser
Administrator
The Spock transform error is a result of an incompatible AST change in Groovy 1.7.3. While we are still using 1.7.2 at work, the latest Groovy Eclipse builds use 1.7.3, hence our Eclipse users are running into this problem (which is easily fixed). So the only question that remains is why Groovy Eclipse doesn't show the full error message; I've created http://jira.codehaus.org/browse/GRECLIPSE-793 for this.

Cheers,
Peter