Trouble Eclipse-Groovy after updating to 2.5.1 plugin - can't find groovy-startup.conf

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Trouble Eclipse-Groovy after updating to 2.5.1 plugin - can't find groovy-startup.conf

Bill Wright
Hi, 

I'm using the STS Eclipse version (3.6) and installed the Groovy 1.8 tools. Everything was working fine but then I was prompted to upgrade to  Groovy Compiler 1.8 Feature (2.5.1.xx...) and Groovy-Eclipse Feature (2.5.1.xx). The installed worked and I restarted Eclipse, but when I go to run my program, I get this error: 


exception while configuring main class loader: 
java.io.FileNotFoundException: /Users/bwright/springsource/sts-2.6.1.SR1/plugins/org.codehaus.groovy_1.8.0.xx-20110606-1400-e36/conf/groovy-starter.conf (No such file or directory) 

Under the plugin directory I have this sub-directory: 

org.codehaus.groovy_1.8.0.xx-20110608-1400-e36 

Note that it is searching for 20110606 but I have 20110608 installed. Why is it looking in a non-existent directory and how can I fix this? It seems like the upgrade might have had the directory named hard-coded and someone forgot to update the directory? 

I've tried uninstalling the groovy compiler and then I installed the latest one, which is:

  Groovy Compiler 1.8 Feature 2.5.1.xx-20110615-1900-e36 org.codehaus.groovy18.feature.feature.group

But I get the same error when I try to run my code. How can I get Eclipse to recognize the new installed groovy compiler?

Bill
Reply | Threaded
Open this post in threaded view
|

Re: Trouble Eclipse-Groovy after updating to 2.5.1 plugin - can't find groovy-startup.conf

Andrew Eisenberg
You need to delete your old run configurations and recreate them
(alternatively, you can edit them by hand, but that's a bit painful).

This has been fixed in the dev builds and you should no longer need to
do this in future versions.  See here:
http://jira.codehaus.org/browse/GRECLIPSE-1055

On Thu, Jun 16, 2011 at 2:42 PM, Bill Wright <[hidden email]> wrote:

> Hi,
>
> I'm using the STS Eclipse version (3.6) and installed the Groovy 1.8 tools.
> Everything was working fine but then I was prompted to upgrade to  Groovy
> Compiler 1.8 Feature (2.5.1.xx...) and Groovy-Eclipse Feature (2.5.1.xx).
> The installed worked and I restarted Eclipse, but when I go to run my
> program, I get this error:
>
>
> exception while configuring main class loader:
> java.io.FileNotFoundException:
> /Users/bwright/springsource/sts-2.6.1.SR1/plugins/org.codehaus.groovy_1.8.0.xx-20110606-1400-e36/conf/groovy-starter.conf
> (No such file or directory)
>
> Under the plugin directory I have this sub-directory:
>
> org.codehaus.groovy_1.8.0.xx-20110608-1400-e36
>
> Note that it is searching for 20110606 but I have 20110608 installed. Why is
> it looking in a non-existent directory and how can I fix this? It seems like
> the upgrade might have had the directory named hard-coded and someone forgot
> to update the directory?
>
> I've tried uninstalling the groovy compiler and then I installed the latest
> one, which is:
>   Groovy Compiler 1.8 Feature 2.5.1.xx-20110615-1900-e36
> org.codehaus.groovy18.feature.feature.group
> But I get the same error when I try to run my code. How can I get Eclipse to
> recognize the new installed groovy compiler?
> Bill

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email