Unable to install Groovy plugin - eclipse indigo

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to install Groovy plugin - eclipse indigo

shwetank singh
Hi

I can really use some help here.
i've followed all instructions for installing Groovy plugin for Eclipse-Indigo but to no avail. would someone be able to point me to what i am doing wrong

here's what i did..
a) i have eclipse-jee-indigo-M6-win32
b) added update site http://dist.springsource.org/release/GRECLIPSE/e3.7/
c) added dependency m2e - http://download.eclipse.org/technology/m2e/releases

and got following:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Artifact not found: osgi.bundle,org.codehaus.groovy,1.7.10.xx-20111212-0900-e37-RELEASE.
http://dist.springsource.org/release/GRECLIPSE/e3.7/plugins/org.codehaus.groovy_1.7.10.xx-20111212-0900-e37-RELEASE.jar
Artifact not found: osgi.bundle,org.codehaus.groovy,1.8.4.xx-20111212-0900-e37-RELEASE.
http://dist.springsource.org/release/GRECLIPSE/e3.7/plugins/org.codehaus.groovy_1.8.4.xx-20111212-0900-e37-RELEASE.jar

alternatively, i downloaded the zip from http://dist.springsource.org/release/GRECLIPSE/e3.7/archive-2.6.0.xx-20111212-0900-e37-RELEASE.zip
and added features and plugins from this to my eclipse installation. this at least gave me the feature as it should but then i can't use it..creating a Groovy project this way also looks up for
org.codehaus.groovy_1.8.4.xx-20111212-0900-e37-RELEASE.jar which i don't have! (i can download it but am afraid it would lead to something else).

please point out how can i use just the update site and it gets me everything i need..surely i am a novice at this!
--
Shwetank
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install Groovy plugin - eclipse indigo

Andrew Eisenberg
Typically, you will get the collection error due to network problems
or a firewall.  I'd say it's likely you are behind some sort of
firewall.  If it is a personal firewall, you may need to turn it off.
I've even seen cases where anti-virus software will prevent your
eclipse install from completing.

Alternatively, you can install from the downloaded zip file.  Do not
unzip it or place it in the dropins directory.  Instead, you add the
archive file as an update site (the same way you add other update
sites Help -> Install new software -> Add...  And then click on
Archive...  Browse to the downloaded zip file and use that as the
update site to install.

On Tue, Feb 14, 2012 at 11:05 PM, shwetank singh
<[hidden email]> wrote:

> Hi
>
> I can really use some help here.
> i've followed all instructions for installing Groovy plugin for
> Eclipse-Indigo but to no avail. would someone be able to point me to what i
> am doing wrong
>
> here's what i did..
> a) i have eclipse-jee-indigo-M6-win32
> b) added update site http://dist.springsource.org/release/GRECLIPSE/e3.7/
> c) added dependency m2e -
> http://download.eclipse.org/technology/m2e/releases
>
> and got following:
>
> An error occurred while collecting items to be installed
> session context was:(profile=epp.package.jee,
> phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=,
> action=).
> Artifact not found:
> osgi.bundle,org.codehaus.groovy,1.7.10.xx-20111212-0900-e37-RELEASE.
> http://dist.springsource.org/release/GRECLIPSE/e3.7/plugins/org.codehaus.groovy_1.7.10.xx-20111212-0900-e37-RELEASE.jar
> Artifact not found:
> osgi.bundle,org.codehaus.groovy,1.8.4.xx-20111212-0900-e37-RELEASE.
> http://dist.springsource.org/release/GRECLIPSE/e3.7/plugins/org.codehaus.groovy_1.8.4.xx-20111212-0900-e37-RELEASE.jar
>
> alternatively, i downloaded the zip from
> http://dist.springsource.org/release/GRECLIPSE/e3.7/archive-2.6.0.xx-20111212-0900-e37-RELEASE.zip
> and added features and plugins from this to my eclipse installation. this at
> least gave me the feature as it should but then i can't use it..creating a
> Groovy project this way also looks up for
> org.codehaus.groovy_1.8.4.xx-20111212-0900-e37-RELEASE.jar which i don't
> have! (i can download it but am afraid it would lead to something else).
>
> please point out how can i use just the update site and it gets me
> everything i need..surely i am a novice at this!
> --
> Shwetank

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Unable to install Groovy plugin - eclipse indigo

shwetank singh
it worked just fine after i disabled the firewall..thanks Andrew..saved my day!

On Wed, Feb 15, 2012 at 9:53 PM, Andrew Eisenberg <[hidden email]> wrote:
Typically, you will get the collection error due to network problems
or a firewall.  I'd say it's likely you are behind some sort of
firewall.  If it is a personal firewall, you may need to turn it off.
I've even seen cases where anti-virus software will prevent your
eclipse install from completing.

Alternatively, you can install from the downloaded zip file.  Do not
unzip it or place it in the dropins directory.  Instead, you add the
archive file as an update site (the same way you add other update
sites Help -> Install new software -> Add...  And then click on
Archive...  Browse to the downloaded zip file and use that as the
update site to install.

On Tue, Feb 14, 2012 at 11:05 PM, shwetank singh
<[hidden email]> wrote:
> Hi
>
> I can really use some help here.
> i've followed all instructions for installing Groovy plugin for
> Eclipse-Indigo but to no avail. would someone be able to point me to what i
> am doing wrong
>
> here's what i did..
> a) i have eclipse-jee-indigo-M6-win32
> b) added update site http://dist.springsource.org/release/GRECLIPSE/e3.7/
> c) added dependency m2e -
> http://download.eclipse.org/technology/m2e/releases
>
> and got following:
>
> An error occurred while collecting items to be installed
> session context was:(profile=epp.package.jee,
> phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=,
> action=).
> Artifact not found:
> osgi.bundle,org.codehaus.groovy,1.7.10.xx-20111212-0900-e37-RELEASE.
> http://dist.springsource.org/release/GRECLIPSE/e3.7/plugins/org.codehaus.groovy_1.7.10.xx-20111212-0900-e37-RELEASE.jar
> Artifact not found:
> osgi.bundle,org.codehaus.groovy,1.8.4.xx-20111212-0900-e37-RELEASE.
> http://dist.springsource.org/release/GRECLIPSE/e3.7/plugins/org.codehaus.groovy_1.8.4.xx-20111212-0900-e37-RELEASE.jar
>
> alternatively, i downloaded the zip from
> http://dist.springsource.org/release/GRECLIPSE/e3.7/archive-2.6.0.xx-20111212-0900-e37-RELEASE.zip
> and added features and plugins from this to my eclipse installation. this at
> least gave me the feature as it should but then i can't use it..creating a
> Groovy project this way also looks up for
> org.codehaus.groovy_1.8.4.xx-20111212-0900-e37-RELEASE.jar which i don't
> have! (i can download it but am afraid it would lead to something else).
>
> please point out how can i use just the update site and it gets me
> everything i need..surely i am a novice at this!
> --
> Shwetank

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email





--
Shwetank