Urgent build problem !!!

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Urgent build problem !!!

Alex Pasechnik
Hi,

we have a groovy/java app that has built fine until just now:


here is our pom config


                <plugin>
                    <groupId>org.apache.maven.plugins</groupId>
                    <artifactId>maven-compiler-plugin</artifactId>
                    <version>2.3.2</version>
                    <configuration>
                        <source>1.6</source>
                        <target>1.6</target>
                        <compilerId>groovy-eclipse-compiler</compilerId>
                        <verbose>false</verbose>
                    </configuration>
                    <dependencies>
                        <dependency>
                            <groupId>org.codehaus.groovy</groupId>
                            <artifactId>groovy-eclipse-compiler</artifactId>
                            <version>2.7.0-01-SNAPSHOT</version>
                        </dependency>
                        <!-- <dependency>
                            <groupId>org.codehaus.groovy</groupId>
                            <artifactId>groovy-eclipse-batch</artifactId>
                            <version>1.8.6-01</version>
                        </dependency> -->
                    </dependencies>
                </plugin>


but we get this error on build...


[INFO] Deleting /Developer/dev/xxx/yyy/model/target
[debug] execute contextualize
[INFO] [resources:resources {execution: default-resources}]
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 2 resources
[INFO] [compiler:compile {execution: default-compile}]
[INFO] Using Groovy-Eclipse compiler to compile both Java and Groovy files
[FATAL ERROR] org.apache.maven.plugin.CompilerMojo#execute() caused a linkage error (java.lang.ExceptionInInitializerError) and may be out-of-date. Check the realms:
[FATAL ERROR] Plugin realm = app0.child-container[org.apache.maven.plugins:maven-compiler-plugin:2.3.2]
urls[0] = file:/Users/xxx/.m2/repository/org/apache/maven/plugins/maven-compiler-plugin/2.3.2/maven-compiler-plugin-2.3.2.jar
urls[1] = file:/Users/xxx/.m2/repository/org/codehaus/groovy/groovy-eclipse-compiler/2.7.0-01/groovy-eclipse-compiler-2.7.0-01.jar
urls[2] = file:/Users/xxx/.m2/repository/org/codehaus/groovy/groovy-eclipse-batch/2.0.4-01/groovy-eclipse-batch-2.0.4-01.jar
urls[3] = file:/Users/xxx/.m2/repository/org/codehaus/plexus/plexus-compiler-api/1.8.1/plexus-compiler-api-1.8.1.jar
urls[4] = file:/Users/xxx/.m2/repository/org/codehaus/plexus/plexus-utils/2.0.5/plexus-utils-2.0.5.jar
urls[5] = file:/Users/xxx/.m2/repository/org/codehaus/plexus/plexus-compiler-manager/1.8.1/plexus-compiler-manager-1.8.1.jar
urls[6] = file:/Users/xxx/.m2/repository/org/codehaus/plexus/plexus-compiler-javac/1.8.1/plexus-compiler-javac-1.8.1.jar
[FATAL ERROR] Container realm = plexus.core
urls[0] = file:/Developer/tools/apache-maven-2.2.1/lib/maven-2.2.1-uber.jar
[INFO] ------------------------------------------------------------------------
[ERROR] FATAL ERROR
[INFO] ------------------------------------------------------------------------
[INFO] null
[INFO] ------------------------------------------------------------------------
[INFO] Trace
java.lang.ExceptionInInitializerError
    at org.codehaus.jdt.groovy.integration.internal.GroovyLanguageSupport.getParser(GroovyLanguageSupport.java:86)
    at org.codehaus.jdt.groovy.integration.LanguageSupportFactory.getParser(LanguageSupportFactory.java:48)
    at org.eclipse.jdt.internal.compiler.Compiler.initializeParser(Compiler.java:743)
    at org.eclipse.jdt.internal.compiler.Compiler.<init>(Compiler.java:297)
    at org.eclipse.jdt.internal.compiler.batch.Main.performCompilation(Main.java:3891)
    at org.eclipse.jdt.internal.compiler.batch.Main.compile(Main.java:1684)
    at org.
---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Urgent build problem !!!

Andrew Eisenberg
Set a hard dependency on the groovy-eclipse-batch v 2.0.0-01 in your
maven-compiler-plugin.  The most recent groovy-eclipse-batch I pushed
is somehow broken.  I'll be taking a look at this tomorrow.

On Sun, Sep 30, 2012 at 1:01 PM, Alex Pasechnik
<[hidden email]> wrote:

> Hi,
>
> we have a groovy/java app that has built fine until just now:
>
>
> here is our pom config
>
>
>                 <plugin>
>                     <groupId>org.apache.maven.plugins</groupId>
>                     <artifactId>maven-compiler-plugin</artifactId>
>                     <version>2.3.2</version>
>                     <configuration>
>                         <source>1.6</source>
>                         <target>1.6</target>
>                         <compilerId>groovy-eclipse-compiler</compilerId>
>                         <verbose>false</verbose>
>                     </configuration>
>                     <dependencies>
>                         <dependency>
>                             <groupId>org.codehaus.groovy</groupId>
>                             <artifactId>groovy-eclipse-compiler</artifactId>
>                             <version>2.7.0-01-SNAPSHOT</version>
>                         </dependency>
>                         <!-- <dependency>
>                             <groupId>org.codehaus.groovy</groupId>
>                             <artifactId>groovy-eclipse-batch</artifactId>
>                             <version>1.8.6-01</version>
>                         </dependency> -->
>                     </dependencies>
>                 </plugin>
>
>
> but we get this error on build...
>
>
> [INFO] Deleting /Developer/dev/xxx/yyy/model/target
> [debug] execute contextualize
> [INFO] [resources:resources {execution: default-resources}]
> [INFO] Using 'UTF-8' encoding to copy filtered resources.
> [INFO] Copying 2 resources
> [INFO] [compiler:compile {execution: default-compile}]
> [INFO] Using Groovy-Eclipse compiler to compile both Java and Groovy files
> [FATAL ERROR] org.apache.maven.plugin.CompilerMojo#execute() caused a linkage error (java.lang.ExceptionInInitializerError) and may be out-of-date. Check the realms:
> [FATAL ERROR] Plugin realm = app0.child-container[org.apache.maven.plugins:maven-compiler-plugin:2.3.2]
> urls[0] = file:/Users/xxx/.m2/repository/org/apache/maven/plugins/maven-compiler-plugin/2.3.2/maven-compiler-plugin-2.3.2.jar
> urls[1] = file:/Users/xxx/.m2/repository/org/codehaus/groovy/groovy-eclipse-compiler/2.7.0-01/groovy-eclipse-compiler-2.7.0-01.jar
> urls[2] = file:/Users/xxx/.m2/repository/org/codehaus/groovy/groovy-eclipse-batch/2.0.4-01/groovy-eclipse-batch-2.0.4-01.jar
> urls[3] = file:/Users/xxx/.m2/repository/org/codehaus/plexus/plexus-compiler-api/1.8.1/plexus-compiler-api-1.8.1.jar
> urls[4] = file:/Users/xxx/.m2/repository/org/codehaus/plexus/plexus-utils/2.0.5/plexus-utils-2.0.5.jar
> urls[5] = file:/Users/xxx/.m2/repository/org/codehaus/plexus/plexus-compiler-manager/1.8.1/plexus-compiler-manager-1.8.1.jar
> urls[6] = file:/Users/xxx/.m2/repository/org/codehaus/plexus/plexus-compiler-javac/1.8.1/plexus-compiler-javac-1.8.1.jar
> [FATAL ERROR] Container realm = plexus.core
> urls[0] = file:/Developer/tools/apache-maven-2.2.1/lib/maven-2.2.1-uber.jar
> [INFO] ------------------------------------------------------------------------
> [ERROR] FATAL ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] null
> [INFO] ------------------------------------------------------------------------
> [INFO] Trace
> java.lang.ExceptionInInitializerError
>     at org.codehaus.jdt.groovy.integration.internal.GroovyLanguageSupport.getParser(GroovyLanguageSupport.java:86)
>     at org.codehaus.jdt.groovy.integration.LanguageSupportFactory.getParser(LanguageSupportFactory.java:48)
>     at org.eclipse.jdt.internal.compiler.Compiler.initializeParser(Compiler.java:743)
>     at org.eclipse.jdt.internal.compiler.Compiler.<init>(Compiler.java:297)
>     at org.eclipse.jdt.internal.compiler.batch.Main.performCompilation(Main.java:3891)
>     at org.eclipse.jdt.internal.compiler.batch.Main.compile(Main.java:1684)
>     at org.
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email