Version conflict with Gradle and Groovy

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Version conflict with Gradle and Groovy

KARR, DAVID
I posted a SO question about this: http://stackoverflow.com/questions/28882642/groovy-version-mismatch-running-spock-test-in-gradle-project-in-eclipse 

I have a Gradle and Groovy project in Eclipse Kepler.  I want to run a Spock unit test.  The Gradle plugin is loading version 2.3.9 of groovy-all, and the Groovy plugin is loading version 2.3.10.  I get complaints like "Conflicting module versions. Module [groovy-all is loaded in version 2.3.9 and you are trying to load version 2.3.10".  I've tried modifying the order of the dependencies in the "Order and export" tab, but that just reverses the versions specified in the error message.  I see no way to make them use the same version, or if that's even safe to do.

What are my options here?

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Loading...