conflicting installs, but i can't figure out how to get rid of the old

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

conflicting installs, but i can't figure out how to get rid of the old

Joe Greenawalt
Hi, I get the below error, but I removed the pre-existing installation I believe both through eclipse software manager (about eclipse -> installation details) and deleting the anything groovy inside plugins.
My assumption is that eclipse thinks M1 is still installed and can't install RC4?  If correct, any suggestions on how to get around this?

Thanks,


Eclipse 3.5, Mac OS X Snow Leopard.
____________________________
Cannot complete the install because of a conflicting dependency.
  Software being installed: Groovy-Eclipse Feature 2.0.0.xx-20100106-0900-e35-RC4 (org.codehaus.groovy.eclipse.feature.feature.group 2.0.0.xx-20100106-0900-e35-RC4)
  Only one of the following can be installed at once:
    JDT Core patch for Groovy-Eclipse plugin 2.0.0.xx-20100106-0900-e35-RC4 (org.codehaus.groovy.jdt.patch.feature.jar 2.0.0.xx-20100106-0900-e35-RC4)
    JDT Core patch for Groovy-Eclipse plugin 2.0.0.xx-20091019-1600-M1-e35 (org.codehaus.groovy.jdt.patch.feature.jar 2.0.0.xx-20091019-1600-M1-e35)
  Only one of the following can be installed at once:
    Java Development Tools Core 3.5.1.xx-20100106-0900-e35-RC4 (org.eclipse.jdt.core 3.5.1.xx-20100106-0900-e35-RC4)
    Java Development Tools Core 3.5.1.xx-20091019-1600-M1-e35 (org.eclipse.jdt.core 3.5.1.xx-20091019-1600-M1-e35)
    Java Development Tools Core 3.5.1.v_972_R35x (org.eclipse.jdt.core 3.5.1.v_972_R35x)
    Java Development Tools Core 3.5.0.v_963 (org.eclipse.jdt.core 3.5.0.v_963)
  Cannot satisfy dependency:
    From: Groovy-Eclipse Feature 2.0.0.xx-20100106-0900-e35-RC4 (org.codehaus.groovy.eclipse.feature.feature.group 2.0.0.xx-20100106-0900-e35-RC4)
    To: org.codehaus.groovy.jdt.patch.feature.group [2.0.0.xx-20100106-0900-e35-RC4]
  Cannot satisfy dependency:
    From: JDT Core patch for Groovy-Eclipse plugin 2.0.0.xx-20091019-1600-M1-e35 (org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20091019-1600-M1-e35)
    To: org.codehaus.groovy.jdt.patch.feature.jar [2.0.0.xx-20091019-1600-M1-e35]
  Cannot satisfy dependency:
    From: JDT Core patch for Groovy-Eclipse plugin 2.0.0.xx-20100106-0900-e35-RC4 (org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20100106-0900-e35-RC4)
    To: org.codehaus.groovy.jdt.patch.feature.jar [2.0.0.xx-20100106-0900-e35-RC4]
  Cannot satisfy dependency:
    From: JDT Core patch for Groovy-Eclipse plugin 2.0.0.xx-20100106-0900-e35-RC4 (org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20100106-0900-e35-RC4)
    To: org.eclipse.jdt.feature.group [3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1,3.5.2)
  Cannot satisfy dependency:
    From: Eclipse Java Development Tools 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1 (org.eclipse.jdt.feature.group 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1)
    To: org.eclipse.jdt.core [3.5.0.v_963]
  Cannot satisfy dependency:
    From: Eclipse Java Development Tools 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ (org.eclipse.jdt.feature.group 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ)
    To: org.eclipse.jdt.core [3.5.1.v_972_R35x]
  Cannot satisfy dependency:
    From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20100106-0900-e35-RC4 Eclipse Java Development Tools 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1 (org.eclipse.jdt.feature.group 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1)
    To: org.eclipse.jdt.core [3.5.1.xx-20100106-0900-e35-RC4]
  Cannot satisfy dependency:
    From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20100106-0900-e35-RC4 Eclipse Java Development Tools 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ (org.eclipse.jdt.feature.group 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ)
    To: org.eclipse.jdt.core [3.5.1.xx-20100106-0900-e35-RC4]
Reply | Threaded
Open this post in threaded view
|

Re: conflicting installs, but i can't figure out how to get rid of the old

Andrew Eisenberg
Yes, it does look like the p2 installer still thinks M1 is installed.
Can you try to revert your installation?

About Eclipse -> Installation Details -> Installation History

And choose the appropriate date.  If this doesn't work for you, there
are a few more things we can try, but they would be getting a bit
kludgy.  And they may hose your installation.  So, let me know if this
works for you.

--a

On Sun, Jan 10, 2010 at 8:57 AM, Joe Greenawalt
<[hidden email]> wrote:

> Hi, I get the below error, but I removed the pre-existing installation I
> believe both through eclipse software manager (about eclipse -> installation
> details) and deleting the anything groovy inside plugins.
> My assumption is that eclipse thinks M1 is still installed and can't install
> RC4?  If correct, any suggestions on how to get around this?
>
> Thanks,
>
>
> Eclipse 3.5, Mac OS X Snow Leopard.
> ____________________________
> Cannot complete the install because of a conflicting dependency.
>   Software being installed: Groovy-Eclipse Feature
> 2.0.0.xx-20100106-0900-e35-RC4
> (org.codehaus.groovy.eclipse.feature.feature.group
> 2.0.0.xx-20100106-0900-e35-RC4)
>   Only one of the following can be installed at once:
>     JDT Core patch for Groovy-Eclipse plugin 2.0.0.xx-20100106-0900-e35-RC4
> (org.codehaus.groovy.jdt.patch.feature.jar 2.0.0.xx-20100106-0900-e35-RC4)
>     JDT Core patch for Groovy-Eclipse plugin 2.0.0.xx-20091019-1600-M1-e35
> (org.codehaus.groovy.jdt.patch.feature.jar 2.0.0.xx-20091019-1600-M1-e35)
>   Only one of the following can be installed at once:
>     Java Development Tools Core 3.5.1.xx-20100106-0900-e35-RC4
> (org.eclipse.jdt.core 3.5.1.xx-20100106-0900-e35-RC4)
>     Java Development Tools Core 3.5.1.xx-20091019-1600-M1-e35
> (org.eclipse.jdt.core 3.5.1.xx-20091019-1600-M1-e35)
>     Java Development Tools Core 3.5.1.v_972_R35x (org.eclipse.jdt.core
> 3.5.1.v_972_R35x)
>     Java Development Tools Core 3.5.0.v_963 (org.eclipse.jdt.core
> 3.5.0.v_963)
>   Cannot satisfy dependency:
>     From: Groovy-Eclipse Feature 2.0.0.xx-20100106-0900-e35-RC4
> (org.codehaus.groovy.eclipse.feature.feature.group
> 2.0.0.xx-20100106-0900-e35-RC4)
>     To: org.codehaus.groovy.jdt.patch.feature.group
> [2.0.0.xx-20100106-0900-e35-RC4]
>   Cannot satisfy dependency:
>     From: JDT Core patch for Groovy-Eclipse plugin
> 2.0.0.xx-20091019-1600-M1-e35 (org.codehaus.groovy.jdt.patch.feature.group
> 2.0.0.xx-20091019-1600-M1-e35)
>     To: org.codehaus.groovy.jdt.patch.feature.jar
> [2.0.0.xx-20091019-1600-M1-e35]
>   Cannot satisfy dependency:
>     From: JDT Core patch for Groovy-Eclipse plugin
> 2.0.0.xx-20100106-0900-e35-RC4 (org.codehaus.groovy.jdt.patch.feature.group
> 2.0.0.xx-20100106-0900-e35-RC4)
>     To: org.codehaus.groovy.jdt.patch.feature.jar
> [2.0.0.xx-20100106-0900-e35-RC4]
>   Cannot satisfy dependency:
>     From: JDT Core patch for Groovy-Eclipse plugin
> 2.0.0.xx-20100106-0900-e35-RC4 (org.codehaus.groovy.jdt.patch.feature.group
> 2.0.0.xx-20100106-0900-e35-RC4)
>     To: org.eclipse.jdt.feature.group
> [3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1,3.5.2)
>   Cannot satisfy dependency:
>     From: Eclipse Java Development Tools
> 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1 (org.eclipse.jdt.feature.group
> 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1)
>     To: org.eclipse.jdt.core [3.5.0.v_963]
>   Cannot satisfy dependency:
>     From: Eclipse Java Development Tools
> 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ
> (org.eclipse.jdt.feature.group
> 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ)
>     To: org.eclipse.jdt.core [3.5.1.v_972_R35x]
>   Cannot satisfy dependency:
>     From Patch: org.codehaus.groovy.jdt.patch.feature.group
> 2.0.0.xx-20100106-0900-e35-RC4 Eclipse Java Development Tools
> 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1 (org.eclipse.jdt.feature.group
> 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1)
>     To: org.eclipse.jdt.core [3.5.1.xx-20100106-0900-e35-RC4]
>   Cannot satisfy dependency:
>     From Patch: org.codehaus.groovy.jdt.patch.feature.group
> 2.0.0.xx-20100106-0900-e35-RC4 Eclipse Java Development Tools
> 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ
> (org.eclipse.jdt.feature.group
> 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ)
>     To: org.eclipse.jdt.core [3.5.1.xx-20100106-0900-e35-RC4]
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: conflicting installs, but i can't figure out how to get rid of the old

Joe Greenawalt
Andrew, thanks for the tips.  I played around a little bit, and just decided to reinstall eclipse, i have it working now.  Do you know what the upgrade is going to involve going forward after "final" is released?  New link, uninstall reinstall, etc..

Thanks.

On Sun, Jan 10, 2010 at 11:46 PM, Andrew Eisenberg <[hidden email]> wrote:
Yes, it does look like the p2 installer still thinks M1 is installed.
Can you try to revert your installation?

About Eclipse -> Installation Details -> Installation History

And choose the appropriate date.  If this doesn't work for you, there
are a few more things we can try, but they would be getting a bit
kludgy.  And they may hose your installation.  So, let me know if this
works for you.

--a

On Sun, Jan 10, 2010 at 8:57 AM, Joe Greenawalt
<[hidden email]> wrote:
> Hi, I get the below error, but I removed the pre-existing installation I
> believe both through eclipse software manager (about eclipse -> installation
> details) and deleting the anything groovy inside plugins.
> My assumption is that eclipse thinks M1 is still installed and can't install
> RC4?  If correct, any suggestions on how to get around this?
>
> Thanks,
>
>
> Eclipse 3.5, Mac OS X Snow Leopard.
> ____________________________
> Cannot complete the install because of a conflicting dependency.
>   Software being installed: Groovy-Eclipse Feature
> 2.0.0.xx-20100106-0900-e35-RC4
> (org.codehaus.groovy.eclipse.feature.feature.group
> 2.0.0.xx-20100106-0900-e35-RC4)
>   Only one of the following can be installed at once:
>     JDT Core patch for Groovy-Eclipse plugin 2.0.0.xx-20100106-0900-e35-RC4
> (org.codehaus.groovy.jdt.patch.feature.jar 2.0.0.xx-20100106-0900-e35-RC4)
>     JDT Core patch for Groovy-Eclipse plugin 2.0.0.xx-20091019-1600-M1-e35
> (org.codehaus.groovy.jdt.patch.feature.jar 2.0.0.xx-20091019-1600-M1-e35)
>   Only one of the following can be installed at once:
>     Java Development Tools Core 3.5.1.xx-20100106-0900-e35-RC4
> (org.eclipse.jdt.core 3.5.1.xx-20100106-0900-e35-RC4)
>     Java Development Tools Core 3.5.1.xx-20091019-1600-M1-e35
> (org.eclipse.jdt.core 3.5.1.xx-20091019-1600-M1-e35)
>     Java Development Tools Core 3.5.1.v_972_R35x (org.eclipse.jdt.core
> 3.5.1.v_972_R35x)
>     Java Development Tools Core 3.5.0.v_963 (org.eclipse.jdt.core
> 3.5.0.v_963)
>   Cannot satisfy dependency:
>     From: Groovy-Eclipse Feature 2.0.0.xx-20100106-0900-e35-RC4
> (org.codehaus.groovy.eclipse.feature.feature.group
> 2.0.0.xx-20100106-0900-e35-RC4)
>     To: org.codehaus.groovy.jdt.patch.feature.group
> [2.0.0.xx-20100106-0900-e35-RC4]
>   Cannot satisfy dependency:
>     From: JDT Core patch for Groovy-Eclipse plugin
> 2.0.0.xx-20091019-1600-M1-e35 (org.codehaus.groovy.jdt.patch.feature.group
> 2.0.0.xx-20091019-1600-M1-e35)
>     To: org.codehaus.groovy.jdt.patch.feature.jar
> [2.0.0.xx-20091019-1600-M1-e35]
>   Cannot satisfy dependency:
>     From: JDT Core patch for Groovy-Eclipse plugin
> 2.0.0.xx-20100106-0900-e35-RC4 (org.codehaus.groovy.jdt.patch.feature.group
> 2.0.0.xx-20100106-0900-e35-RC4)
>     To: org.codehaus.groovy.jdt.patch.feature.jar
> [2.0.0.xx-20100106-0900-e35-RC4]
>   Cannot satisfy dependency:
>     From: JDT Core patch for Groovy-Eclipse plugin
> 2.0.0.xx-20100106-0900-e35-RC4 (org.codehaus.groovy.jdt.patch.feature.group
> 2.0.0.xx-20100106-0900-e35-RC4)
>     To: org.eclipse.jdt.feature.group
> [3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1,3.5.2)
>   Cannot satisfy dependency:
>     From: Eclipse Java Development Tools
> 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1 (org.eclipse.jdt.feature.group
> 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1)
>     To: org.eclipse.jdt.core [3.5.0.v_963]
>   Cannot satisfy dependency:
>     From: Eclipse Java Development Tools
> 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ
> (org.eclipse.jdt.feature.group
> 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ)
>     To: org.eclipse.jdt.core [3.5.1.v_972_R35x]
>   Cannot satisfy dependency:
>     From Patch: org.codehaus.groovy.jdt.patch.feature.group
> 2.0.0.xx-20100106-0900-e35-RC4 Eclipse Java Development Tools
> 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1 (org.eclipse.jdt.feature.group
> 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1)
>     To: org.eclipse.jdt.core [3.5.1.xx-20100106-0900-e35-RC4]
>   Cannot satisfy dependency:
>     From Patch: org.codehaus.groovy.jdt.patch.feature.group
> 2.0.0.xx-20100106-0900-e35-RC4 Eclipse Java Development Tools
> 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ
> (org.eclipse.jdt.feature.group
> 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ)
>     To: org.eclipse.jdt.core [3.5.1.xx-20100106-0900-e35-RC4]
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: conflicting installs, but i can't figure out how to get rid of the old

Andrew Eisenberg
I'm not sure what caused your initial install problem, but I do not
expect that there should be any problems going forward with upgrades.
If you do experience a problem, it is definitely a bug and please
report it.  It would be helpful if you could keep an eye on your error
log in that case.

On Mon, Jan 11, 2010 at 8:49 AM, Joe Greenawalt
<[hidden email]> wrote:

> Andrew, thanks for the tips.  I played around a little bit, and just decided
> to reinstall eclipse, i have it working now.  Do you know what the upgrade
> is going to involve going forward after "final" is released?  New link,
> uninstall reinstall, etc..
>
> Thanks.
>
> On Sun, Jan 10, 2010 at 11:46 PM, Andrew Eisenberg <[hidden email]>
> wrote:
>>
>> Yes, it does look like the p2 installer still thinks M1 is installed.
>> Can you try to revert your installation?
>>
>> About Eclipse -> Installation Details -> Installation History
>>
>> And choose the appropriate date.  If this doesn't work for you, there
>> are a few more things we can try, but they would be getting a bit
>> kludgy.  And they may hose your installation.  So, let me know if this
>> works for you.
>>
>> --a
>>
>> On Sun, Jan 10, 2010 at 8:57 AM, Joe Greenawalt
>> <[hidden email]> wrote:
>> > Hi, I get the below error, but I removed the pre-existing installation I
>> > believe both through eclipse software manager (about eclipse ->
>> > installation
>> > details) and deleting the anything groovy inside plugins.
>> > My assumption is that eclipse thinks M1 is still installed and can't
>> > install
>> > RC4?  If correct, any suggestions on how to get around this?
>> >
>> > Thanks,
>> >
>> >
>> > Eclipse 3.5, Mac OS X Snow Leopard.
>> > ____________________________
>> > Cannot complete the install because of a conflicting dependency.
>> >   Software being installed: Groovy-Eclipse Feature
>> > 2.0.0.xx-20100106-0900-e35-RC4
>> > (org.codehaus.groovy.eclipse.feature.feature.group
>> > 2.0.0.xx-20100106-0900-e35-RC4)
>> >   Only one of the following can be installed at once:
>> >     JDT Core patch for Groovy-Eclipse plugin
>> > 2.0.0.xx-20100106-0900-e35-RC4
>> > (org.codehaus.groovy.jdt.patch.feature.jar
>> > 2.0.0.xx-20100106-0900-e35-RC4)
>> >     JDT Core patch for Groovy-Eclipse plugin
>> > 2.0.0.xx-20091019-1600-M1-e35
>> > (org.codehaus.groovy.jdt.patch.feature.jar
>> > 2.0.0.xx-20091019-1600-M1-e35)
>> >   Only one of the following can be installed at once:
>> >     Java Development Tools Core 3.5.1.xx-20100106-0900-e35-RC4
>> > (org.eclipse.jdt.core 3.5.1.xx-20100106-0900-e35-RC4)
>> >     Java Development Tools Core 3.5.1.xx-20091019-1600-M1-e35
>> > (org.eclipse.jdt.core 3.5.1.xx-20091019-1600-M1-e35)
>> >     Java Development Tools Core 3.5.1.v_972_R35x (org.eclipse.jdt.core
>> > 3.5.1.v_972_R35x)
>> >     Java Development Tools Core 3.5.0.v_963 (org.eclipse.jdt.core
>> > 3.5.0.v_963)
>> >   Cannot satisfy dependency:
>> >     From: Groovy-Eclipse Feature 2.0.0.xx-20100106-0900-e35-RC4
>> > (org.codehaus.groovy.eclipse.feature.feature.group
>> > 2.0.0.xx-20100106-0900-e35-RC4)
>> >     To: org.codehaus.groovy.jdt.patch.feature.group
>> > [2.0.0.xx-20100106-0900-e35-RC4]
>> >   Cannot satisfy dependency:
>> >     From: JDT Core patch for Groovy-Eclipse plugin
>> > 2.0.0.xx-20091019-1600-M1-e35
>> > (org.codehaus.groovy.jdt.patch.feature.group
>> > 2.0.0.xx-20091019-1600-M1-e35)
>> >     To: org.codehaus.groovy.jdt.patch.feature.jar
>> > [2.0.0.xx-20091019-1600-M1-e35]
>> >   Cannot satisfy dependency:
>> >     From: JDT Core patch for Groovy-Eclipse plugin
>> > 2.0.0.xx-20100106-0900-e35-RC4
>> > (org.codehaus.groovy.jdt.patch.feature.group
>> > 2.0.0.xx-20100106-0900-e35-RC4)
>> >     To: org.codehaus.groovy.jdt.patch.feature.jar
>> > [2.0.0.xx-20100106-0900-e35-RC4]
>> >   Cannot satisfy dependency:
>> >     From: JDT Core patch for Groovy-Eclipse plugin
>> > 2.0.0.xx-20100106-0900-e35-RC4
>> > (org.codehaus.groovy.jdt.patch.feature.group
>> > 2.0.0.xx-20100106-0900-e35-RC4)
>> >     To: org.eclipse.jdt.feature.group
>> > [3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1,3.5.2)
>> >   Cannot satisfy dependency:
>> >     From: Eclipse Java Development Tools
>> > 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1
>> > (org.eclipse.jdt.feature.group
>> > 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1)
>> >     To: org.eclipse.jdt.core [3.5.0.v_963]
>> >   Cannot satisfy dependency:
>> >     From: Eclipse Java Development Tools
>> > 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ
>> > (org.eclipse.jdt.feature.group
>> > 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ)
>> >     To: org.eclipse.jdt.core [3.5.1.v_972_R35x]
>> >   Cannot satisfy dependency:
>> >     From Patch: org.codehaus.groovy.jdt.patch.feature.group
>> > 2.0.0.xx-20100106-0900-e35-RC4 Eclipse Java Development Tools
>> > 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1
>> > (org.eclipse.jdt.feature.group
>> > 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1)
>> >     To: org.eclipse.jdt.core [3.5.1.xx-20100106-0900-e35-RC4]
>> >   Cannot satisfy dependency:
>> >     From Patch: org.codehaus.groovy.jdt.patch.feature.group
>> > 2.0.0.xx-20100106-0900-e35-RC4 Eclipse Java Development Tools
>> > 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ
>> > (org.eclipse.jdt.feature.group
>> > 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ)
>> >     To: org.eclipse.jdt.core [3.5.1.xx-20100106-0900-e35-RC4]
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: conflicting installs, but i can't figure out how to get rid of the old

Joe Greenawalt
will do, thanks.

On Mon, Jan 11, 2010 at 1:36 PM, Andrew Eisenberg <[hidden email]> wrote:
I'm not sure what caused your initial install problem, but I do not
expect that there should be any problems going forward with upgrades.
If you do experience a problem, it is definitely a bug and please
report it.  It would be helpful if you could keep an eye on your error
log in that case.

On Mon, Jan 11, 2010 at 8:49 AM, Joe Greenawalt
<[hidden email]> wrote:
> Andrew, thanks for the tips.  I played around a little bit, and just decided
> to reinstall eclipse, i have it working now.  Do you know what the upgrade
> is going to involve going forward after "final" is released?  New link,
> uninstall reinstall, etc..
>
> Thanks.
>
> On Sun, Jan 10, 2010 at 11:46 PM, Andrew Eisenberg <[hidden email]>
> wrote:
>>
>> Yes, it does look like the p2 installer still thinks M1 is installed.
>> Can you try to revert your installation?
>>
>> About Eclipse -> Installation Details -> Installation History
>>
>> And choose the appropriate date.  If this doesn't work for you, there
>> are a few more things we can try, but they would be getting a bit
>> kludgy.  And they may hose your installation.  So, let me know if this
>> works for you.
>>
>> --a
>>
>> On Sun, Jan 10, 2010 at 8:57 AM, Joe Greenawalt
>> <[hidden email]> wrote:
>> > Hi, I get the below error, but I removed the pre-existing installation I
>> > believe both through eclipse software manager (about eclipse ->
>> > installation
>> > details) and deleting the anything groovy inside plugins.
>> > My assumption is that eclipse thinks M1 is still installed and can't
>> > install
>> > RC4?  If correct, any suggestions on how to get around this?
>> >
>> > Thanks,
>> >
>> >
>> > Eclipse 3.5, Mac OS X Snow Leopard.
>> > ____________________________
>> > Cannot complete the install because of a conflicting dependency.
>> >   Software being installed: Groovy-Eclipse Feature
>> > 2.0.0.xx-20100106-0900-e35-RC4
>> > (org.codehaus.groovy.eclipse.feature.feature.group
>> > 2.0.0.xx-20100106-0900-e35-RC4)
>> >   Only one of the following can be installed at once:
>> >     JDT Core patch for Groovy-Eclipse plugin
>> > 2.0.0.xx-20100106-0900-e35-RC4
>> > (org.codehaus.groovy.jdt.patch.feature.jar
>> > 2.0.0.xx-20100106-0900-e35-RC4)
>> >     JDT Core patch for Groovy-Eclipse plugin
>> > 2.0.0.xx-20091019-1600-M1-e35
>> > (org.codehaus.groovy.jdt.patch.feature.jar
>> > 2.0.0.xx-20091019-1600-M1-e35)
>> >   Only one of the following can be installed at once:
>> >     Java Development Tools Core 3.5.1.xx-20100106-0900-e35-RC4
>> > (org.eclipse.jdt.core 3.5.1.xx-20100106-0900-e35-RC4)
>> >     Java Development Tools Core 3.5.1.xx-20091019-1600-M1-e35
>> > (org.eclipse.jdt.core 3.5.1.xx-20091019-1600-M1-e35)
>> >     Java Development Tools Core 3.5.1.v_972_R35x (org.eclipse.jdt.core
>> > 3.5.1.v_972_R35x)
>> >     Java Development Tools Core 3.5.0.v_963 (org.eclipse.jdt.core
>> > 3.5.0.v_963)
>> >   Cannot satisfy dependency:
>> >     From: Groovy-Eclipse Feature 2.0.0.xx-20100106-0900-e35-RC4
>> > (org.codehaus.groovy.eclipse.feature.feature.group
>> > 2.0.0.xx-20100106-0900-e35-RC4)
>> >     To: org.codehaus.groovy.jdt.patch.feature.group
>> > [2.0.0.xx-20100106-0900-e35-RC4]
>> >   Cannot satisfy dependency:
>> >     From: JDT Core patch for Groovy-Eclipse plugin
>> > 2.0.0.xx-20091019-1600-M1-e35
>> > (org.codehaus.groovy.jdt.patch.feature.group
>> > 2.0.0.xx-20091019-1600-M1-e35)
>> >     To: org.codehaus.groovy.jdt.patch.feature.jar
>> > [2.0.0.xx-20091019-1600-M1-e35]
>> >   Cannot satisfy dependency:
>> >     From: JDT Core patch for Groovy-Eclipse plugin
>> > 2.0.0.xx-20100106-0900-e35-RC4
>> > (org.codehaus.groovy.jdt.patch.feature.group
>> > 2.0.0.xx-20100106-0900-e35-RC4)
>> >     To: org.codehaus.groovy.jdt.patch.feature.jar
>> > [2.0.0.xx-20100106-0900-e35-RC4]
>> >   Cannot satisfy dependency:
>> >     From: JDT Core patch for Groovy-Eclipse plugin
>> > 2.0.0.xx-20100106-0900-e35-RC4
>> > (org.codehaus.groovy.jdt.patch.feature.group
>> > 2.0.0.xx-20100106-0900-e35-RC4)
>> >     To: org.eclipse.jdt.feature.group
>> > [3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1,3.5.2)
>> >   Cannot satisfy dependency:
>> >     From: Eclipse Java Development Tools
>> > 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1
>> > (org.eclipse.jdt.feature.group
>> > 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1)
>> >     To: org.eclipse.jdt.core [3.5.0.v_963]
>> >   Cannot satisfy dependency:
>> >     From: Eclipse Java Development Tools
>> > 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ
>> > (org.eclipse.jdt.feature.group
>> > 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ)
>> >     To: org.eclipse.jdt.core [3.5.1.v_972_R35x]
>> >   Cannot satisfy dependency:
>> >     From Patch: org.codehaus.groovy.jdt.patch.feature.group
>> > 2.0.0.xx-20100106-0900-e35-RC4 Eclipse Java Development Tools
>> > 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1
>> > (org.eclipse.jdt.feature.group
>> > 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1)
>> >     To: org.eclipse.jdt.core [3.5.1.xx-20100106-0900-e35-RC4]
>> >   Cannot satisfy dependency:
>> >     From Patch: org.codehaus.groovy.jdt.patch.feature.group
>> > 2.0.0.xx-20100106-0900-e35-RC4 Eclipse Java Development Tools
>> > 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ
>> > (org.eclipse.jdt.feature.group
>> > 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ)
>> >     To: org.eclipse.jdt.core [3.5.1.xx-20100106-0900-e35-RC4]
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email