eclipse 3.4 plugin

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

eclipse 3.4 plugin

Garner, Shawn

I am try to write a spock specification and it seems like my .groovy is compiling into a *.class.

However when I open a .groovy file with the groovy editor it is giving me validation errors like it is validating a java file.

It’s telling me def cannot be resolved to a type and the type is Java Problem

It’s also telling me that I need a semi-colon which tells me it does not seeing the source as a groovy file even though it is compiling it fine.

I don’t have the option of upgrading to a newer version of eclipse (wouldn’t that be nice).

I checked and the project is of groovy nature.

 

I appreciate any help.

 

Shawn


-----Message Disclaimer-----

This e-mail message is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and exempt from disclosure under applicable law. If you are not the intended recipient, any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify us immediately by reply email to [hidden email] and delete or destroy all copies of the original message and attachments thereto. Email sent to or from the Principal Financial Group or any of its member companies may be retained as required by law or regulation.

Nothing in this message is intended to constitute an Electronic signature for purposes of the Uniform Electronic Transactions Act (UETA) or the Electronic Signatures in Global and National Commerce Act ("E-Sign") unless a specific statement to the contrary is included in this message.

While this communication may be used to promote or market a transaction or an idea that is discussed in the publication, it is intended to provide general information about the subject matter covered and is provided with the understanding that The Principal is not rendering legal, accounting, or tax advice. It is not a marketed opinion and may not be used to avoid penalties under the Internal Revenue Code. You should consult with appropriate counsel or other advisors on all matters pertaining to legal, tax, or accounting obligations and requirements.





	
	
	
	
Reply | Threaded
Open this post in threaded view
|

Re: eclipse 3.4 plugin

Andrew Eisenberg
What version of the plugin are you using?  Also, what version of
Groovy are you using?

Are you using the version from this update site:
http://ci.repository.codehaus.org/greclipse/snapshot/e34/

Only groovy 1.7 is supported for Eclipse 3.4.  And it can only install
into Eclipse 3.4.2.  It looks as if the JDT patch is not being
properly picked up by your Eclipse installation.  One of the reasons
why we had to drop support for Eclipse 3.4 is that there wasn't very
good support for feature patches (which is how we implemented our
hooks into the Java compiler).

On Wed, Aug 31, 2011 at 7:11 AM, Garner, Shawn
<[hidden email]> wrote:

> I am try to write a spock specification and it seems like my .groovy is
> compiling into a *.class.
>
> However when I open a .groovy file with the groovy editor it is giving me
> validation errors like it is validating a java file.
>
> It’s telling me def cannot be resolved to a type and the type is Java
> Problem
>
> It’s also telling me that I need a semi-colon which tells me it does not
> seeing the source as a groovy file even though it is compiling it fine.
>
> I don’t have the option of upgrading to a newer version of eclipse (wouldn’t
> that be nice).
>
> I checked and the project is of groovy nature.
>
>
>
> I appreciate any help.
>
>
>
> Shawn
>
> -----Message Disclaimer-----
>
> This e-mail message is intended only for the use of the individual or entity
> to which it is addressed, and may contain information that is privileged,
> confidential and exempt from disclosure under applicable law. If you are not
> the intended recipient, any dissemination, distribution or copying of this
> communication is strictly prohibited. If you have received this
> communication in error, please notify us immediately by reply email to
> [hidden email] and delete or destroy all copies of the original
> message and attachments thereto. Email sent to or from the Principal
> Financial Group or any of its member companies may be retained as required
> by law or regulation.
>
> Nothing in this message is intended to constitute an Electronic signature
> for purposes of the Uniform Electronic Transactions Act (UETA) or the
> Electronic Signatures in Global and National Commerce Act ("E-Sign") unless
> a specific statement to the contrary is included in this message.
>
> While this communication may be used to promote or market a transaction or
> an idea that is discussed in the publication, it is intended to provide
> general information about the subject matter covered and is provided with
> the understanding that The Principal is not rendering legal, accounting, or
> tax advice. It is not a marketed opinion and may not be used to avoid
> penalties under the Internal Revenue Code. You should consult with
> appropriate counsel or other advisors on all matters pertaining to legal,
> tax, or accounting obligations and requirements.
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

RE: eclipse 3.4 plugin

Garner, Shawn
I'm using the plugin and features here which only lets you use the embedded 1.7 beta Groovy: http://ci.repository.codehaus.org/greclipse/snapshot/e34/old/archive-2.0.0.xx-20091027-1400-e34.zip

So from the version number it looks like version 2.0.0 from 10/27/2009.

Chose the option to make my current web project a groovy project.

Shawn

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
Sent: Wednesday, August 31, 2011 11:41 AM
To: [hidden email]
Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin

What version of the plugin are you using?  Also, what version of
Groovy are you using?

Are you using the version from this update site:
http://ci.repository.codehaus.org/greclipse/snapshot/e34/

Only groovy 1.7 is supported for Eclipse 3.4.  And it can only install
into Eclipse 3.4.2.  It looks as if the JDT patch is not being
properly picked up by your Eclipse installation.  One of the reasons
why we had to drop support for Eclipse 3.4 is that there wasn't very
good support for feature patches (which is how we implemented our
hooks into the Java compiler).

On Wed, Aug 31, 2011 at 7:11 AM, Garner, Shawn
<[hidden email]> wrote:

> I am try to write a spock specification and it seems like my .groovy is
> compiling into a *.class.
>
> However when I open a .groovy file with the groovy editor it is giving me
> validation errors like it is validating a java file.
>
> It's telling me def cannot be resolved to a type and the type is Java
> Problem
>
> It's also telling me that I need a semi-colon which tells me it does not
> seeing the source as a groovy file even though it is compiling it fine.
>
> I don't have the option of upgrading to a newer version of eclipse (wouldn't
> that be nice).
>
> I checked and the project is of groovy nature.
>
>
>
> I appreciate any help.
>
>
>
> Shawn
>
> -----Message Disclaimer-----
>
> This e-mail message is intended only for the use of the individual or entity
> to which it is addressed, and may contain information that is privileged,
> confidential and exempt from disclosure under applicable law. If you are not
> the intended recipient, any dissemination, distribution or copying of this
> communication is strictly prohibited. If you have received this
> communication in error, please notify us immediately by reply email to
> [hidden email] and delete or destroy all copies of the original
> message and attachments thereto. Email sent to or from the Principal
> Financial Group or any of its member companies may be retained as required
> by law or regulation.
>
> Nothing in this message is intended to constitute an Electronic signature
> for purposes of the Uniform Electronic Transactions Act (UETA) or the
> Electronic Signatures in Global and National Commerce Act ("E-Sign") unless
> a specific statement to the contrary is included in this message.
>
> While this communication may be used to promote or market a transaction or
> an idea that is discussed in the publication, it is intended to provide
> general information about the subject matter covered and is provided with
> the understanding that The Principal is not rendering legal, accounting, or
> tax advice. It is not a marketed opinion and may not be used to avoid
> penalties under the Internal Revenue Code. You should consult with
> appropriate counsel or other advisors on all matters pertaining to legal,
> tax, or accounting obligations and requirements.
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

RE: eclipse 3.4 plugin

Garner, Shawn
I'm using JDT 3.4.2 and Eclipse 3.4.2.
I searched in the Feature details and found them.

Shawn

-----Original Message-----
From: Garner, Shawn [mailto:[hidden email]]
Sent: Wednesday, August 31, 2011 11:45 AM
To: [hidden email]
Subject: RE: [groovy-eclipse-plugin-user] eclipse 3.4 plugin

I'm using the plugin and features here which only lets you use the embedded 1.7 beta Groovy: http://ci.repository.codehaus.org/greclipse/snapshot/e34/old/archive-2.0.0.xx-20091027-1400-e34.zip

So from the version number it looks like version 2.0.0 from 10/27/2009.

Chose the option to make my current web project a groovy project.

Shawn

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
Sent: Wednesday, August 31, 2011 11:41 AM
To: [hidden email]
Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin

What version of the plugin are you using?  Also, what version of
Groovy are you using?

Are you using the version from this update site:
http://ci.repository.codehaus.org/greclipse/snapshot/e34/

Only groovy 1.7 is supported for Eclipse 3.4.  And it can only install
into Eclipse 3.4.2.  It looks as if the JDT patch is not being
properly picked up by your Eclipse installation.  One of the reasons
why we had to drop support for Eclipse 3.4 is that there wasn't very
good support for feature patches (which is how we implemented our
hooks into the Java compiler).

On Wed, Aug 31, 2011 at 7:11 AM, Garner, Shawn
<[hidden email]> wrote:

> I am try to write a spock specification and it seems like my .groovy is
> compiling into a *.class.
>
> However when I open a .groovy file with the groovy editor it is giving me
> validation errors like it is validating a java file.
>
> It's telling me def cannot be resolved to a type and the type is Java
> Problem
>
> It's also telling me that I need a semi-colon which tells me it does not
> seeing the source as a groovy file even though it is compiling it fine.
>
> I don't have the option of upgrading to a newer version of eclipse (wouldn't
> that be nice).
>
> I checked and the project is of groovy nature.
>
>
>
> I appreciate any help.
>
>
>
> Shawn
>
> -----Message Disclaimer-----
>
> This e-mail message is intended only for the use of the individual or entity
> to which it is addressed, and may contain information that is privileged,
> confidential and exempt from disclosure under applicable law. If you are not
> the intended recipient, any dissemination, distribution or copying of this
> communication is strictly prohibited. If you have received this
> communication in error, please notify us immediately by reply email to
> [hidden email] and delete or destroy all copies of the original
> message and attachments thereto. Email sent to or from the Principal
> Financial Group or any of its member companies may be retained as required
> by law or regulation.
>
> Nothing in this message is intended to constitute an Electronic signature
> for purposes of the Uniform Electronic Transactions Act (UETA) or the
> Electronic Signatures in Global and National Commerce Act ("E-Sign") unless
> a specific statement to the contrary is included in this message.
>
> While this communication may be used to promote or market a transaction or
> an idea that is discussed in the publication, it is intended to provide
> general information about the subject matter covered and is provided with
> the understanding that The Principal is not rendering legal, accounting, or
> tax advice. It is not a marketed opinion and may not be used to avoid
> penalties under the Internal Revenue Code. You should consult with
> appropriate counsel or other advisors on all matters pertaining to legal,
> tax, or accounting obligations and requirements.
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

RE: eclipse 3.4 plugin

Garner, Shawn
The only thing I can tell it did was add the nature to the project file.

<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
        <name>MyWebProjectWeb</name>
        <comment></comment>
        <projects>
        </projects>
        <buildSpec>
                <buildCommand>
                        <name>org.eclipse.wst.jsdt.core.javascriptValidator</name>
                        <arguments>
                        </arguments>
                </buildCommand>
                <buildCommand>
                        <name>org.eclipse.jdt.core.javabuilder</name>
                        <arguments>
                        </arguments>
                </buildCommand>
                <buildCommand>
                        <name>org.eclipse.wst.common.project.facet.core.builder</name>
                        <arguments>
                        </arguments>
                </buildCommand>
                <buildCommand>
                        <name>org.eclipse.wst.validation.validationbuilder</name>
                        <arguments>
                        </arguments>
                </buildCommand>
        </buildSpec>
        <natures>
                <nature>org.eclipse.jdt.groovy.core.groovyNature</nature>
                <nature>org.eclipse.jem.workbench.JavaEMFNature</nature>
                <nature>org.eclipse.wst.common.modulecore.ModuleCoreNature</nature>
                <nature>org.eclipse.wst.common.project.facet.core.nature</nature>
                <nature>org.eclipse.jdt.core.javanature</nature>
                <nature>org.eclipse.wst.jsdt.core.jsNature</nature>
        </natures>
</projectDescription>

Shawn

-----Original Message-----
From: Garner, Shawn [mailto:[hidden email]]
Sent: Wednesday, August 31, 2011 11:54 AM
To: [hidden email]
Subject: RE: [groovy-eclipse-plugin-user] eclipse 3.4 plugin

I'm using JDT 3.4.2 and Eclipse 3.4.2.
I searched in the Feature details and found them.

Shawn

-----Original Message-----
From: Garner, Shawn [mailto:[hidden email]]
Sent: Wednesday, August 31, 2011 11:45 AM
To: [hidden email]
Subject: RE: [groovy-eclipse-plugin-user] eclipse 3.4 plugin

I'm using the plugin and features here which only lets you use the embedded 1.7 beta Groovy: http://ci.repository.codehaus.org/greclipse/snapshot/e34/old/archive-2.0.0.xx-20091027-1400-e34.zip

So from the version number it looks like version 2.0.0 from 10/27/2009.

Chose the option to make my current web project a groovy project.

Shawn

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
Sent: Wednesday, August 31, 2011 11:41 AM
To: [hidden email]
Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin

What version of the plugin are you using?  Also, what version of
Groovy are you using?

Are you using the version from this update site:
http://ci.repository.codehaus.org/greclipse/snapshot/e34/

Only groovy 1.7 is supported for Eclipse 3.4.  And it can only install
into Eclipse 3.4.2.  It looks as if the JDT patch is not being
properly picked up by your Eclipse installation.  One of the reasons
why we had to drop support for Eclipse 3.4 is that there wasn't very
good support for feature patches (which is how we implemented our
hooks into the Java compiler).

On Wed, Aug 31, 2011 at 7:11 AM, Garner, Shawn
<[hidden email]> wrote:

> I am try to write a spock specification and it seems like my .groovy is
> compiling into a *.class.
>
> However when I open a .groovy file with the groovy editor it is giving me
> validation errors like it is validating a java file.
>
> It's telling me def cannot be resolved to a type and the type is Java
> Problem
>
> It's also telling me that I need a semi-colon which tells me it does not
> seeing the source as a groovy file even though it is compiling it fine.
>
> I don't have the option of upgrading to a newer version of eclipse (wouldn't
> that be nice).
>
> I checked and the project is of groovy nature.
>
>
>
> I appreciate any help.
>
>
>
> Shawn
>
> -----Message Disclaimer-----
>
> This e-mail message is intended only for the use of the individual or entity
> to which it is addressed, and may contain information that is privileged,
> confidential and exempt from disclosure under applicable law. If you are not
> the intended recipient, any dissemination, distribution or copying of this
> communication is strictly prohibited. If you have received this
> communication in error, please notify us immediately by reply email to
> [hidden email] and delete or destroy all copies of the original
> message and attachments thereto. Email sent to or from the Principal
> Financial Group or any of its member companies may be retained as required
> by law or regulation.
>
> Nothing in this message is intended to constitute an Electronic signature
> for purposes of the Uniform Electronic Transactions Act (UETA) or the
> Electronic Signatures in Global and National Commerce Act ("E-Sign") unless
> a specific statement to the contrary is included in this message.
>
> While this communication may be used to promote or market a transaction or
> an idea that is discussed in the publication, it is intended to provide
> general information about the subject matter covered and is provided with
> the understanding that The Principal is not rendering legal, accounting, or
> tax advice. It is not a marketed opinion and may not be used to avoid
> penalties under the Internal Revenue Code. You should consult with
> appropriate counsel or other advisors on all matters pertaining to legal,
> tax, or accounting obligations and requirements.
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: eclipse 3.4 plugin

Andrew Eisenberg
On Wed, Aug 31, 2011 at 9:58 AM, Garner, Shawn
<[hidden email]> wrote:
> The only thing I can tell it did was add the nature to the project file.
That's all that it should do.  I am still fairly sure that the problem
is that the JDT patch is not installed properly.

How did you install Groovy-Eclipse from the zip file?  Did you go
through the install manager, or did you unzip it (unzipping will not
work)?

Can you take a look at your bundles.info file?  It is at
eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info.
 Look for the line for org.eclipse.jdt.core.  What version is there
(it should be the groovy-eclipse version, not the eclipse version)?

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

RE: eclipse 3.4 plugin

Garner, Shawn
I unziped it and put the non-source jars in the plugins and feature directories.

I couldn't get it to install through the manager.  It kept saying I was missing some core help bundle which it couldn't find.

I looked in the bundles.info and it is 3.4.13.v_903_R34x and is not the version I got from the zip file and is what came with eclipse.

Shawn

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
Sent: Wednesday, August 31, 2011 12:03 PM
To: [hidden email]
Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin

On Wed, Aug 31, 2011 at 9:58 AM, Garner, Shawn
<[hidden email]> wrote:
> The only thing I can tell it did was add the nature to the project file.
That's all that it should do.  I am still fairly sure that the problem
is that the JDT patch is not installed properly.

How did you install Groovy-Eclipse from the zip file?  Did you go
through the install manager, or did you unzip it (unzipping will not
work)?

Can you take a look at your bundles.info file?  It is at
eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info.
 Look for the line for org.eclipse.jdt.core.  What version is there
(it should be the groovy-eclipse version, not the eclipse version)?

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email




-----Message Disclaimer-----

This e-mail message is intended only for the use of the individual or
entity to which it is addressed, and may contain information that is
privileged, confidential and exempt from disclosure under applicable law.
If you are not the intended recipient, any dissemination, distribution or
copying of this communication is strictly prohibited. If you have
received this communication in error, please notify us immediately by
reply email to [hidden email] and delete or destroy all copies of
the original message and attachments thereto. Email sent to or from the
Principal Financial Group or any of its member companies may be retained
as required by law or regulation.

Nothing in this message is intended to constitute an Electronic signature
for purposes of the Uniform Electronic Transactions Act (UETA) or the
Electronic Signatures in Global and National Commerce Act ("E-Sign")
unless a specific statement to the contrary is included in this message.

While this communication may be used to promote or market a transaction
or an idea that is discussed in the publication, it is intended to provide
general information about the subject matter covered and is provided with
the understanding that The Principal is not rendering legal, accounting,
or tax advice. It is not a marketed opinion and may not be used to avoid
penalties under the Internal Revenue Code. You should consult with
appropriate counsel or other advisors on all matters pertaining to legal,
tax, or accounting obligations and requirements.


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

RE: eclipse 3.4 plugin

Garner, Shawn
It wasn't finding org.eclipse.help.feature.group which I didn't think help was a very important feature so thought I could bypass by unzipping and copying.

Shawn

-----Original Message-----
From: Garner, Shawn [mailto:[hidden email]]
Sent: Wednesday, August 31, 2011 12:12 PM
To: [hidden email]
Subject: RE: [groovy-eclipse-plugin-user] eclipse 3.4 plugin

I unziped it and put the non-source jars in the plugins and feature directories.

I couldn't get it to install through the manager.  It kept saying I was missing some core help bundle which it couldn't find.

I looked in the bundles.info and it is 3.4.13.v_903_R34x and is not the version I got from the zip file and is what came with eclipse.

Shawn

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
Sent: Wednesday, August 31, 2011 12:03 PM
To: [hidden email]
Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin

On Wed, Aug 31, 2011 at 9:58 AM, Garner, Shawn
<[hidden email]> wrote:
> The only thing I can tell it did was add the nature to the project file.
That's all that it should do.  I am still fairly sure that the problem
is that the JDT patch is not installed properly.

How did you install Groovy-Eclipse from the zip file?  Did you go
through the install manager, or did you unzip it (unzipping will not
work)?

Can you take a look at your bundles.info file?  It is at
eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info.
 Look for the line for org.eclipse.jdt.core.  What version is there
(it should be the groovy-eclipse version, not the eclipse version)?

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email




-----Message Disclaimer-----

This e-mail message is intended only for the use of the individual or
entity to which it is addressed, and may contain information that is
privileged, confidential and exempt from disclosure under applicable law.
If you are not the intended recipient, any dissemination, distribution or
copying of this communication is strictly prohibited. If you have
received this communication in error, please notify us immediately by
reply email to [hidden email] and delete or destroy all copies of
the original message and attachments thereto. Email sent to or from the
Principal Financial Group or any of its member companies may be retained
as required by law or regulation.

Nothing in this message is intended to constitute an Electronic signature
for purposes of the Uniform Electronic Transactions Act (UETA) or the
Electronic Signatures in Global and National Commerce Act ("E-Sign")
unless a specific statement to the contrary is included in this message.

While this communication may be used to promote or market a transaction
or an idea that is discussed in the publication, it is intended to provide
general information about the subject matter covered and is provided with
the understanding that The Principal is not rendering legal, accounting,
or tax advice. It is not a marketed opinion and may not be used to avoid
penalties under the Internal Revenue Code. You should consult with
appropriate counsel or other advisors on all matters pertaining to legal,
tax, or accounting obligations and requirements.


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: eclipse 3.4 plugin

Andrew Eisenberg
Unzipping the plugin will not work.  You need to install using the
install manager in order for the jdt patch to be configured properly.
Also, some of the jars must be unzipped in the install.  It would be a
real mess to try to install manually through unzipping.

Is there really no way that you can upgrade?  :)

What is the exact p2 error message that you are getting when you are
trying to install?  I'd recommend trying to track down that missing
bundle and installing it.  It could be that you installed a flavor of
Eclipse that doesn't come with that feature by default.

On Wed, Aug 31, 2011 at 10:21 AM, Garner, Shawn
<[hidden email]> wrote:

> It wasn't finding org.eclipse.help.feature.group which I didn't think help was a very important feature so thought I could bypass by unzipping and copying.
>
> Shawn
>
> -----Original Message-----
> From: Garner, Shawn [mailto:[hidden email]]
> Sent: Wednesday, August 31, 2011 12:12 PM
> To: [hidden email]
> Subject: RE: [groovy-eclipse-plugin-user] eclipse 3.4 plugin
>
> I unziped it and put the non-source jars in the plugins and feature directories.
>
> I couldn't get it to install through the manager.  It kept saying I was missing some core help bundle which it couldn't find.
>
> I looked in the bundles.info and it is 3.4.13.v_903_R34x and is not the version I got from the zip file and is what came with eclipse.
>
> Shawn
>
> -----Original Message-----
> From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
> Sent: Wednesday, August 31, 2011 12:03 PM
> To: [hidden email]
> Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin
>
> On Wed, Aug 31, 2011 at 9:58 AM, Garner, Shawn
> <[hidden email]> wrote:
>> The only thing I can tell it did was add the nature to the project file.
> That's all that it should do.  I am still fairly sure that the problem
> is that the JDT patch is not installed properly.
>
> How did you install Groovy-Eclipse from the zip file?  Did you go
> through the install manager, or did you unzip it (unzipping will not
> work)?
>
> Can you take a look at your bundles.info file?  It is at
> eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info.
>  Look for the line for org.eclipse.jdt.core.  What version is there
> (it should be the groovy-eclipse version, not the eclipse version)?
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>
>
> -----Message Disclaimer-----
>
> This e-mail message is intended only for the use of the individual or
> entity to which it is addressed, and may contain information that is
> privileged, confidential and exempt from disclosure under applicable law.
> If you are not the intended recipient, any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have
> received this communication in error, please notify us immediately by
> reply email to [hidden email] and delete or destroy all copies of
> the original message and attachments thereto. Email sent to or from the
> Principal Financial Group or any of its member companies may be retained
> as required by law or regulation.
>
> Nothing in this message is intended to constitute an Electronic signature
> for purposes of the Uniform Electronic Transactions Act (UETA) or the
> Electronic Signatures in Global and National Commerce Act ("E-Sign")
> unless a specific statement to the contrary is included in this message.
>
> While this communication may be used to promote or market a transaction
> or an idea that is discussed in the publication, it is intended to provide
> general information about the subject matter covered and is provided with
> the understanding that The Principal is not rendering legal, accounting,
> or tax advice. It is not a marketed opinion and may not be used to avoid
> penalties under the Internal Revenue Code. You should consult with
> appropriate counsel or other advisors on all matters pertaining to legal,
> tax, or accounting obligations and requirements.
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

RE: eclipse 3.4 plugin

Garner, Shawn
No, as a big organization we stay on major versions for a long time in order to standardize dev environments and some other reasons.  It's pretty much dictated when a new version is rolled out.
We don't upgrade that regularly so a new version would come at least 6 months down the road and maybe longer.

I deleted my jars I had copied and did a clean and tried to install via the install site.  I seem to be getting more and different errors than I was before.  Not sure what changed.

Shawn

Cannot complete the request.  See the details.
Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.4.v_894_R34x,3.4.4.v_894_R34x]
Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0.100.v_894_R34x,1.0.100.v_894_R34x]
Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.ui/[3.3.1.v20090120_r342,3.3.1.v20090120_r342]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.ide.application/[1.0.1.M20090204-0800,1.0.1.M20090204-0800]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.101.v200902111700,3.3.101.v200902111700]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.browser/[3.2.201.v20080708_34x,3.2.201.v20080708_34x]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.team.core/[3.4.2.r34x_20080115,3.4.2.r34x_20080115]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem.win32.x86/[1.1.0.v20080604-1400,1.1.0.v20080604-1400]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.security/[1.0.1.R34x_v20080721,1.0.1.R34x_v20080721]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.externaltools/[3.2.0.v20080514-1542,3.2.0.v20080514-1542]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem/[1.2.0.v20080604-1400,1.2.0.v20080604-1400]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.navigator.resources/[3.3.101.M20080910-0800,3.3.101.M20080910-0800]
Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.forms/[3.3.103.v20081027_34x,3.3.103.v20081027_34x]
Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.103.v20090128_34x,3.3.103.v20090128_34x]
Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.webapp/[3.3.101.M20080805_34x,3.3.101.M20080805_34x]
Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.ui/[3.3.102.v20081014_34x,3.3.102.v20081014_34x]
Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.core/[3.2.0.v20080529,3.2.0.v20080529]
Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.jsp.jasper/[1.0.100.v20080427-0830,1.0.100.v20080427-0830]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.jobs/[3.4.1.R34x_v20081128,3.4.1.R34x_v20081128]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.osgi/[3.4.3.R34x_v20081215-1030,3.4.3.R34x_v20081215-1030]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.preferences/[3.2.201.R34x_v20080709,3.2.201.R34x_v20080709]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.contenttype/[3.3.0.v20080604-1400,3.3.0.v20080604-1400]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.2.v3452b,3.4.2.v3452b]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/com.ibm.icu/[3.8.1.v20080530,3.8.1.v20080530]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.app/[1.1.0.v20080421-2006,1.1.0.v20080421-2006]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3.4.1.v3452b,3.4.1.v3452b]
Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.webapp/[3.3.101.M20080805_34x,3.3.101.M20080805_34x]
Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.forms/[3.3.103.v20081027_34x,3.3.103.v20081027_34x]
Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.jsp.jasper/[1.0.100.v20080427-0830,1.0.100.v20080427-0830]
Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.core/[3.2.0.v20080529,3.2.0.v20080529]
Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.group/[3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63,3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63]
Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.103.v20090128_34x,3.3.103.v20090128_34x]
Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.ui/[3.3.102.v20081014_34x,3.3.102.v20081014_34x]
Unsatisfied dependency: [org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20091027-1400-e34] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.group/[3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI,3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.ide.application/[1.0.1.M20090204-0800,1.0.1.M20090204-0800]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.browser/[3.2.201.v20080708_34x,3.2.201.v20080708_34x]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.security/[1.0.1.R34x_v20080721,1.0.1.R34x_v20080721]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.navigator.resources/[3.3.101.M20080910-0800,3.3.101.M20080910-0800]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.feature.group/[1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK,1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.team.core/[3.4.2.r34x_20080115,3.4.2.r34x_20080115]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem.win32.x86/[1.1.0.v20080604-1400,1.1.0.v20080604-1400]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem/[1.2.0.v20080604-1400,1.2.0.v20080604-1400]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.101.v200902111700,3.3.101.v200902111700]
Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.externaltools/[3.2.0.v20080514-1542,3.2.0.v20080514-1542]
Unsatisfied dependency: [org.codehaus.groovy.eclipse.feature.feature.group 2.0.0.xx-20091027-1400-e34] requiredCapability: org.eclipse.equinox.p2.iu/org.codehaus.groovy.jdt.patch.feature.group/[2.0.0.xx-20091027-1400-e34,2.0.0.xx-20091027-1400-e34]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.2.v3452b,3.4.2.v3452b]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/com.ibm.icu/[3.8.1.v20080530,3.8.1.v20080530]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.contenttype/[3.3.0.v20080604-1400,3.3.0.v20080604-1400]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.app/[1.1.0.v20080421-2006,1.1.0.v20080421-2006]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.jobs/[3.4.1.R34x_v20081128,3.4.1.R34x_v20081128]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.preferences/[3.2.201.R34x_v20080709,3.2.201.R34x_v20080709]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3.4.1.v3452b,3.4.1.v3452b]
Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.osgi/[3.4.3.R34x_v20081215-1030,3.4.3.R34x_v20081215-1030]
Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.ui/[3.3.1.v20090120_r342,3.3.1.v20090120_r342]
Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0.100.v_894_R34x,1.0.100.v_894_R34x]
Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.4.v_894_R34x,3.4.4.v_894_R34x]
Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.group/[3.4.0,4.0.0)



-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
Sent: Wednesday, August 31, 2011 1:00 PM
To: [hidden email]
Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin

Unzipping the plugin will not work.  You need to install using the
install manager in order for the jdt patch to be configured properly.
Also, some of the jars must be unzipped in the install.  It would be a
real mess to try to install manually through unzipping.

Is there really no way that you can upgrade?  :)

What is the exact p2 error message that you are getting when you are
trying to install?  I'd recommend trying to track down that missing
bundle and installing it.  It could be that you installed a flavor of
Eclipse that doesn't come with that feature by default.

On Wed, Aug 31, 2011 at 10:21 AM, Garner, Shawn
<[hidden email]> wrote:

> It wasn't finding org.eclipse.help.feature.group which I didn't think help was a very important feature so thought I could bypass by unzipping and copying.
>
> Shawn
>
> -----Original Message-----
> From: Garner, Shawn [mailto:[hidden email]]
> Sent: Wednesday, August 31, 2011 12:12 PM
> To: [hidden email]
> Subject: RE: [groovy-eclipse-plugin-user] eclipse 3.4 plugin
>
> I unziped it and put the non-source jars in the plugins and feature directories.
>
> I couldn't get it to install through the manager.  It kept saying I was missing some core help bundle which it couldn't find.
>
> I looked in the bundles.info and it is 3.4.13.v_903_R34x and is not the version I got from the zip file and is what came with eclipse.
>
> Shawn
>
> -----Original Message-----
> From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
> Sent: Wednesday, August 31, 2011 12:03 PM
> To: [hidden email]
> Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin
>
> On Wed, Aug 31, 2011 at 9:58 AM, Garner, Shawn
> <[hidden email]> wrote:
>> The only thing I can tell it did was add the nature to the project file.
> That's all that it should do.  I am still fairly sure that the problem
> is that the JDT patch is not installed properly.
>
> How did you install Groovy-Eclipse from the zip file?  Did you go
> through the install manager, or did you unzip it (unzipping will not
> work)?
>
> Can you take a look at your bundles.info file?  It is at
> eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info.
>  Look for the line for org.eclipse.jdt.core.  What version is there
> (it should be the groovy-eclipse version, not the eclipse version)?
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>
>
> -----Message Disclaimer-----
>
> This e-mail message is intended only for the use of the individual or
> entity to which it is addressed, and may contain information that is
> privileged, confidential and exempt from disclosure under applicable law.
> If you are not the intended recipient, any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have
> received this communication in error, please notify us immediately by
> reply email to [hidden email] and delete or destroy all copies of
> the original message and attachments thereto. Email sent to or from the
> Principal Financial Group or any of its member companies may be retained
> as required by law or regulation.
>
> Nothing in this message is intended to constitute an Electronic signature
> for purposes of the Uniform Electronic Transactions Act (UETA) or the
> Electronic Signatures in Global and National Commerce Act ("E-Sign")
> unless a specific statement to the contrary is included in this message.
>
> While this communication may be used to promote or market a transaction
> or an idea that is discussed in the publication, it is intended to provide
> general information about the subject matter covered and is provided with
> the understanding that The Principal is not rendering legal, accounting,
> or tax advice. It is not a marketed opinion and may not be used to avoid
> penalties under the Internal Revenue Code. You should consult with
> appropriate counsel or other advisors on all matters pertaining to legal,
> tax, or accounting obligations and requirements.
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: eclipse 3.4 plugin

Andrew Eisenberg
It could be that your manual uninstall wasn't performed properly.  Any
chance that you can start with a clean 3.4.2?

It looks like the feature org.eclipse.jdt.feature.group
3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI is not being found
and so installation fails.  It could be that by manually deleting
groovy-eclipse, you left the configuration in a state where it
couldn't find that feature.

Have you restarted Eclipse with the -clean option?  But, your best bet
is a new, clean installation.

On Wed, Aug 31, 2011 at 1:03 PM, Garner, Shawn
<[hidden email]> wrote:

> No, as a big organization we stay on major versions for a long time in order to standardize dev environments and some other reasons.  It's pretty much dictated when a new version is rolled out.
> We don't upgrade that regularly so a new version would come at least 6 months down the road and maybe longer.
>
> I deleted my jars I had copied and did a clean and tried to install via the install site.  I seem to be getting more and different errors than I was before.  Not sure what changed.
>
> Shawn
>
> Cannot complete the request.  See the details.
> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.4.v_894_R34x,3.4.4.v_894_R34x]
> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0.100.v_894_R34x,1.0.100.v_894_R34x]
> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.ui/[3.3.1.v20090120_r342,3.3.1.v20090120_r342]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.ide.application/[1.0.1.M20090204-0800,1.0.1.M20090204-0800]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.101.v200902111700,3.3.101.v200902111700]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.browser/[3.2.201.v20080708_34x,3.2.201.v20080708_34x]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.team.core/[3.4.2.r34x_20080115,3.4.2.r34x_20080115]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem.win32.x86/[1.1.0.v20080604-1400,1.1.0.v20080604-1400]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.security/[1.0.1.R34x_v20080721,1.0.1.R34x_v20080721]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.externaltools/[3.2.0.v20080514-1542,3.2.0.v20080514-1542]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem/[1.2.0.v20080604-1400,1.2.0.v20080604-1400]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.navigator.resources/[3.3.101.M20080910-0800,3.3.101.M20080910-0800]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.forms/[3.3.103.v20081027_34x,3.3.103.v20081027_34x]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.103.v20090128_34x,3.3.103.v20090128_34x]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.webapp/[3.3.101.M20080805_34x,3.3.101.M20080805_34x]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.ui/[3.3.102.v20081014_34x,3.3.102.v20081014_34x]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.core/[3.2.0.v20080529,3.2.0.v20080529]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.jsp.jasper/[1.0.100.v20080427-0830,1.0.100.v20080427-0830]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.jobs/[3.4.1.R34x_v20081128,3.4.1.R34x_v20081128]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.osgi/[3.4.3.R34x_v20081215-1030,3.4.3.R34x_v20081215-1030]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.preferences/[3.2.201.R34x_v20080709,3.2.201.R34x_v20080709]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.contenttype/[3.3.0.v20080604-1400,3.3.0.v20080604-1400]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.2.v3452b,3.4.2.v3452b]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/com.ibm.icu/[3.8.1.v20080530,3.8.1.v20080530]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.app/[1.1.0.v20080421-2006,1.1.0.v20080421-2006]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3.4.1.v3452b,3.4.1.v3452b]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.webapp/[3.3.101.M20080805_34x,3.3.101.M20080805_34x]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.forms/[3.3.103.v20081027_34x,3.3.103.v20081027_34x]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.jsp.jasper/[1.0.100.v20080427-0830,1.0.100.v20080427-0830]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.core/[3.2.0.v20080529,3.2.0.v20080529]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.group/[3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63,3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.103.v20090128_34x,3.3.103.v20090128_34x]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.ui/[3.3.102.v20081014_34x,3.3.102.v20081014_34x]
> Unsatisfied dependency: [org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20091027-1400-e34] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.group/[3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI,3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.ide.application/[1.0.1.M20090204-0800,1.0.1.M20090204-0800]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.browser/[3.2.201.v20080708_34x,3.2.201.v20080708_34x]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.security/[1.0.1.R34x_v20080721,1.0.1.R34x_v20080721]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.navigator.resources/[3.3.101.M20080910-0800,3.3.101.M20080910-0800]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.feature.group/[1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK,1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.team.core/[3.4.2.r34x_20080115,3.4.2.r34x_20080115]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem.win32.x86/[1.1.0.v20080604-1400,1.1.0.v20080604-1400]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem/[1.2.0.v20080604-1400,1.2.0.v20080604-1400]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.101.v200902111700,3.3.101.v200902111700]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.externaltools/[3.2.0.v20080514-1542,3.2.0.v20080514-1542]
> Unsatisfied dependency: [org.codehaus.groovy.eclipse.feature.feature.group 2.0.0.xx-20091027-1400-e34] requiredCapability: org.eclipse.equinox.p2.iu/org.codehaus.groovy.jdt.patch.feature.group/[2.0.0.xx-20091027-1400-e34,2.0.0.xx-20091027-1400-e34]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.2.v3452b,3.4.2.v3452b]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/com.ibm.icu/[3.8.1.v20080530,3.8.1.v20080530]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.contenttype/[3.3.0.v20080604-1400,3.3.0.v20080604-1400]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.app/[1.1.0.v20080421-2006,1.1.0.v20080421-2006]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.jobs/[3.4.1.R34x_v20081128,3.4.1.R34x_v20081128]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.preferences/[3.2.201.R34x_v20080709,3.2.201.R34x_v20080709]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3.4.1.v3452b,3.4.1.v3452b]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.osgi/[3.4.3.R34x_v20081215-1030,3.4.3.R34x_v20081215-1030]
> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.ui/[3.3.1.v20090120_r342,3.3.1.v20090120_r342]
> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0.100.v_894_R34x,1.0.100.v_894_R34x]
> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.4.v_894_R34x,3.4.4.v_894_R34x]
> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.group/[3.4.0,4.0.0)
>
>
>
> -----Original Message-----
> From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
> Sent: Wednesday, August 31, 2011 1:00 PM
> To: [hidden email]
> Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin
>
> Unzipping the plugin will not work.  You need to install using the
> install manager in order for the jdt patch to be configured properly.
> Also, some of the jars must be unzipped in the install.  It would be a
> real mess to try to install manually through unzipping.
>
> Is there really no way that you can upgrade?  :)
>
> What is the exact p2 error message that you are getting when you are
> trying to install?  I'd recommend trying to track down that missing
> bundle and installing it.  It could be that you installed a flavor of
> Eclipse that doesn't come with that feature by default.
>
> On Wed, Aug 31, 2011 at 10:21 AM, Garner, Shawn
> <[hidden email]> wrote:
>> It wasn't finding org.eclipse.help.feature.group which I didn't think help was a very important feature so thought I could bypass by unzipping and copying.
>>
>> Shawn
>>
>> -----Original Message-----
>> From: Garner, Shawn [mailto:[hidden email]]
>> Sent: Wednesday, August 31, 2011 12:12 PM
>> To: [hidden email]
>> Subject: RE: [groovy-eclipse-plugin-user] eclipse 3.4 plugin
>>
>> I unziped it and put the non-source jars in the plugins and feature directories.
>>
>> I couldn't get it to install through the manager.  It kept saying I was missing some core help bundle which it couldn't find.
>>
>> I looked in the bundles.info and it is 3.4.13.v_903_R34x and is not the version I got from the zip file and is what came with eclipse.
>>
>> Shawn
>>
>> -----Original Message-----
>> From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
>> Sent: Wednesday, August 31, 2011 12:03 PM
>> To: [hidden email]
>> Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin
>>
>> On Wed, Aug 31, 2011 at 9:58 AM, Garner, Shawn
>> <[hidden email]> wrote:
>>> The only thing I can tell it did was add the nature to the project file.
>> That's all that it should do.  I am still fairly sure that the problem
>> is that the JDT patch is not installed properly.
>>
>> How did you install Groovy-Eclipse from the zip file?  Did you go
>> through the install manager, or did you unzip it (unzipping will not
>> work)?
>>
>> Can you take a look at your bundles.info file?  It is at
>> eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info.
>>  Look for the line for org.eclipse.jdt.core.  What version is there
>> (it should be the groovy-eclipse version, not the eclipse version)?
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>>
>>
>> -----Message Disclaimer-----
>>
>> This e-mail message is intended only for the use of the individual or
>> entity to which it is addressed, and may contain information that is
>> privileged, confidential and exempt from disclosure under applicable law.
>> If you are not the intended recipient, any dissemination, distribution or
>> copying of this communication is strictly prohibited. If you have
>> received this communication in error, please notify us immediately by
>> reply email to [hidden email] and delete or destroy all copies of
>> the original message and attachments thereto. Email sent to or from the
>> Principal Financial Group or any of its member companies may be retained
>> as required by law or regulation.
>>
>> Nothing in this message is intended to constitute an Electronic signature
>> for purposes of the Uniform Electronic Transactions Act (UETA) or the
>> Electronic Signatures in Global and National Commerce Act ("E-Sign")
>> unless a specific statement to the contrary is included in this message.
>>
>> While this communication may be used to promote or market a transaction
>> or an idea that is discussed in the publication, it is intended to provide
>> general information about the subject matter covered and is provided with
>> the understanding that The Principal is not rendering legal, accounting,
>> or tax advice. It is not a marketed opinion and may not be used to avoid
>> penalties under the Internal Revenue Code. You should consult with
>> appropriate counsel or other advisors on all matters pertaining to legal,
>> tax, or accounting obligations and requirements.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

RE: eclipse 3.4 plugin

Garner, Shawn
Sorry I just messed up my eclipse install yesterday and the corporate install script took 3.5 hours to run yesterday for a fresh one.
I'm not too interested in un-installing and re-installing a fresh one.

I did do a clean option.  No help.

Shawn
-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
Sent: Wednesday, August 31, 2011 4:08 PM
To: [hidden email]
Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin

It could be that your manual uninstall wasn't performed properly.  Any
chance that you can start with a clean 3.4.2?

It looks like the feature org.eclipse.jdt.feature.group
3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI is not being found
and so installation fails.  It could be that by manually deleting
groovy-eclipse, you left the configuration in a state where it
couldn't find that feature.

Have you restarted Eclipse with the -clean option?  But, your best bet
is a new, clean installation.

On Wed, Aug 31, 2011 at 1:03 PM, Garner, Shawn
<[hidden email]> wrote:

> No, as a big organization we stay on major versions for a long time in order to standardize dev environments and some other reasons.  It's pretty much dictated when a new version is rolled out.
> We don't upgrade that regularly so a new version would come at least 6 months down the road and maybe longer.
>
> I deleted my jars I had copied and did a clean and tried to install via the install site.  I seem to be getting more and different errors than I was before.  Not sure what changed.
>
> Shawn
>
> Cannot complete the request.  See the details.
> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.4.v_894_R34x,3.4.4.v_894_R34x]
> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0.100.v_894_R34x,1.0.100.v_894_R34x]
> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.ui/[3.3.1.v20090120_r342,3.3.1.v20090120_r342]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.ide.application/[1.0.1.M20090204-0800,1.0.1.M20090204-0800]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.101.v200902111700,3.3.101.v200902111700]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.browser/[3.2.201.v20080708_34x,3.2.201.v20080708_34x]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.team.core/[3.4.2.r34x_20080115,3.4.2.r34x_20080115]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem.win32.x86/[1.1.0.v20080604-1400,1.1.0.v20080604-1400]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.security/[1.0.1.R34x_v20080721,1.0.1.R34x_v20080721]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.externaltools/[3.2.0.v20080514-1542,3.2.0.v20080514-1542]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem/[1.2.0.v20080604-1400,1.2.0.v20080604-1400]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.navigator.resources/[3.3.101.M20080910-0800,3.3.101.M20080910-0800]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.forms/[3.3.103.v20081027_34x,3.3.103.v20081027_34x]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.103.v20090128_34x,3.3.103.v20090128_34x]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.webapp/[3.3.101.M20080805_34x,3.3.101.M20080805_34x]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.ui/[3.3.102.v20081014_34x,3.3.102.v20081014_34x]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.core/[3.2.0.v20080529,3.2.0.v20080529]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.jsp.jasper/[1.0.100.v20080427-0830,1.0.100.v20080427-0830]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.jobs/[3.4.1.R34x_v20081128,3.4.1.R34x_v20081128]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.osgi/[3.4.3.R34x_v20081215-1030,3.4.3.R34x_v20081215-1030]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.preferences/[3.2.201.R34x_v20080709,3.2.201.R34x_v20080709]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.contenttype/[3.3.0.v20080604-1400,3.3.0.v20080604-1400]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.2.v3452b,3.4.2.v3452b]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/com.ibm.icu/[3.8.1.v20080530,3.8.1.v20080530]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.app/[1.1.0.v20080421-2006,1.1.0.v20080421-2006]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3.4.1.v3452b,3.4.1.v3452b]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.webapp/[3.3.101.M20080805_34x,3.3.101.M20080805_34x]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.forms/[3.3.103.v20081027_34x,3.3.103.v20081027_34x]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.jsp.jasper/[1.0.100.v20080427-0830,1.0.100.v20080427-0830]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.core/[3.2.0.v20080529,3.2.0.v20080529]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.group/[3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63,3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.103.v20090128_34x,3.3.103.v20090128_34x]
> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.ui/[3.3.102.v20081014_34x,3.3.102.v20081014_34x]
> Unsatisfied dependency: [org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20091027-1400-e34] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.group/[3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI,3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.ide.application/[1.0.1.M20090204-0800,1.0.1.M20090204-0800]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.browser/[3.2.201.v20080708_34x,3.2.201.v20080708_34x]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.security/[1.0.1.R34x_v20080721,1.0.1.R34x_v20080721]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.navigator.resources/[3.3.101.M20080910-0800,3.3.101.M20080910-0800]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.feature.group/[1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK,1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.team.core/[3.4.2.r34x_20080115,3.4.2.r34x_20080115]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem.win32.x86/[1.1.0.v20080604-1400,1.1.0.v20080604-1400]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem/[1.2.0.v20080604-1400,1.2.0.v20080604-1400]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.101.v200902111700,3.3.101.v200902111700]
> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.externaltools/[3.2.0.v20080514-1542,3.2.0.v20080514-1542]
> Unsatisfied dependency: [org.codehaus.groovy.eclipse.feature.feature.group 2.0.0.xx-20091027-1400-e34] requiredCapability: org.eclipse.equinox.p2.iu/org.codehaus.groovy.jdt.patch.feature.group/[2.0.0.xx-20091027-1400-e34,2.0.0.xx-20091027-1400-e34]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.2.v3452b,3.4.2.v3452b]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/com.ibm.icu/[3.8.1.v20080530,3.8.1.v20080530]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.contenttype/[3.3.0.v20080604-1400,3.3.0.v20080604-1400]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.app/[1.1.0.v20080421-2006,1.1.0.v20080421-2006]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.jobs/[3.4.1.R34x_v20081128,3.4.1.R34x_v20081128]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.preferences/[3.2.201.R34x_v20080709,3.2.201.R34x_v20080709]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3.4.1.v3452b,3.4.1.v3452b]
> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.osgi/[3.4.3.R34x_v20081215-1030,3.4.3.R34x_v20081215-1030]
> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.ui/[3.3.1.v20090120_r342,3.3.1.v20090120_r342]
> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0.100.v_894_R34x,1.0.100.v_894_R34x]
> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.4.v_894_R34x,3.4.4.v_894_R34x]
> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.group/[3.4.0,4.0.0)
>
>
>
> -----Original Message-----
> From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
> Sent: Wednesday, August 31, 2011 1:00 PM
> To: [hidden email]
> Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin
>
> Unzipping the plugin will not work.  You need to install using the
> install manager in order for the jdt patch to be configured properly.
> Also, some of the jars must be unzipped in the install.  It would be a
> real mess to try to install manually through unzipping.
>
> Is there really no way that you can upgrade?  :)
>
> What is the exact p2 error message that you are getting when you are
> trying to install?  I'd recommend trying to track down that missing
> bundle and installing it.  It could be that you installed a flavor of
> Eclipse that doesn't come with that feature by default.
>
> On Wed, Aug 31, 2011 at 10:21 AM, Garner, Shawn
> <[hidden email]> wrote:
>> It wasn't finding org.eclipse.help.feature.group which I didn't think help was a very important feature so thought I could bypass by unzipping and copying.
>>
>> Shawn
>>
>> -----Original Message-----
>> From: Garner, Shawn [mailto:[hidden email]]
>> Sent: Wednesday, August 31, 2011 12:12 PM
>> To: [hidden email]
>> Subject: RE: [groovy-eclipse-plugin-user] eclipse 3.4 plugin
>>
>> I unziped it and put the non-source jars in the plugins and feature directories.
>>
>> I couldn't get it to install through the manager.  It kept saying I was missing some core help bundle which it couldn't find.
>>
>> I looked in the bundles.info and it is 3.4.13.v_903_R34x and is not the version I got from the zip file and is what came with eclipse.
>>
>> Shawn
>>
>> -----Original Message-----
>> From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
>> Sent: Wednesday, August 31, 2011 12:03 PM
>> To: [hidden email]
>> Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin
>>
>> On Wed, Aug 31, 2011 at 9:58 AM, Garner, Shawn
>> <[hidden email]> wrote:
>>> The only thing I can tell it did was add the nature to the project file.
>> That's all that it should do.  I am still fairly sure that the problem
>> is that the JDT patch is not installed properly.
>>
>> How did you install Groovy-Eclipse from the zip file?  Did you go
>> through the install manager, or did you unzip it (unzipping will not
>> work)?
>>
>> Can you take a look at your bundles.info file?  It is at
>> eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info.
>>  Look for the line for org.eclipse.jdt.core.  What version is there
>> (it should be the groovy-eclipse version, not the eclipse version)?
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>>
>>
>> -----Message Disclaimer-----
>>
>> This e-mail message is intended only for the use of the individual or
>> entity to which it is addressed, and may contain information that is
>> privileged, confidential and exempt from disclosure under applicable law.
>> If you are not the intended recipient, any dissemination, distribution or
>> copying of this communication is strictly prohibited. If you have
>> received this communication in error, please notify us immediately by
>> reply email to [hidden email] and delete or destroy all copies of
>> the original message and attachments thereto. Email sent to or from the
>> Principal Financial Group or any of its member companies may be retained
>> as required by law or regulation.
>>
>> Nothing in this message is intended to constitute an Electronic signature
>> for purposes of the Uniform Electronic Transactions Act (UETA) or the
>> Electronic Signatures in Global and National Commerce Act ("E-Sign")
>> unless a specific statement to the contrary is included in this message.
>>
>> While this communication may be used to promote or market a transaction
>> or an idea that is discussed in the publication, it is intended to provide
>> general information about the subject matter covered and is provided with
>> the understanding that The Principal is not rendering legal, accounting,
>> or tax advice. It is not a marketed opinion and may not be used to avoid
>> penalties under the Internal Revenue Code. You should consult with
>> appropriate counsel or other advisors on all matters pertaining to legal,
>> tax, or accounting obligations and requirements.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: eclipse 3.4 plugin

Andrew Eisenberg
Well, if you can re-install and you can't upgrade, then it will be
very difficult.  We never had an official release of Groovy-Eclipse on
Eclipse 3.4 because of these instabilities.

You can try reverting your configuration, but I'm not sure how well
that worked in 3.4.  Try this:

1. Help -> About Eclipse -> Installation History
2. Choose a previous configuration and revert

And another question.  Is your Eclipse installed in a read-only
directory, or in the C:\program files directory?

On Wed, Aug 31, 2011 at 2:31 PM, Garner, Shawn
<[hidden email]> wrote:

> Sorry I just messed up my eclipse install yesterday and the corporate install script took 3.5 hours to run yesterday for a fresh one.
> I'm not too interested in un-installing and re-installing a fresh one.
>
> I did do a clean option.  No help.
>
> Shawn
> -----Original Message-----
> From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
> Sent: Wednesday, August 31, 2011 4:08 PM
> To: [hidden email]
> Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin
>
> It could be that your manual uninstall wasn't performed properly.  Any
> chance that you can start with a clean 3.4.2?
>
> It looks like the feature org.eclipse.jdt.feature.group
> 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI is not being found
> and so installation fails.  It could be that by manually deleting
> groovy-eclipse, you left the configuration in a state where it
> couldn't find that feature.
>
> Have you restarted Eclipse with the -clean option?  But, your best bet
> is a new, clean installation.
>
> On Wed, Aug 31, 2011 at 1:03 PM, Garner, Shawn
> <[hidden email]> wrote:
>> No, as a big organization we stay on major versions for a long time in order to standardize dev environments and some other reasons.  It's pretty much dictated when a new version is rolled out.
>> We don't upgrade that regularly so a new version would come at least 6 months down the road and maybe longer.
>>
>> I deleted my jars I had copied and did a clean and tried to install via the install site.  I seem to be getting more and different errors than I was before.  Not sure what changed.
>>
>> Shawn
>>
>> Cannot complete the request.  See the details.
>> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.4.v_894_R34x,3.4.4.v_894_R34x]
>> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0.100.v_894_R34x,1.0.100.v_894_R34x]
>> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.ui/[3.3.1.v20090120_r342,3.3.1.v20090120_r342]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.ide.application/[1.0.1.M20090204-0800,1.0.1.M20090204-0800]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.101.v200902111700,3.3.101.v200902111700]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.browser/[3.2.201.v20080708_34x,3.2.201.v20080708_34x]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.team.core/[3.4.2.r34x_20080115,3.4.2.r34x_20080115]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem.win32.x86/[1.1.0.v20080604-1400,1.1.0.v20080604-1400]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.security/[1.0.1.R34x_v20080721,1.0.1.R34x_v20080721]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.externaltools/[3.2.0.v20080514-1542,3.2.0.v20080514-1542]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem/[1.2.0.v20080604-1400,1.2.0.v20080604-1400]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.navigator.resources/[3.3.101.M20080910-0800,3.3.101.M20080910-0800]
>> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.forms/[3.3.103.v20081027_34x,3.3.103.v20081027_34x]
>> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.103.v20090128_34x,3.3.103.v20090128_34x]
>> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.webapp/[3.3.101.M20080805_34x,3.3.101.M20080805_34x]
>> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.ui/[3.3.102.v20081014_34x,3.3.102.v20081014_34x]
>> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.core/[3.2.0.v20080529,3.2.0.v20080529]
>> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.jsp.jasper/[1.0.100.v20080427-0830,1.0.100.v20080427-0830]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.jobs/[3.4.1.R34x_v20081128,3.4.1.R34x_v20081128]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.osgi/[3.4.3.R34x_v20081215-1030,3.4.3.R34x_v20081215-1030]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.preferences/[3.2.201.R34x_v20080709,3.2.201.R34x_v20080709]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.contenttype/[3.3.0.v20080604-1400,3.3.0.v20080604-1400]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.2.v3452b,3.4.2.v3452b]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/com.ibm.icu/[3.8.1.v20080530,3.8.1.v20080530]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.app/[1.1.0.v20080421-2006,1.1.0.v20080421-2006]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3.4.1.v3452b,3.4.1.v3452b]
>> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.webapp/[3.3.101.M20080805_34x,3.3.101.M20080805_34x]
>> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.forms/[3.3.103.v20081027_34x,3.3.103.v20081027_34x]
>> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.jsp.jasper/[1.0.100.v20080427-0830,1.0.100.v20080427-0830]
>> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.core/[3.2.0.v20080529,3.2.0.v20080529]
>> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.group/[3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63,3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63]
>> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.103.v20090128_34x,3.3.103.v20090128_34x]
>> Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.ui/[3.3.102.v20081014_34x,3.3.102.v20081014_34x]
>> Unsatisfied dependency: [org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20091027-1400-e34] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.group/[3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI,3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.ide.application/[1.0.1.M20090204-0800,1.0.1.M20090204-0800]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.browser/[3.2.201.v20080708_34x,3.2.201.v20080708_34x]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.security/[1.0.1.R34x_v20080721,1.0.1.R34x_v20080721]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.navigator.resources/[3.3.101.M20080910-0800,3.3.101.M20080910-0800]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.feature.group/[1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK,1.0.2.R342_v20090122-7r7xEKaEJBZu5oGhP3u6nOmbM9VK]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.team.core/[3.4.2.r34x_20080115,3.4.2.r34x_20080115]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem.win32.x86/[1.1.0.v20080604-1400,1.1.0.v20080604-1400]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.filesystem/[1.2.0.v20080604-1400,1.2.0.v20080604-1400]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.101.v200902111700,3.3.101.v200902111700]
>> Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.externaltools/[3.2.0.v20080514-1542,3.2.0.v20080514-1542]
>> Unsatisfied dependency: [org.codehaus.groovy.eclipse.feature.feature.group 2.0.0.xx-20091027-1400-e34] requiredCapability: org.eclipse.equinox.p2.iu/org.codehaus.groovy.jdt.patch.feature.group/[2.0.0.xx-20091027-1400-e34,2.0.0.xx-20091027-1400-e34]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.2.v3452b,3.4.2.v3452b]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/com.ibm.icu/[3.8.1.v20080530,3.8.1.v20080530]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.contenttype/[3.3.0.v20080604-1400,3.3.0.v20080604-1400]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.app/[1.1.0.v20080421-2006,1.1.0.v20080421-2006]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.core.jobs/[3.4.1.R34x_v20081128,3.4.1.R34x_v20081128]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.equinox.preferences/[3.2.201.R34x_v20080709,3.2.201.R34x_v20080709]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3.4.1.v3452b,3.4.1.v3452b]
>> Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.osgi/[3.4.3.R34x_v20081215-1030,3.4.3.R34x_v20081215-1030]
>> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ant.ui/[3.3.1.v20090120_r342,3.3.1.v20090120_r342]
>> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0.100.v_894_R34x,1.0.100.v_894_R34x]
>> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.4.v_894_R34x,3.4.4.v_894_R34x]
>> Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.group/[3.4.0,4.0.0)
>>
>>
>>
>> -----Original Message-----
>> From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
>> Sent: Wednesday, August 31, 2011 1:00 PM
>> To: [hidden email]
>> Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin
>>
>> Unzipping the plugin will not work.  You need to install using the
>> install manager in order for the jdt patch to be configured properly.
>> Also, some of the jars must be unzipped in the install.  It would be a
>> real mess to try to install manually through unzipping.
>>
>> Is there really no way that you can upgrade?  :)
>>
>> What is the exact p2 error message that you are getting when you are
>> trying to install?  I'd recommend trying to track down that missing
>> bundle and installing it.  It could be that you installed a flavor of
>> Eclipse that doesn't come with that feature by default.
>>
>> On Wed, Aug 31, 2011 at 10:21 AM, Garner, Shawn
>> <[hidden email]> wrote:
>>> It wasn't finding org.eclipse.help.feature.group which I didn't think help was a very important feature so thought I could bypass by unzipping and copying.
>>>
>>> Shawn
>>>
>>> -----Original Message-----
>>> From: Garner, Shawn [mailto:[hidden email]]
>>> Sent: Wednesday, August 31, 2011 12:12 PM
>>> To: [hidden email]
>>> Subject: RE: [groovy-eclipse-plugin-user] eclipse 3.4 plugin
>>>
>>> I unziped it and put the non-source jars in the plugins and feature directories.
>>>
>>> I couldn't get it to install through the manager.  It kept saying I was missing some core help bundle which it couldn't find.
>>>
>>> I looked in the bundles.info and it is 3.4.13.v_903_R34x and is not the version I got from the zip file and is what came with eclipse.
>>>
>>> Shawn
>>>
>>> -----Original Message-----
>>> From: [hidden email] [mailto:[hidden email]] On Behalf Of Andrew Eisenberg
>>> Sent: Wednesday, August 31, 2011 12:03 PM
>>> To: [hidden email]
>>> Subject: Re: [groovy-eclipse-plugin-user] eclipse 3.4 plugin
>>>
>>> On Wed, Aug 31, 2011 at 9:58 AM, Garner, Shawn
>>> <[hidden email]> wrote:
>>>> The only thing I can tell it did was add the nature to the project file.
>>> That's all that it should do.  I am still fairly sure that the problem
>>> is that the JDT patch is not installed properly.
>>>
>>> How did you install Groovy-Eclipse from the zip file?  Did you go
>>> through the install manager, or did you unzip it (unzipping will not
>>> work)?
>>>
>>> Can you take a look at your bundles.info file?  It is at
>>> eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info.
>>>  Look for the line for org.eclipse.jdt.core.  What version is there
>>> (it should be the groovy-eclipse version, not the eclipse version)?
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe from this list, please visit:
>>>
>>>    http://xircles.codehaus.org/manage_email
>>>
>>>
>>>
>>>
>>> -----Message Disclaimer-----
>>>
>>> This e-mail message is intended only for the use of the individual or
>>> entity to which it is addressed, and may contain information that is
>>> privileged, confidential and exempt from disclosure under applicable law.
>>> If you are not the intended recipient, any dissemination, distribution or
>>> copying of this communication is strictly prohibited. If you have
>>> received this communication in error, please notify us immediately by
>>> reply email to [hidden email] and delete or destroy all copies of
>>> the original message and attachments thereto. Email sent to or from the
>>> Principal Financial Group or any of its member companies may be retained
>>> as required by law or regulation.
>>>
>>> Nothing in this message is intended to constitute an Electronic signature
>>> for purposes of the Uniform Electronic Transactions Act (UETA) or the
>>> Electronic Signatures in Global and National Commerce Act ("E-Sign")
>>> unless a specific statement to the contrary is included in this message.
>>>
>>> While this communication may be used to promote or market a transaction
>>> or an idea that is discussed in the publication, it is intended to provide
>>> general information about the subject matter covered and is provided with
>>> the understanding that The Principal is not rendering legal, accounting,
>>> or tax advice. It is not a marketed opinion and may not be used to avoid
>>> penalties under the Internal Revenue Code. You should consult with
>>> appropriate counsel or other advisors on all matters pertaining to legal,
>>> tax, or accounting obligations and requirements.
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe from this list, please visit:
>>>
>>>    http://xircles.codehaus.org/manage_email
>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe from this list, please visit:
>>>
>>>    http://xircles.codehaus.org/manage_email
>>>
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email