grails home in eclipse and sts

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

grails home in eclipse and sts

Ray Tayek
hi, just imported a 1.0.0-M4 app into eclipse with the latest groovy
plugin. no problems other than having to add the groovy libs to the project.

trying the same thing with sts, it imports the grails app with no
problems.but trying to do a create domain class from within sts
complains about the version:

Application expects grails version [1.2.0.RC2], but GRAILS_HOME is
version [1.2-M4] - use the correct Grails version or run 'grails
upgrade' if this Grails version is newer than the version your
application expects.

i do not have and environment variable for grails home. eclipse has a
classpath variable. sts seems to not have this.

so where is the 1.2-M4 coming from and how should i fix this?

thanks

---
co-chair http://ocjug.org/



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: grails home in eclipse and sts

Andrew Eisenberg
What do you have as your default grails install in Preferences ->
Groovy -> Grails?

Upon downloading STS, this may have been automatically configured for you.

In the future, you may get better support if you ask on the STS forms page:
http://forum.springsource.org/forumdisplay.php?f=32

On Mon, Dec 21, 2009 at 7:30 PM, Ray Tayek <[hidden email]> wrote:

> hi, just imported a 1.0.0-M4 app into eclipse with the latest groovy plugin.
> no problems other than having to add the groovy libs to the project.
>
> trying the same thing with sts, it imports the grails app with no
> problems.but trying to do a create domain class from within sts complains
> about the version:
>
> Application expects grails version [1.2.0.RC2], but GRAILS_HOME is version
> [1.2-M4] - use the correct Grails version or run 'grails upgrade' if this
> Grails version is newer than the version your application expects.
>
> i do not have and environment variable for grails home. eclipse has a
> classpath variable. sts seems to not have this.
>
> so where is the 1.2-M4 coming from and how should i fix this?
>
> thanks
>
> ---
> co-chair http://ocjug.org/
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>   http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: grails home in eclipse and sts

Ray Tayek
At 08:24 PM 12/21/2009, you wrote:
>What do you have as your default grails install in Preferences ->
>Groovy -> Grails?

the old one :(

changing it. works fine now.

>Upon downloading STS, this may have been automatically configured for you.

yes

>In the future, you may get better support if you ask on the STS forms page:
>http://forum.springsource.org/forumdisplay.php?f=32

ok

thanks

>On Mon, Dec 21, 2009 at 7:30 PM, Ray Tayek <[hidden email]> wrote:
> > hi, just imported a 1.0.0-M4 app into eclipse with the latest
> groovy plugin.
> > no problems other than having to add the groovy libs to the project.
> >
> > trying the same thing with sts, it imports the grails app with no
> > problems.but trying to do a create domain class from within sts complains
> > about the version:
> >
> > Application expects grails version [1.2.0.RC2], but GRAILS_HOME is version
> > [1.2-M4] - use the correct Grails version or run 'grails upgrade' if this
> > Grails version is newer than the version your application expects.
> >
> > i do not have and environment variable for grails home. eclipse has a
> > classpath variable. sts seems to not have this.
> >
> > so where is the 1.2-M4 coming from and how should i fix this? ...

---
co-chair http://ocjug.org/



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email