unable to build with groovy-eclipse-compiler

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

unable to build with groovy-eclipse-compiler

Carr, Brian M
I've been having continued problems getting GMaven to generate valid stubs for my groovy code, so I decided to take the plunge and try out the groovy-eclipse-compiler.  I've downloaded the sample project from http://contraptionsforprogramming.blogspot.com/2010/10/more-on-groovy-eclipse-and-maven.html and I'm getting an artifact resolution failure.


its-app-mai133:groovy-eclipse-maven-tests bcarr$ mvn -U clean package
[INFO] Scanning for projects...
[INFO]                                                                        
[INFO] ------------------------------------------------------------------------
[INFO] Building Groovy-Eclipse and Maven can play nicely together! 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------

...
...
[WARNING] The POM for org.codehaus.groovy:groovy-eclipse-batch:jar:0.5.0 is missing, no dependency information available
Downloading: [central mirror]/org/codehaus/groovy/groovy-eclipse-batch/0.5.0/groovy-eclipse-batch-0.5.0.jar
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2.298s
[INFO] Finished at: Thu Apr 21 11:31:08 CDT 2011
[INFO] Final Memory: 6M/528M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.3.1:compile (default-compile) on project groovy-eclipse-maven-tests: Execution default-compile of goal org.apache.maven.plugins:maven-compiler-plugin:2.3.1:compile failed: Plugin org.apache.maven.plugins:maven-compiler-plugin:2.3.1 or one of its dependencies could not be resolved: Could not find artifact org.codehaus.groovy:groovy-eclipse-batch:jar:0.5.0 in [central mirror] -> [Help 1]



So you can see it's successfully finding groovy-eclipse-compiler from the maven.springsource.org/snapshots repo, but is unable to find groovy-eclipse-batch.  Is there another repo which needs to be defined for this to work?

--b
 
______________________________
Brian M. Carr
Identity and Access Management
ITS Applications
University of Texas at Austin
V: 512-232-6419
F: 512-471-5746
[hidden email]


smime.p7s (6K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: unable to build with groovy-eclipse-compiler

Andrew Eisenberg
This is a little odd because I am able to access the file myself.
This works for me:
http://maven.springsource.org/snapshots/org/codehaus/groovy/groovy-eclipse-batch/0.5.0/groovy-eclipse-batch-0.5.0.jar

A colleague of mine just mentioned that there was a major outage with
Amazon Web services, (we host greclipse releases on S3).  So, this
*may* have been affected:

http://slashdot.org/story/11/04/21/1515238/Major-Outage-At-the-Amazon-Web-Services

Could you try this again in an hour or two and let me know if it is working?


On Thu, Apr 21, 2011 at 9:33 AM, Carr, Brian M
<[hidden email]> wrote:

> I've been having continued problems getting GMaven to generate valid stubs for my groovy code, so I decided to take the plunge and try out the groovy-eclipse-compiler.  I've downloaded the sample project from http://contraptionsforprogramming.blogspot.com/2010/10/more-on-groovy-eclipse-and-maven.html and I'm getting an artifact resolution failure.
>
>
> its-app-mai133:groovy-eclipse-maven-tests bcarr$ mvn -U clean package
> [INFO] Scanning for projects...
> [INFO]
> [INFO] ------------------------------------------------------------------------
> [INFO] Building Groovy-Eclipse and Maven can play nicely together! 1.0-SNAPSHOT
> [INFO] ------------------------------------------------------------------------
>
> ...
> ...
> [WARNING] The POM for org.codehaus.groovy:groovy-eclipse-batch:jar:0.5.0 is missing, no dependency information available
> Downloading: [central mirror]/org/codehaus/groovy/groovy-eclipse-batch/0.5.0/groovy-eclipse-batch-0.5.0.jar
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 2.298s
> [INFO] Finished at: Thu Apr 21 11:31:08 CDT 2011
> [INFO] Final Memory: 6M/528M
> [INFO] ------------------------------------------------------------------------
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.3.1:compile (default-compile) on project groovy-eclipse-maven-tests: Execution default-compile of goal org.apache.maven.plugins:maven-compiler-plugin:2.3.1:compile failed: Plugin org.apache.maven.plugins:maven-compiler-plugin:2.3.1 or one of its dependencies could not be resolved: Could not find artifact org.codehaus.groovy:groovy-eclipse-batch:jar:0.5.0 in [central mirror] -> [Help 1]
>
>
>
> So you can see it's successfully finding groovy-eclipse-compiler from the maven.springsource.org/snapshots repo, but is unable to find groovy-eclipse-batch.  Is there another repo which needs to be defined for this to work?
>
> --b
>
> ______________________________
> Brian M. Carr
> Identity and Access Management
> ITS Applications
> University of Texas at Austin
> V: 512-232-6419
> F: 512-471-5746
> [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: unable to build with groovy-eclipse-compiler

Carr, Brian M
Hmm, your link still doesn't work as of 4:40 Central-US time.  I get a message similar to below.  However, I am able to browse to the files via http://s3browse.springsource.com/browse/maven.springframework.org/snapshot/org/codehaus/groovy/groovy-eclipse-batch/0.5.0/ and download them and put them in the right place for my local repository.  Hopefully s3 gets sorted soon.

<?xml version="1.0" encoding="UTF-8"?>
<Error><Code>NoSuchBucket</Code><Message>The specified bucket does not exist</Message><BucketName>maven.springsource.org</BucketName><RequestId>9EF487346BB87B3B</RequestId><HostId>7vP2c9zXs3FNBA1dg9HY7fxm2v7PCnY//gp9r+JThVW7LskLtjHTyoE4ApSQv/X2</HostId></Error>

thanks for the help,
--b
______________________________
Brian M. Carr
Identity and Access Management
ITS Applications
University of Texas at Austin
V: 512-232-6419
F: 512-471-5746
[hidden email]

On Apr 21, 2011, at 12:00 PM, Andrew Eisenberg wrote:

> This is a little odd because I am able to access the file myself.
> This works for me:
> http://maven.springsource.org/snapshots/org/codehaus/groovy/groovy-eclipse-batch/0.5.0/groovy-eclipse-batch-0.5.0.jar
>
> A colleague of mine just mentioned that there was a major outage with
> Amazon Web services, (we host greclipse releases on S3).  So, this
> *may* have been affected:
>
> http://slashdot.org/story/11/04/21/1515238/Major-Outage-At-the-Amazon-Web-Services
>
> Could you try this again in an hour or two and let me know if it is working?
>
>
> On Thu, Apr 21, 2011 at 9:33 AM, Carr, Brian M
> <[hidden email]> wrote:
>> I've been having continued problems getting GMaven to generate valid stubs for my groovy code, so I decided to take the plunge and try out the groovy-eclipse-compiler.  I've downloaded the sample project from http://contraptionsforprogramming.blogspot.com/2010/10/more-on-groovy-eclipse-and-maven.html and I'm getting an artifact resolution failure.
>>
>>
>> its-app-mai133:groovy-eclipse-maven-tests bcarr$ mvn -U clean package
>> [INFO] Scanning for projects...
>> [INFO]
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Building Groovy-Eclipse and Maven can play nicely together! 1.0-SNAPSHOT
>> [INFO] ------------------------------------------------------------------------
>>
>> ...
>> ...
>> [WARNING] The POM for org.codehaus.groovy:groovy-eclipse-batch:jar:0.5.0 is missing, no dependency information available
>> Downloading: [central mirror]/org/codehaus/groovy/groovy-eclipse-batch/0.5.0/groovy-eclipse-batch-0.5.0.jar
>> [INFO] ------------------------------------------------------------------------
>> [INFO] BUILD FAILURE
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Total time: 2.298s
>> [INFO] Finished at: Thu Apr 21 11:31:08 CDT 2011
>> [INFO] Final Memory: 6M/528M
>> [INFO] ------------------------------------------------------------------------
>> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.3.1:compile (default-compile) on project groovy-eclipse-maven-tests: Execution default-compile of goal org.apache.maven.plugins:maven-compiler-plugin:2.3.1:compile failed: Plugin org.apache.maven.plugins:maven-compiler-plugin:2.3.1 or one of its dependencies could not be resolved: Could not find artifact org.codehaus.groovy:groovy-eclipse-batch:jar:0.5.0 in [central mirror] -> [Help 1]
>>
>>
>>
>> So you can see it's successfully finding groovy-eclipse-compiler from the maven.springsource.org/snapshots repo, but is unable to find groovy-eclipse-batch.  Is there another repo which needs to be defined for this to work?
>>
>> --b
>>
>> ______________________________
>> Brian M. Carr
>> Identity and Access Management
>> ITS Applications
>> University of Texas at Austin
>> V: 512-232-6419
>> F: 512-471-5746
>> [hidden email]
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>


smime.p7s (6K) Download Attachment